-   Slackware (
-   -   Can't install lilo to MBR or floppy (

pele_smk 12-07-2003 12:07 PM

Can't install lilo to MBR or floppy
I've been trying to install lilo to the MBR for some time now and it never works. I was able to install lilo to a floppy, but I reinstalled my system and now I can't install Lilo anywhere. I run liloconfig and use the expert option. When I finally get to the option to install Lilo to "/boot" "MBR" or "Floppy" I choose floppy and it the light to the floppy drive comes on then within 3 seconds it goes off and liloconfig just stops. No error message or anything, it just spits back out to a #prompt. My goal is to install lilo to the MBR, but now I'm gonna have to be satisfied with just getting it installed on floppy. Any hlep would be appreciated. I'm running Slack 9.1 and have my winXp Pro Fat32 partion on the first partition of the harddrive and my slack on the remaining partitions. The drive is a 20gig drive. Hope someone can help.

2damncommon 12-07-2003 12:26 PM

Are you running lilo as root?
Maybe use the full path, "/sbin/lilo".
If the configuration is not correct Lilo will fail. Have you made any changes? Are there error messages?

pele_smk 12-07-2003 07:52 PM

No errors at all. I am also running lilo as root. When I run /sbin/lilo it hits my floppy and finds the currenty configuration. I need to install it to MBR though, and when I try to make another copy of the liloconfiguration onto a floppy it no longer lets me.

2damncommon 12-07-2003 09:15 PM

You may want to post your lilo.conf and your hard drive partitions.

/bin/bash 12-09-2003 04:45 PM


I need to install it to MBR though
What happens when you choose MBR?

pele_smk 12-10-2003 02:25 PM

my lilo.conf
Here is my lilo.conf

# LILO configuration file
# generated by 'liloconfig'
# Start LILO global section
boot = /dev/fd0
message = /boot/boot_message.txt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# DOS bootable partition config begins
other = /dev/hdc1
label = DOS
table = /dev/hdc
# DOS bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hdc6
label = Linux
# Linux bootable partition config ends

pele_smk 12-10-2003 03:08 PM

YIPPPPPPPYYYYY IT works. I didn't do anything different. I ran liloconfig and said to recycle existing lilo.conf. I only changed the names from DOS to WINXP and so on and it worked. I'm not sure why it decided to work today after all this work. Thanks for your help. Even though you didn't solve the problem you kept me persistent. Thanks!

apathas 12-10-2003 05:46 PM

yeah for some reason lilo is flaky sometimes.
i had one install where only way I could get it to update was to type lilo -v.
Never did figure out why.

All times are GMT -5. The time now is 05:35 PM.