-   Slackware (
-   -   can't execute KDE programs on Slackware64 14 (

BoydRice 07-03-2013 11:40 PM

can't execute KDE programs on Slackware64 14
Hi All,

I was trying out Alien Bob's new KDE packages and decided I would rather downgrade and stick with what is provided in Slackware64 14. after removing those packages and the deps and then re-installing the KDE packages that come with the stable release I am unable to run them. I figured I must have done something wrong so I made sure to run slackpkg clean-system having it ignore the packages I built with sbopkg, and then I ran slackpkg reinstall slackware64. However that doesn't seem to have fixed it. Trying to launch a KDE program from the terminal returns this message:


konsole: error while loading shared libraries: cannot open shared object file: No such file or directory
Would anyone be so kind as to let me know what I may have done wrong? It isn't a huge deal as I am comfortable in Xfce or Fluxbox, but now I am just curious about how to fix it.

mancha 07-04-2013 12:50 AM

Try re-installing the qt package (in l).

Alien Bob 07-04-2013 04:53 AM

I think you need to re-install more than just Qt.
If you look at the dependencies which you had to upgrade as part of the KDE 4.10.5 series, there are several other packages besides qt:

You should get a copy of the original Slackware64-14.0 versions of these packages and then run "upgradepkg *.t?z" on them which will replace my updated versions with the originals (remember, upgradepkg can upgrade just as easily as downgrade a package version).


BoydRice 07-04-2013 12:12 PM

Thanks to you both. I misunderstood the use of slackpkg reinstall slackware64, I thought it would pull in all packages from a full Slackware 14 install. I went and installed qt and then used slackpkg install l and it installed missing pieces for KDE like virtuoso and soprano etc. My KDE apps now execute but I will go back and explicitly check that all the deps packages are updated. Thanks again, should have read the slackpkg man page better.

All times are GMT -5. The time now is 07:50 PM.