-   Slackware (
-   -   Can't compile webkitgtk from SlackBuild - ideas? (

andreas-r 01-27-2013 10:17 AM

Can't compile webkitgtk from SlackBuild - ideas?
I can't compile webkitgtk from the SlackBuild script.

This is the log from when I tried installing it with sbopkg:


GEN    DerivedSources/ANGLE/glslang.cpp
  GEN    DerivedSources/ANGLE/glslang_tab.cpp
  GEN    DerivedSources/WebCore/JSRequestAnimationFrameCallback.h
  GEN    DerivedSources/WebCore/JSHTMLShadowElement.h
make  all-am
make: *** [all] Killed

Would you like to continue processing the rest of the
queue or would you like to abort?  If this failed
package is a dependency of another package in the queue
then it may not make sense to continue.

(Y)es to continue, (N)o to abort, (R)etry the build?: n

Using the SBo repository for Slackware 14.0
Queue Process:  Download, build, and install

  MD5SUM check for webkit-1.8.3.tar.xz ... OK
  Error occurred with build.  Please check the log.

I've also tried running the script directly without sbopkg. It doesn't give errors but ends abruptly with a line somewhat like this (couldn't find log from that so this is from memory):


make[3]: Leaving directory `/tmp/SBo/webkit-1.8.3'
Both methods takes hours before terminating, 5-7 hours approximately.

The readme doesn't mention anything to be aware of.

I've suspected that it might have to do with my installing multilib so I reverted back (as I didn't need it anyway) with

compat32pkg --remove all
and upgrading glibc and gcc with the slackware stock packages.

Any ideas on what's wrong?

ponce 01-27-2013 01:08 PM

how much ram and swap do you have on the machine you are trying to build it? you can check it with "free -m".
it can be it fails because it doesn't have enough ram available (a wild guess from the "Killed" in the sbopkg log).

andreas-r 01-27-2013 02:48 PM

Thanks for replying, ponce. You could be on to something. Forgot to mention it but I'm running Slackware on VirtualBox. Doing a similar task earlier I got an error saying there wasn't enough virtual memory so I raised the the memory allowed for the Virtual SlackWare Machine from 1 to about 2 GB. These were the settings when i tried compiling the mention program. Don't got any swap on my VirtualBox though:


root@duk:~# free -m
            total      used      free    shared    buffers    cached
Mem:          1814        782      1032          0        61        337
-/+ buffers/cache:        383      1431
Swap:            0          0          0

Didn't think much about it but assumed that the swap partition from my host system would be virtualized. I'll try setting up a swap partition and try again.


ponce 01-27-2013 02:56 PM

I think that with 2Gb of RAM, in this case a 2Gb swap should be enough.

gnashley 01-27-2013 02:58 PM

You probably need more than 1GB of free disk space and/or RAM and/or swap to build such a package. I know that building seamonkey/FF can easily need more than 1GB.

ponce 01-27-2013 03:02 PM

yupz, firefox needs 6 Gb of free ram here during build (slackware64-current).

andreas-r 01-27-2013 03:09 PM

The lack of swap is definitely it then. What SlackWare default software can I use to resize partition and create swap partition. As I recall Fdisk can't resize ...

ponce 01-27-2013 03:34 PM

you shouldn't need it, you can use a file as swap: create it (count is targeted for 1024*2048 - 2Gb)

dd if=/dev/zero of=/swapfile1 bs=1024 count=2097152
chmod 0600 /swapfile1
mkswap /swapfile1

and use it

swapon /swapfile1
you can also add it to /etc/fstab

echo "/swapfile1 swap swap defaults 0 0" >> /etc/fstab
so you have it also after a reboot.

andreas-r 01-28-2013 03:25 AM

With swap the script worked. Thanks! By the way: is it normal for SlackBuild script to take several hours?

willysr 01-28-2013 05:05 AM

Yes, i have experienced a day compiling a package :)

gnashley 01-28-2013 05:22 AM

It depends on what software -some build scripts will run in less than thirty seconds, while some might need thirty *hours* for a big project on a slow machine.

brianL 01-28-2013 08:58 AM

I might be in trouble. I'm building Midori on my Raspberry Pi, using an sbopkg queuefile, and it's partly through WebKit at this moment. :eek:
:) Fingers crossed.
If it fails, ponce has a ready made package.
Wondering if I should stop the build with Ctrl C, and install a package. :scratch:

All times are GMT -5. The time now is 11:15 AM.