-   Slackware (
-   -   Can't compile kmymoney-4.6.3 (

neymac 07-16-2013 08:32 AM

Can't compile kmymoney-4.6.3
After upgrade to kde-4.10.5 (alienbob's one) I can't compile kmymoney-4.6.3, before the upgrade I did, but now as I need import ofx files I installed libofx, when I tried run the kmymoney.SlackBuild it complains "CMake 2.8.9 or higher is required. You are running version 2.8.8", but the slackware64-14.0 uses CMake 2.8.8. To try resolve this issue I did install CMake 2.8.10 using the cmake.slackbuild from slackware-current, and it did not complained anymore, but did not compile, stopping after 80% of the task. As I didn't know wich damage the upgrade of cmake would cause I restored the Slackware-14.0 version. I ask if is there any problem using cmake 2.8.10 with slackware64-14.0? Does anyone have kmymoney-4.6.3 package with ofx enabled for slackware64-14.0?:scratch:

neymac 07-16-2013 10:50 AM

I did another test using CMake 2.8.11 and after 80% running kmymoney.slackbuild I got the following error:

/tmp/SBo/kmymoney-4.6.3/kmymoney/mymoney/storage/mymoneydatabasemgrtest.cpp: In member function ‘void MyMoneyDatabaseMgrTest::testCreateDb()’:
/tmp/SBo/kmymoney-4.6.3/kmymoney/mymoney/storage/mymoneydatabasemgrtest.cpp:92:44: error: ‘geteuid’ was not declared in this scope
make[2]: ** [kmymoney/mymoney/storage/CMakeFiles/mymoneydatabasemgrtest.dir/mymoneydatabasemgrtest.cpp.o] Error 1
I'd like some clue to solve this.

WhiteWolf1776 07-16-2013 11:57 AM

According to this thread... some troubles with kmymoney and kde 4.10. This thread suggests the repo version of kmymoney compiles properly tho.

so you may need to pull from there and bump the slackbuild script version, etc.

neymac 07-16-2013 01:39 PM

@WhiteWolf1776: Thank you very much, it worked. I git cloned it from " git clone git://", rename the folder to kmymoney-4.6.3, compressed the folder with tar, changed the name to kmymoney-4.6.3.tar.bz2 and run the slackbuild as it was, it compiled to the end and run with the ofx that I wanted, the only problem was the language, it is in english instead of my native language, but I think it's not big deal to solve (I guess).

neymac 07-16-2013 03:14 PM

@WhiteWolf1776: OK, now kmymoney is set to my native language, I'd just add the kmymoney.po file and run msgfmt kmymoney.po -o LC_MESSAGES/ Once more thank you!:cool:

All times are GMT -5. The time now is 05:40 PM.