-   Slackware (
-   -   Can't browse/surf but transmission downloads. (

Laxman_prodigy 09-06-2012 07:29 AM

Can't browse/surf but transmission downloads.
So, suddenly while browsing, it got very very slow accessing the webpages and started failing totally. Its Slackware 13.37 and the browsers are mozilla and opera. While Opera kept on opening pages later before the mozilla died on it. I can play Urban terror online with no problem. I have always used dhcpcd way to connect to the web. I am posting this from the Windows partition since its a dual boot and I kept it for the times like these.

I have tried to kill dhcpcd and re-run it with /sbin/dhcpcd. It forkes itself to the background, like the way it says. And the same story. No net browsing. I tried lynx to open google. It fails again. I am quite new to Slackware but have gotten that far from where I have become quite competent enough to troubleshoot any problems and hiccups with the great help of you guys.

Any info I should provide?


P.S And the browsing is fine with Windows 7.

WetDreams 09-06-2012 08:34 AM

Could be a DNS issue. Can you access websites by typing the IP instead of the domain name?

Laxman_prodigy 09-06-2012 08:56 AM

Hi WetDreams.

I understand what you mean but how do I know the IP address of sites I am browsing?! Still posting here from Windows installation coz its fine here. And it was fine under slackware too until recently. I have ran into no net issues until now. All I have been doing is running /sbin/dhcpcd as root sometimes polling used to cross the polling time limit while booting.

ChrisAbela 09-06-2012 09:08 AM

Send the results of the

# ping


# route


# ifconfig -a


# tcpdump -v -i eth0

commands and the contents of /etc/resolve.conf

Note that on Slackware you should also have dhclient, try it.

ChrisAbela 09-06-2012 09:10 AM

Are you behind any firewalls?

business_kid 09-06-2012 09:26 AM

dhcpcd rewrites /etc/resolv.conf, which is a PITA, because if your router doesn't supply sensible dns servers, you end up with something like router) as dns :-/.

There is /etc/resolv.conf.head, which is a top for the new resolv.conf, and /etc/resolv.conf.tail, which is a bottom. I have opendns in the 'head file, so i see that. Also, if you pepper the RC scripts with DHCP_KEEPRESOLV="true" (rc.inet1.conf & rc.wireless.conf) it helps, although they still get overwritten occasionally :-/.

Laxman_prodigy 09-06-2012 09:54 AM

Hi everyone..

I'm not behind any firewalls. I will try the commands given and post the results soon. It seems that I can ping the sites and the lynx works too,just not the GUI browsers.I even tried installing opera through wine and it worked for a while but soon it failed too.

Laxman_prodigy 09-06-2012 10:14 AM


here are the outputs....


bash-4.1$ ping
PING ( 56(84) bytes of data.
64 bytes from ( icmp_req=1 ttl=53 time=54.7 ms
64 bytes from ( icmp_req=2 ttl=53 time=56.0 ms
64 bytes from icmp_req=3 ttl=53 time=54.2 ms
[1]+  Stopped                ping

root@valleyofpeace:~# route
Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface    *      U    202    0        0 eth0
loopback        *          U    0      0        0 lo
default        UG    202    0        0 eth0

root@valleyofpeace:~# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:27:0e:09:e3:ee 
          inet addr:  Bcast:  Mask:
          RX packets:273 errors:0 dropped:0 overruns:0 frame:0
          TX packets:424 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:185069 (180.7 KiB)  TX bytes:45613 (44.5 KiB)
          Interrupt:20 Memory:f4200000-f4220000

lo        Link encap:Local Loopback 
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:200 (200.0 B)  TX bytes:200 (200.0 B)

root@valleyofpeace:~# tcpdump -v -i eth0
tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 65535 bytes
19:30:59.898285 IP (tos 0x0, ttl 64, id 9660, offset 0, flags [DF], proto UDP (17), length 59) > 39312+ A? (31)
19:30:59.898837 IP (tos 0x0, ttl 64, id 19667, offset 0, flags [DF], proto UDP (17), length 72)
[1]+  Stopped                tcpdump -v -i eth0

Contents in /etc/resolve.conf:

# Generated by dhcpcd from eth0
# /etc/resolv.conf.head can replace this line
# /etc/resolv.conf.tail can replace this line

ChrisAbela 09-06-2012 10:22 AM

You do not need wine for Opera. It is possible to install it via a Slackware package created by a slackbuild from I recommend uninstalling mozilla-firefox and re-installing via slackpkg.

Laxman_prodigy 09-06-2012 10:54 AM

I meant to say that I even tried through wine,I already had opera installed through slackbuilds but it wasn't working so I removed it. I had mozilla too from the slackbuilds.I have again installed opera through slackbuild as I had the build already in my Downloads.The problem is no matter what browser I install I can't surf. I can ping,can download through bittorrent,play online but just can't browse!It sometimes used to happen in windows too and I used to manually change IP addresses and it used to work,though I've currently put it to automatic IP setting and its working nonetheless. And what about the outputs I posted? Any clues there?

Laxman_prodigy 09-06-2012 01:45 PM

Hey guys...I resolved the issue. It seems like a DNS issue. I had to edit the /etc/rc.d/rc.inet1.conf and put the IPs,mask and gateway manually and I disabled DHCP too. I also gave the DNS name servers in the resolv.conf manually and restarted the rc.inet1. And now its working fine. Thanks for the support.

ChrisAbela 09-06-2012 02:44 PM

I am glad you resolved it (practically on your own).

Laxman_prodigy 09-07-2012 02:41 AM

Not without the tips here! :D

All times are GMT -5. The time now is 03:06 AM.