LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 11-29-2006, 06:59 AM   #1
todders
Member
 
Registered: Nov 2006
Location: watford
Distribution: Slackware 13 64Bit Multi-Lib KDE4.2.4
Posts: 83

Rep: Reputation: 18
Cannot write to usb stick as normal user


Hello currently using slackware 11.0,i have managed through the excellent guides on here to succesfully mount my usb stick and acess the device but cannot create any new folders or write to the stick,i believe it must be a permission problem somewehre,i have included my fstab output here,iam sure it is something so easy...

/dev/hda1 / ext3 defaults 1 1
/dev/hda3 /home ext3 defaults 1 2
/dev/sda1 /mnt/usb vfat defaults 1 0
/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0



many thanks

adrian

Last edited by todders; 11-29-2006 at 07:17 AM.
 
Old 11-29-2006, 07:12 AM   #2
odcheck
Member
 
Registered: Aug 2006
Distribution: Fedora, CentOS, RHEL, Debian
Posts: 977

Rep: Reputation: 30
can't you write as root or as user?
check with chmod for the permissions.
And do you really want to include it into /etc/fstab ?

What happens if you mount it as root
like
Code:
mount -t vfat /dev/sda1 /mnt/usb
 
Old 11-29-2006, 07:15 AM   #3
todders
Member
 
Registered: Nov 2006
Location: watford
Distribution: Slackware 13 64Bit Multi-Lib KDE4.2.4
Posts: 83

Original Poster
Rep: Reputation: 18
Cannot write to usb stick

hello i can access the device and write to as root but not as a normal user...

regards

adrian
 
Old 11-29-2006, 07:19 AM   #4
The_Outlander
Member
 
Registered: Aug 2004
Location: Australia
Distribution: Slackware 12.1
Posts: 235

Rep: Reputation: 30
Quote:
/dev/hda1 / ext3 defaults 1 1
/dev/hda3 /home ext3 defaults 1 2
/dev/sda1 /mnt/usb vfat defaults 1 0
/dev/cdrom /mnt/cdrom auto noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0
There may be better ways to acheive this, but changing the /dev/sda1 line as below will give you access.
Quote:
/dev/sda1 /mnt/usb vfat noauto,users,rw 0 0
You can do the same with the /dev/fd0 line by replacing owner with users and also /dev/cdrom, except it remains ro.

This will give you access from the desktop, with a mouse click or two on the relevant icon. The device should mount. Otherwise mount it as user.

Last edited by The_Outlander; 11-29-2006 at 07:23 AM.
 
Old 11-29-2006, 07:36 AM   #5
todders
Member
 
Registered: Nov 2006
Location: watford
Distribution: Slackware 13 64Bit Multi-Lib KDE4.2.4
Posts: 83

Original Poster
Rep: Reputation: 18
Quote:
Originally Posted by The_Outlander
There may be better ways to acheive this, but changing the /dev/sda1 line as below will give you access.

You can do the same with the /dev/fd0 line by replacing owner with users and also /dev/cdrom, except it remains ro.

This will give you access from the desktop, with a mouse click or two on the relevant icon. The device should mount. Otherwise mount it as user.
Many thanks for your reply...

i have tried this and it will let me acess the drive as a user but still cannot write to the device as user,i can when iam in root though so it is not a major problem but one i would like to sort out..

regards

adrian
 
Old 11-29-2006, 07:43 AM   #6
The_Outlander
Member
 
Registered: Aug 2004
Location: Australia
Distribution: Slackware 12.1
Posts: 235

Rep: Reputation: 30
Ah, I see.
#chmod 777 /dev/sda1

Gives global permissions. You should be able to write to it with this.
 
Old 11-29-2006, 08:01 AM   #7
todders
Member
 
Registered: Nov 2006
Location: watford
Distribution: Slackware 13 64Bit Multi-Lib KDE4.2.4
Posts: 83

Original Poster
Rep: Reputation: 18
excellent this now works many thanks it is much appreciated
 
Old 11-29-2006, 08:15 AM   #8
The_Outlander
Member
 
Registered: Aug 2004
Location: Australia
Distribution: Slackware 12.1
Posts: 235

Rep: Reputation: 30
Keeping in mind that it is accessible to everyone.
Now you know it works, a more restrictive set of permissions might be more appropriate.

#chmod 755 /dev/sda1
 
Old 11-29-2006, 03:37 PM   #9
todders
Member
 
Registered: Nov 2006
Location: watford
Distribution: Slackware 13 64Bit Multi-Lib KDE4.2.4
Posts: 83

Original Poster
Rep: Reputation: 18
thank you for that have used your last set of commands now much appreciated...

thanks

adrian
 
  


Reply

Tags
dongle


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to read/write usb 256mb memory stick Aju Linux - Hardware 13 03-09-2009 03:24 AM
USB Stick on Debian-Etch 2.4, write is disabled SlackerLX Linux - Hardware 12 10-08-2005 01:41 AM
USB Stick reads but won't write jaws_tas Linux - Hardware 3 09-23-2005 12:36 AM
Can't WRITE to USB stick, Mount OK NO WRITE! ClericPreston Linux - Newbie 4 12-04-2004 10:43 AM
write protect freezes my usb stick db391 Linux - Hardware 3 09-25-2004 04:43 AM


All times are GMT -5. The time now is 11:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration