LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-04-2007, 07:06 PM   #1
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 3,191

Rep: Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938
cannot (un)set powersave mode


I recently rebooted my machine, and usually when I am under an x-windows session, I have it set not to use any kind of power save feature for my monitor. I do not have the DPMS option in xorg.conf, and I made sure that rc.acpid would not load (chmod -x) and commented out the setterm option in rc.M. So after about 15 minutes, my screen goes blank still, so I also made sure that xset s off was in my .xinitrc, so now thats taken care of, and still my screen goes blank.

I then decide to try this command while in my x-windows session:
Code:
setterm -blank 0
After a while, still it goes blank, so I decide to exit to a CLI, and do the following as root:
Code:
root@slackuser:/home/slackuser# setterm -blank 0 -powesave off -append
Ok, so the command works, so I go back into x-windows, and yet it goes blank again, so I try the same command as root (su), in xterm, but then I get a different result:

Code:
root@slacker:/home/slackuser# setterm -blank 0 -powersave off -append
cannot (un)set powersave mode
root@slacker:/home/slackuser#
Now what!? I made sure acpi/apm were not loading, why is it still going blank, and what should I try next?
 
Old 09-04-2007, 10:43 PM   #2
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,367

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
I was getting annoyed with that problem as well until I solved it recently (I don't remember where I found the solution, but it required much googling). I don't know if this will solve your problem, but I added the following to my /etc/X11/xorg.conf file, immediately after the
Code:
Section "Module"
...
...
EndSection
and before the
Code:
Section "InputDevice"
Here it is:
Code:
Section "ServerFlags"
    Option         "blank time" "0"
    Option         "standby time" "0"
    Option         "suspend time" "0"
    Option         "off time" "0"
EndSection
Hope that helps (if not, sorry...)
 
Old 09-05-2007, 08:11 PM   #3
Jeebizz
Senior Member
 
Registered: May 2004
Distribution: Slackware14.2 64-Bit Desktop, Devuan 2.0 ASCII Toshiba Satellite Notebook
Posts: 3,191

Original Poster
Rep: Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938Reputation: 938
Thumbs up

That worked exactly the way I needed, thanks!
 
Old 09-05-2007, 09:08 PM   #4
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,367

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Glad I could help! Now you can adjust everything via KDE's power management settings (if you use KDE) if you want and it will actually work.
 
Old 09-06-2007, 09:44 PM   #5
T3slider
Senior Member
 
Registered: Jul 2007
Distribution: Slackware64-14.1
Posts: 2,367

Rep: Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841Reputation: 841
Apparently the root of the problem is /etc/rc.d/rc.M, as explained in this (new) post:
http://www.linuxquestions.org/questi...d.php?t=582748

Basically, undo my solution and use the new one -- this avoids overriding a setting and instead undoes the root of the problem. Sorry for the bad advice!

[edit]I just reread your first post and saw that you already commented out the line in rc.M. Never-mind then...[/edit]

Last edited by T3slider; 09-06-2007 at 09:45 PM.
 
Old 09-17-2008, 05:49 AM   #6
xockes
LQ Newbie
 
Registered: Sep 2008
Posts: 1

Rep: Reputation: 0
Thumbs up Thanks from a Eee PC 701 Xandros user

Thanks T3Slider. I just want to post it here so people googling the same problem can find a solution to a crazy set up in the Eee PC.

Suppose you want to set an Eee PC to display a little presentation with its characteristics, price and goodies. Well guess what, every 20 mins. it will blank the screen. This is the only solution to the problem I have found that works.

Again

Linux Eee PC 701 Xandros and Blank Screen Off, the rest of the key words can be found easily in your posts. Thanks a lot.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
iwconfig mode monitor Error: "Set Mode" (8B06) WOP1337 Linux - Wireless Networking 2 04-03-2007 08:13 AM
Can't set video mode? wazntme Linux - Newbie 1 10-27-2005 08:20 PM
Can't set mode, essid or ap Biggus Linux - Wireless Networking 8 03-19-2005 08:26 AM
why can't i set udma mode 2? jogurt666 Linux - General 1 08-29-2004 09:33 AM
Powersave Mode sacsjohn Linux - Newbie 1 03-07-2003 10:38 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration