LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-26-2016, 11:13 PM   #1
Freaksta
Member
 
Registered: Jan 2003
Distribution: Slackware 14.1
Posts: 281

Rep: Reputation: 33
Cannot type with Logitech wireless keyboard with Luks + LVM boot


Hello friends!

Code:
T:  Bus=01 Lev=01 Prnt=01 Port=04 Cnt=01 Dev#=  2 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
P:  Vendor=046d ProdID=c52b Rev=12.03
S:  Manufacturer=Logitech
S:  Product=USB Receiver
C:  #Ifs= 3 Cfg#= 1 Atr=a0 MxPwr=98mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=01 Driver=usbhid
I:  If#= 1 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=01 Prot=02 Driver=usbhid
I:  If#= 2 Alt= 0 #EPs= 1 Cls=03(HID  ) Sub=00 Prot=00 Driver=usbhid
As you can see, the logitech receiver is using usbhid module.

Code:
mkinitrd -c -k 4.4.14 -m ext4:usbhid:usb:ehci_hcd:ohci-hcd:uhci-hcd:hid:hid-logitech-dj:hid-logitech-hidpp -f ext4 -r /dev/cryptvg/root -C /dev/sda2 -L
My initrd contains the usbhid driver, and yet when luks is prompting me for my password, I am unable to use the wireless keyboard to type.

Any suggestions?

Last edited by Freaksta; 08-26-2016 at 11:15 PM.
 
Old 08-26-2016, 11:28 PM   #2
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware -current 32bit!
Posts: 537

Rep: Reputation: 202Reputation: 202Reputation: 202
Can you show us your
Code:
 cat /etc/lilo.conf
and your
Code:
ls /boot
 
Old 08-27-2016, 12:02 AM   #3
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,068

Rep: Reputation: 1453Reputation: 1453Reputation: 1453Reputation: 1453Reputation: 1453Reputation: 1453Reputation: 1453Reputation: 1453Reputation: 1453Reputation: 1453
Do you have /usr on a different partition from /?
 
Old 08-27-2016, 03:29 AM   #4
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,044

Rep: Reputation: 150Reputation: 150
Do you have hid-generic in /boot/initrd-tree/load_kernel_modules?
 
Old 08-27-2016, 05:57 AM   #5
phi11ip
Member
 
Registered: Jul 2007
Location: Nottingham, UK
Distribution: Slackware64-current
Posts: 93

Rep: Reputation: 23
Had a very similar problem with my Logitech keyboard and mouse, was not able to log in to KDE via SDDM. Turned out to be interference from the motherboard as the nano receiver is so close to the case. You could try different usb 2 port (Logitech unifying receivers don't work on usb 3). What worked for me was a male to female extender cable keeping the receiver away from the motherboard. Also as a temporary solution try moving the keyboard to different positions.
 
1 members found this post helpful.
Old 08-27-2016, 07:50 AM   #6
Freaksta
Member
 
Registered: Jan 2003
Distribution: Slackware 14.1
Posts: 281

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by STDOUBT View Post
Can you show us your
Code:
 cat /etc/lilo.conf
and your
Code:
ls /boot
Code:
chooser=simple
delay=1
timeout=1
#
image=vmlinuz
	initrd=initrd.gz
        label=Slackware
        read-only
        append="root=/dev/cryptvg/root vga=normal ro"
bash-4.3$
b
Code:
ash-4.3$ ls /boot
README.initrd		   elilo-ia32.efi    slack.bmp
System.map		   elilo-x86_64.efi  tuxlogo.bmp
System.map-generic-4.4.14  grub		     tuxlogo.dat
System.map-huge-4.4.14	   initrd-tree	     vmlinuz
coffee.dat		   initrd.gz	     vmlinuz-generic
config			   inside.bmp	     vmlinuz-generic-4.4.14
config-generic-4.4.14	   inside.dat	     vmlinuz-huge
config-huge-4.4.14	   onlyblue.bmp      vmlinuz-huge-4.4.14
efi			   onlyblue.dat
bash-4.3$
 
Old 08-27-2016, 07:50 AM   #7
Freaksta
Member
 
Registered: Jan 2003
Distribution: Slackware 14.1
Posts: 281

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by Richard Cranium View Post
Do you have /usr on a different partition from /?
Nope
 
Old 08-27-2016, 07:51 AM   #8
Freaksta
Member
 
Registered: Jan 2003
Distribution: Slackware 14.1
Posts: 281

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by guanx View Post
Do you have hid-generic in /boot/initrd-tree/load_kernel_modules?
nano 2.6.0 File: /boot/initrd-tree/load_kernel_modules

# This is a script used to load the kernel modules.
# To use it, chmod it 755, and then add the insmod
# lines needed to load your modules, like this:

modprobe -v jbd2
modprobe -v mbcache
modprobe -v ext4
modprobe -v hid
modprobe -v usbhid
modprobe -v ehci-hcd
modprobe -v ohci-hcd
modprobe -v uhci-hcd
modprobe -v hid-logitech-dj
modprobe -v hid-logitech-hidpp

Last edited by Freaksta; 08-27-2016 at 07:53 AM.
 
Old 08-27-2016, 10:19 AM   #9
guanx
Senior Member
 
Registered: Dec 2008
Posts: 1,044

Rep: Reputation: 150Reputation: 150
Quote:
Originally Posted by Freaksta View Post
nano 2.6.0 File: /boot/initrd-tree/load_kernel_modules

# This is a script used to load the kernel modules.
# To use it, chmod it 755, and then add the insmod
# lines needed to load your modules, like this:

modprobe -v jbd2
modprobe -v mbcache
modprobe -v ext4
modprobe -v hid
modprobe -v usbhid
modprobe -v ehci-hcd
modprobe -v ohci-hcd
modprobe -v uhci-hcd
modprobe -v hid-logitech-dj
modprobe -v hid-logitech-hidpp
Then put hid-generic into /etc/mkinitrd.conf and run mkinitrd once more.
 
Old 08-27-2016, 10:37 AM   #10
Freaksta
Member
 
Registered: Jan 2003
Distribution: Slackware 14.1
Posts: 281

Original Poster
Rep: Reputation: 33
# This is a script used to load the kernel modules.
# To use it, chmod it 755, and then add the insmod
# lines needed to load your modules, like this:

modprobe -v jbd2
modprobe -v mbcache
modprobe -v ext4
modprobe -v hid
modprobe -v usbhid
modprobe -v ehci-hcd
modprobe -v ohci-hcd
modprobe -v uhci-hcd
modprobe -v hid-logitech-dj
modprobe -v hid-logitech-hidpp
modprobe -v hid-generic

still not working
 
Old 08-27-2016, 03:07 PM   #11
STDOUBT
Member
 
Registered: May 2010
Location: Stumptown
Distribution: Slackware -current 32bit!
Posts: 537

Rep: Reputation: 202Reputation: 202Reputation: 202
Freaksta,
If you're sure you built your initrd.gz against a certain kernel (in this case it seems it should have been vmlinuz-generic-4.4.14), then either make sure "/boot/vmlinuz" is in fact a link to vmlinuz-generic-4.4.14, or, change your line in lilo.config from
Code:
image=vmlinuz
to
Code:
image=/boot/vmlinuz-generic-4.4.14
I get the sense there is some kind of mis-match happening.
As always, after any change to /etc/lilo.conf, run "lilo".
Also, did you in fact
Code:
chmod 755 /boot/initrd-tree/load_kernel_modules
?
 
Old 09-18-2016, 02:42 PM   #12
number22
Member
 
Registered: Sep 2006
Location: Earth
Distribution: Slackware 14.1 Slackware64-current multilib
Posts: 278
Blog Entries: 7

Rep: Reputation: Disabled
you need add these modules into mkinitrd.

ehci-platform
ehci-pci
ohci-platform
ohci-pci
 
Old 09-21-2016, 12:28 AM   #13
michaelslack
Member
 
Registered: Feb 2013
Location: Sydney
Distribution: slackware
Posts: 110

Rep: Reputation: 36
I had a similar problem years ago. I remember adding various modules until it worked. The text below is (a relevant snippet from) the mkinitrd command I used:

Code:
mkinitrd -c -k 3.10.17 -f ext4 -r /dev/cryptvg/root -m hid_generic:usb-storage:xhci-hcd:ehci-hcd:ehci-pci:mbcache:jbd2:ext4:hid-logitech-dj:hid-microsoft:uhci-hcd:usbhid
There are a few there that you don't seem to have included: xhci-hcd, ehci-pci. It can't hurt to try adding those.

The other thing you can try to do is run

Code:
lsmod
when the logitech keyboard is plugged in (assuming you can log in with a different keyboard and then switch over to the logitech one) and see which modules are being used.

Cheers,

Michael
 
Old 01-02-2017, 03:43 PM   #14
Freaksta
Member
 
Registered: Jan 2003
Distribution: Slackware 14.1
Posts: 281

Original Poster
Rep: Reputation: 33
This is working from a -m module's loaded list:


Code:
nvme:xhci-pci:ohci-pci:ehci-pci:xhci-hcd:uhci-hcd:ehci-hcd:hid:usbhid:i2c-hid:hid_generic:hid-cherry:hid-logitech:hid-logitech-dj:hid-logitech-hidpp:hid-lenovo:hid-microsoft:hid_multitouch:jbd2:mbcache:ext4

Last edited by Freaksta; 01-02-2017 at 03:45 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Boot Failure Luks on LVM qombi Linux - Server 2 01-10-2016 11:05 AM
[SOLVED] Partitioning for (U)EFI, LVM and LUKS, maybe dual boot later gargamel Linux - General 7 07-15-2015 04:58 PM
How to set up custom boot backgrounds from boot to login with LVM and LUKS? spudzy Linux - Software 1 10-09-2014 10:03 AM
[SOLVED] lilo: dual boot luks with lvm BashTin Slackware 4 07-17-2014 07:54 AM
LUKS LVM with usb token at boot mrmnemo Ubuntu 3 02-26-2011 09:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration