LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 01-16-2005, 03:35 PM   #1
grimlaur
LQ Newbie
 
Registered: Jan 2005
Location: West Palm Beach, Florida
Distribution: Slackware 11.0 / Suse 10.1
Posts: 20

Rep: Reputation: 0
Cannot See info.php in Apache 1.3.33 Slack 10


Hello everybody

I have tried everything possible to view a .php file but the window stays white.

I followed the instructions from Shilo's servin' web sites, I have seen the Apache Hey, it worked.. The SSL/TLS.... Screen..

I had to manuallly add the LoadModule php4_module libexec/apache/libphp4.so line as well as AddModule mod_php4.c

When I start and stop the server I get an error of {warn} module php4 is already loaded, skipping.

Question: does the fact that i had to manually add these lines mean that my PHP was not configured correctly?

My apache error log says:

[error] PHP warning: Unknown (/var/www/htdocs/info.php) Failed to open stream: permission denied in Unknown on line 0

[error] PHP warning: (null) (): Failed Opening '/var/www/htdocs/info.php' for inclusion (include_path= ".:/usr/lib/php') in unknown on line 0

Question is this refering to the php.ini file or am i lost? and if yes what do i do?

any help would be greatly appreciated

I can say that lynx http://localhost -dump -head | grep server
== Server: Apache 1.3.33 (unix) PHP/4.3.10
and this is slackware 10.0

thanks Grimlaur
 
Old 01-16-2005, 03:43 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
You will need to give the user you are running apache as (probably apache or nobody) read access to that file and read/execute access to its directory. What are the permissions on the file:
ls -la /var/www/htdocs/
 
Old 01-16-2005, 04:06 PM   #3
grimlaur
LQ Newbie
 
Registered: Jan 2005
Location: West Palm Beach, Florida
Distribution: Slackware 11.0 / Suse 10.1
Posts: 20

Original Poster
Rep: Reputation: 0
David

Ah...

The one thing the ex- windows user forgets about.... permissions silly me....

chmod 755

I am embarrassed. Got a smiley for this one?

Thanks so much for the help i greatly appreciate it.



I can see clearly now the rain is gone and once again a wunderfull newbie post has ended.

this is grimlaur... signing off





 
Old 02-05-2005, 04:27 PM   #4
bato
Member
 
Registered: Nov 2004
Distribution: Slackware 10.2
Posts: 32

Rep: Reputation: 15
kernel 2.6.10

How to enable agpgrep module in kernel 2.6.10?Because when I am starting my slackware 10 a text comes that says something like FATAL: agpgrep module not found ot cannot find agpgrem module.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
slack apache and php zuessh Slackware 4 04-23-2005 08:40 PM
apache won't start with php info in modules.conf synaptical Linux - Software 2 04-09-2005 10:39 AM
LAMP(Linux,Apache,MySql,PHP) and other info hamtavs General 1 01-25-2005 04:54 AM
Slack 9.1 apache + php Greg21 Slackware 2 01-23-2004 01:22 PM
Apache+php problem in Slack 9.0 raypen Slackware 2 06-05-2003 05:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration