LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-07-2018, 01:44 AM   #16
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,333

Rep: Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267Reputation: 2267

if it's convenient for you, please try this (testing) modified SlackBuild

http://ponce.cc/slackware/testing/hplip/

EDIT: well, I've been too slow: it's already in current!

Last edited by ponce; 08-07-2018 at 02:18 AM.
 
1 members found this post helpful.
Old 08-07-2018, 01:08 PM   #17
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 386

Original Poster
Rep: Reputation: 127Reputation: 127
Thanks to everyone. Still cannot print even after the latest -current update.

Switched on debug-logging and the log is in the pastebin link below:

https://hastebin.com/equwituloc.php

Meanwhile, I will once again revert to 3.18.6.
 
1 members found this post helpful.
Old 08-07-2018, 02:24 PM   #18
ferrari
Senior Member
 
Registered: Sep 2003
Location: Auckland, NZ
Distribution: openSUSE Leap
Posts: 3,123

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
Examining the log, this caught my attention...
Code:
D [07/Aug/2018:14:02:43 -0400] [Job 365] prnt/backend/hp.c 919: ERROR: null print job total=0
D [07/Aug/2018:14:02:43 -0400] [Job 365] PID 6162 (/usr/lib64/cups/backend/hp) exited with no errors.
D [07/Aug/2018:14:02:43 -0400] [Job 365] PID 6161 (/usr/lib64/cups/filter/foomatic-rip-hplip) stopped with status 255 (Unknown error 155)
...and a few lines down it results in the following error message...
Code:
E [07/Aug/2018:14:02:43 -0400] [Job 365] Job stopped due to filter errors; please consult the error_log file for details.
...but it's not clear (to me at least) about the underlying cause here.
 
Old 08-07-2018, 02:42 PM   #19
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 386

Original Poster
Rep: Reputation: 127Reputation: 127
Quote:
Originally Posted by ferrari View Post
...but it's not clear (to me at least) about the underlying cause here.
Indeed.

Meanwhile, I can print with 3.18.6 with no issues.
 
Old 08-07-2018, 10:48 PM   #20
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 323

Rep: Reputation: 121Reputation: 121
FWIW - on 3.18.7-x86_64-1 - printing did not work. On 3.18.7-x86_64-2 - "worksforme".

HP Laserjet MFP M130fn (hpcups).

hpijs has not worked for me for ages. Too lazy to have tried latest patch. Will try soon.
 
1 members found this post helpful.
Old 08-07-2018, 11:05 PM   #21
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 386

Original Poster
Rep: Reputation: 127Reputation: 127
somewhat, 3.18.7-2 still does not work for me. Reverting to 3.18.6 restores functionality.

Will make another try tomorrow.
 
Old 08-16-2018, 09:16 AM   #22
zaskar_84
LQ Newbie
 
Registered: Aug 2018
Location: Argentina
Distribution: Slackware-current
Posts: 3

Rep: Reputation: Disabled
Same problem here, running current (hplip-3.18.7-x86_64-2). I can setup (with hp-toolbox) the printer (hp lj 1020), but every time I send a page I see this in dmesg:

hpcups[593]: segfault at 2261000 ip 00007f8b7a02a9cd sp 00007ffd323bd940 error 6 in libImageProcessor-x86_64.so[7f8b7a023000+6e000]
 
1 members found this post helpful.
Old 08-16-2018, 09:40 AM   #23
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 386

Original Poster
Rep: Reputation: 127Reputation: 127
Indeed. Meanwhile I advise you to revert to 3.18.6. There I can print without problems.
 
Old 08-16-2018, 09:48 AM   #24
zaskar_84
LQ Newbie
 
Registered: Aug 2018
Location: Argentina
Distribution: Slackware-current
Posts: 3

Rep: Reputation: Disabled
Quote:
Meanwhile I advise you to revert to 3.18.6
Thanks, but where can I get old current packages?
 
1 members found this post helpful.
Old 08-16-2018, 10:01 AM   #25
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 386

Original Poster
Rep: Reputation: 127Reputation: 127
you can check AlienBob's git repository:

https://git.slackware.nl/current/tree/source/ap/hplip
 
1 members found this post helpful.
Old 08-16-2018, 10:49 AM   #26
sombragris
Member
 
Registered: Jul 2004
Location: Asuncion, Paraguay, South America
Distribution: Slackware
Posts: 386

Original Poster
Rep: Reputation: 127Reputation: 127
you can also check this post which you might find useful.

Thus:
http://slackmirror.cbpf.br/pub/slack...6-x86_64-1.txz

Last edited by sombragris; 08-16-2018 at 10:51 AM.
 
1 members found this post helpful.
Old 08-16-2018, 10:56 AM   #27
zaskar_84
LQ Newbie
 
Registered: Aug 2018
Location: Argentina
Distribution: Slackware-current
Posts: 3

Rep: Reputation: Disabled
Thanks! I've rebuilt 3.18.6 with alienbob's repo picking last revision previous to 2018-aug-07, and it's working again.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] latest hplip on current64 Launfal Slackware 34 06-10-2016 06:27 PM
Print Driver HP Laserjet 1020 Wellington912 Linux Mint 7 06-30-2014 06:52 AM
LXer: Configuring Fedora 18 to print to HP LaserJet 1020 is a pain in the butt LXer Syndicated Linux News 0 06-11-2013 09:00 AM
LXer: Configuring Fedora 18 to print to HP LaserJet 1020 is a pain in the ass LXer Syndicated Linux News 0 06-11-2013 03:00 AM
[SOLVED] Fedora 12 HP Laserjet 1020 doesn't print rmknox Linux - Newbie 4 08-16-2010 07:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration