-   Slackware (
-   -   Cannot install Genius (Pixart) webcam in Slackware 12 (

wsurfer0 12-19-2012 03:13 PM

Cannot install Genius (Pixart) webcam in Slackware 12
Hello Linux users. I have been trying to install this cursed Genius i-look 110 webcam on this rather obsolete system for days now and am about to give up and just buy one that works out-of-the-box. Anyhow, here are the boring details, so if anyone has any idea, I'd be grateful. If not, thanks anyway, you're a great forum.

BT3 (Slackware 12, kernel
webcam Genius i-look 110 (lsusb gives "Bus 4 Device 4: ID 093a:2468 Pixart Imaging, Inc. Cammaestro 2.5DU/X-EYE/Orite SC-120/ICGear TravelCam/Easy Snap Snake Eye WebCam)

Here are just some of many errors I get while trying to install various software for the wretched thing (sorry for the long post):

guvcview-src-1.5.0 'make' gives:

ivtv-ctl.c:511: error: 'VIDEO_GET_FRAME_COUNT' undeclared (first use in this function)
ivtv-ctl.c:511: error: (Each undeclared identifier is reported only once
ivtv-ctl.c:511: error: for each function it appears in.)
ivtv-ctl.c:593: error: 'AUDIO_BILINGUAL_CHANNEL_SELECT' undeclared (first use in this function)
make[2]: *** [ivtv-ctl.o] Error 1
make[2]: Leaving directory `/opt/v4l-utils-0.8.9/utils/v4l2-ctl'
make[1]: *** [all] Error 1
make[1]: Leaving directory `/opt/v4l-utils-0.8.9/utils'
make: *** [all] Error 2

V4L2 './configure' gives

configure: error: Package requirements (gtk+-2.0 >= 2.14.0 glib-2.0 >= 2.10.0 gthread-2.0 gdk-2.0 >= 2.10.0 gdk-pixbuf-2.0 sdl >= 1.2.10 portaudio-2.0 libpng libavcodec libv4l2 libudev) were not met:

Requested 'gtk+-2.0 >= 2.14.0' but version of GTK+ is 2.10.14
No package 'libv4l2' found
No package 'libudev' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables DEPS_CFLAGS
and DEPS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Philips USB Webcam Driver for Linux 'make' gives

make -C /lib/modules/ SUBDIRS=/opt/pwc-10.0.12-rc1 modules
make[1]: Entering directory `/lib/modules/'
make[1]: *** No rule to make target `modules'. Stop.
make[1]: Leaving directory `/lib/modules/'
make: *** [all] Error 2

wxcam 'make' gives

make all-recursive
make[1]: Entering directory `/root/wxcam-1.1'
Making all in src
make[2]: Entering directory `/root/wxcam-1.1/src'
CXX audio.o
In file included from setting.h:26,
from audio.cpp:22:
v4l.h:30:30: error: libv4l1-videodev.h: No such file or directory
v4l.h: In constructor 'VideoForLinux::VideoForLinux()':
v4l.h:58: error: 'VIDEO_PALETTE_RGB24' was not declared in this scope
v4l.h:59: error: 'VIDEO_PALETTE_RGB32' was not declared in this scope
v4l.h:60: error: 'VIDEO_PALETTE_YUV420P' was not declared in this scope
v4l.h:61: error: 'VIDEO_PALETTE_YUV420' was not declared in this scope
v4l.h:62: error: 'VIDEO_PALETTE_YUYV' was not declared in this scope
make[2]: *** [audio.o] Error 1
make[2]: Leaving directory `/root/wxcam-1.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/wxcam-1.1'
make: *** [all] Error 2

markush 12-21-2012 03:27 AM

Hello wsurfer0, welcome to LQ,

you should use the Slackbuildscript for guvcview But you have a quite old version of Slackware. I don't know if the recent Slackbuildscript will work for 12.

But note that the dependencies for guvcview are ffmpeg and portaudio, have you installed them before?

I've reported this thread to the Moderators and asked it to move to the Slackware-forum of LQ.


colucix 12-21-2012 04:26 AM

Moved: This thread is more suitable in Linux - Slackware and has been moved accordingly to help your thread/question get the exposure it deserves.

wsurfer0 12-22-2012 03:41 AM

Hi, thanks for the reply.

I do have ffmeg and portaudio installed. I needed them for my MPlayer, which now works almost perfectly.

I have tried following your suggestion to install Guvcview from Slackbuild, but as usual, I got into another labyrinth of errors.

First I tried installing Guvcview, which said that I must first install a newer gtk+ and some other stuff, which in turn said i must first install a newer glib and atk and other stuff.

Then I installed glib and went on to install atk, but the atk installation says:

pkg-config --modversion glib-2.0' returned 2.29.2, but GLIB (2.12.12)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files

Now, I think I will just give up on this, but I would like to know how to "set the environment variable PKG_CONFIG_PATH", seeing as I have come across this message more than once.

Thank you for your patience.

markush 12-22-2012 03:49 AM

The problem is that you're using Slackware 12 which is quite old. Though this version is still supported with securityupdates, you run into problems when installing additional software.

One solution would be to find an older version of the software, the other probably better solution would be to upgrade to Slackware-14. There are quite some changes between 12 and 14 and it is very likely that the slackbuilds don't work. Otherwise a new installation of Slackware-14 is done quite fast, and if you use sbopkg (which is a graphical frontend for Slackbuilds) you will install additional programs quickly (and convenient). Download sbopkg here:

For additional questions you will find much help here at the Slackware-forum, and if you have questions which are Slackware related, don't post it in LQ's newbie-forum but here. Most of the Slackbuild-maintainers are here and will help you to solve your problems.


All times are GMT -5. The time now is 10:16 PM.