-   Slackware (
-   -   Cannot get wireless working in slackware (

retne_cow 10-23-2011 08:19 PM

Cannot get wireless working in slackware
Hi, I'm having some trouble getting my wireless working in slackware 13.37. The computer is using a Broadcom chipset, but can't seem to find the wireless card

iwconfig gives me the following

lo        no wireless extention

eth0      no wireless extention

and lspci | grep Broadcom gives me

01:00:0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
02:00:0 Network controller: Broadcom Corporation BCM543225 802.11b/g/n (rev 01)

I'm lost please help

mcleod 10-23-2011 11:57 PM

Cannot get wireless working in slackware Reply to Thread
hi! you might try to look into this site:

and this:

onebuck 10-24-2011 09:53 AM

Moved: This thread is more suitable in <Slackware> and has been moved accordingly to help your thread/question get the exposure it deserves.

hitest 10-24-2011 09:59 AM

Have you tried installing wicd which is located in /extra? It is very good at setting up a wireless connection.

cynwulf 10-24-2011 10:53 AM


Originally Posted by retne_cow (Post 4506155)
and lspci | grep Broadcom gives me

01:00:0 Ethernet controller: Broadcom Corporation NetLink BCM57780 Gigabit Ethernet PCIe (rev 01)
02:00:0 Network controller: Broadcom Corporation BCM543225 802.11b/g/n (rev 01)

There is no such network controller as the BCM543225, though there is a BCM43225, is that the actual output you posted or did you accidentally insert that "5" when posting?

Please provide the verbose output:


lspci -v
If it does turn out to be a BCM43225, that uses the brcm80211 module which is included in kernel 2.6.37 - which is 13.37's kernel. If it's not loaded then it may be due to the lack of firmware - not sure where the broadcom firmware is in slackware, possibly in the "kernel-firmware" package or perhaps in a separate package?

Does this produce anything of interest?

dmesg | grep -i firmware

pg99 10-24-2011 02:16 PM

Your chipset is referenced here as needing the wl kernel module.

There is some information in that file about the wl module possibly conflicting with b43 and others. Check out the info Broadcom has supplied and see if that helps.

xj25vm 10-24-2011 03:28 PM

All the Broadcom cards I've installed under Slackware needed firmware. Firmware goes in Slackware under /lib/firmware. As far as I'm aware - there is no official firmware package for Broadcom cards for Slackware. Officially, it is recommended to use fwcutter and make your own firmware from the corresponding Windows driver for your card. Unofficially ( :D ) I have always found firmware already cut for me on one website or another. Make sure you do something like:


# dmesg | grep Broadcom
or similar in order to find out exactly what name the firmware file should have. Normally the kernel will complain during the boot that a certain firmware file is missing - and this is how you will know what name to give to the firmware file, once you get it.

It is also worth checking the kernel wifi pages ( - many sections there list links to firmware downloads for various cards/modules.

ReaperX7 10-24-2011 03:51 PM

Firmware doesn't work on all the Broadcom chipsets. FWCutter will strip firmware from various prebuilt Linux drivers modules but the process doesn't work for all cards because matching the firmware and chipset without knowing which firmware package to download is hit or miss with any chipsets in the 43xx series, and even then firmware still doesn't always work.

The STA driver is Broadcom's official driver. Just about all 43xx series or later cards will work with the STA driver provided you have the right kernel for it.

The BCM543225 is a very new chipset (802.11-N). You may be required to rebuild your kernel before building the module to gain proper support. I "think" kernel or should be adequate but you may be required to use kernel 3.0.7 in conjunction with the proprietary STA driver.

xj25vm 10-24-2011 04:38 PM

ReaperX7 wrote:


FWCutter will strip firmware from various prebuilt Linux drivers modules
According to


...b43-fwcutter tool [...] will extract firmware from the Windows driver...
Firmware will work if you either download the correct file and name it with the name expected by the kernel, or manually extract it from the correct version of the Windows driver for the chipset you have using fwcutter.

Again, according to , the currently supported Broadcom wifi modules are b43, b43legacy, brcmsmac, brcmfmac. The detail pages state that all the four modules require firmware files. It might seem like sometime firmware is not needed, because on other distributions firmware is already included in the appropriate folder, so the user needs to do nothing.

According to this paragraph , the STA driver doesn't support various features, is fully proprietary and its stack is deprecated from the point of view of the Linux kernel.

The correct module to use for your chipset is the brcmsmac:

Apparently it was first added to the kernel in 2.6.38

It will need firmware, and the firmware files should be here:

These modules/drivers are fairly recent additions to the kernel, so even if you get it working, your mileage might vary in terms of connection quality and stability.

Hope the above helps.

ReaperX7 10-24-2011 08:37 PM

I've never read that... oddly because I've read it like this:


This firmware is copyrighted by Broadcom and must be extracted from Broadcom's proprietary drivers.
The only driver or utility that I've known to require a Windows driver has always been ndiswrapper. I've always assumed the "driver packs" that have been downloadable from the websites for extracting firmware are precompiled portions of the Linux proprietary drivers like prebuilt object files using GCC and such.

xj25vm 10-25-2011 02:23 AM

I've done some more research, and it appears fwcutter covers both cases. From the fwcutter man page (


Currently b43-fwcutter supports Apple MacOS X, Microsoft Windows 98/ME/2000/XP and Linux drivers, but keep in mind that b43-fwcutter doesn't support all driver versions.
One learns something new everyday :)

I believe the whole point of firmware is to have binary blobs which other people can't inspect - in order to protect some of the internal spec of various chips from being revealed to the world. They tend to be proprietary (i.e. - the open source developers wouldn't have access to the source) - and delivered ready compiled by the manufacturer (or extracted in compiled/binary form from some of their other drivers) - thus probably nobody really knows what tools are used to make them in the first place.

All times are GMT -5. The time now is 05:30 PM.