-   Slackware (
-   -   Cannot get USB 3/Hard drive to work in Slackware 13.37; timeout messages in dmesg (

ljones0 05-06-2011 04:42 PM

Cannot get USB 3/Hard drive to work in Slackware 13.37; timeout messages in dmesg
Hello all :) !

I've just recently gotten hold of a new PCIe USB 3 card to go into my PC (the motherboard is an Asus M3A78-EM). Currently I'm running slackware 13.37, 64 bit.

However I'm experiencing a problem with a hard drive plugged into a USB 3 adapter/dock (attaches to the USB PCIe card via a cable). The PCIe card itself appears to be seen ok;

(The PCIe USB 3 Card is a transcend TS-PDU3).

Output from dmesg;

[    1.603595] xhci_hcd 0000:02:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[    1.605020] xhci_hcd 0000:02:00.0: setting latency timer to 64
[    1.605023] xhci_hcd 0000:02:00.0: xHCI Host Controller
[    1.606497] xhci_hcd 0000:02:00.0: new USB bus registered, assigned bus number 8
[    1.620141] xhci_hcd 0000:02:00.0: irq 16, io mem 0xfbcfe000
[    1.621587] xhci_hcd 0000:02:00.0: irq 44 for MSI/MSI-X
[    1.621589] xhci_hcd 0000:02:00.0: irq 45 for MSI/MSI-X
[    1.621591] xhci_hcd 0000:02:00.0: irq 46 for MSI/MSI-X
[    1.621593] xhci_hcd 0000:02:00.0: irq 47 for MSI/MSI-X
[    1.621595] xhci_hcd 0000:02:00.0: irq 48 for MSI/MSI-X
[    1.629842] usb usb8: Manufacturer: Linux xhci_hcd
[    1.633080] xHCI xhci_add_endpoint called for root hub
[    1.633081] xHCI xhci_check_bandwidth called for root hub

But the hard drive does not seem to fare so well;

Output from dmesg;

[  134.666092] usb 8-3: new high speed USB device using xhci_hcd and address 2
[  139.666012] xhci_hcd 0000:02:00.0: Timeout while waiting for a slot
[  144.867013] xhci_hcd 0000:02:00.0: Timeout while waiting for a slot
[  145.068015] usb 8-3: device not accepting address 2, error -62
[  150.069022] xhci_hcd 0000:02:00.0: Timeout while waiting for a slot
[  150.069027] hub 8-0:1.0: couldn't allocate port 3 usb_device
[  155.173009] xhci_hcd 0000:02:00.0: Timeout while waiting for a slot
[  155.173014] hub 8-0:1.0: couldn't allocate port 1 usb_device

The hard drive isn't being detected at all, all I get is the timeout error and it gets no further.

Pokeing about on the internet I'm reading a little about a possible kernel bug (e.g. here. I've tried both kernels and the latest linux kernel, 2.6.39-rc6. Both give the same results x.x .

Does anyone know if this really is a kernel problem or if it is some incompatibility with slackware or ?



SavoTU 05-06-2011 08:27 PM

I don't think this will help but my mouse does this at random, it will work then just stop so i have to unplug/plug it in and then i start getting the same error. I just keep trying different sockets and usually it will work and on the odd occasion i give up and reboot and its works right away. This happens on all the different kernel versions i have tried including the latest one in testing.


Forgot to say this has been happening for about a year and with 3 different mice.

ljones0 05-10-2011 01:13 PM

Ok :) Thanks for that there.

Weird but true moment here though -- after upgrading KDE ( ) it all seems to be working :) !


SavoTU 05-10-2011 02:20 PM

Glad its sorted, did you notice that KDE 4.6.3 packages are also available? Also i cannot point you to that post without adding that the oxygen-gtk is truly stunning

ljones0 05-10-2011 02:51 PM

Intresting, thanks for that :) . Must just update on one thing though -- I'm not sure how much or how little a KDE upgrade did. Weirdly although the device works if both are started from cold if I disconnect the USB 3 device and reeconnect it it dosen't work properly unless I power everything down and back on again. However powering both on at the same time and leaving the USB device powered up (and resetting the PC) the USB 3 device remains and still works. Odd.


All times are GMT -5. The time now is 07:11 PM.