LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-17-2014, 12:22 PM   #1
Xiano
LQ Newbie
 
Registered: Jul 2014
Posts: 12

Rep: Reputation: Disabled
Cannot get network interfaces up in Slackware 14.1 (32b)


I'm trying to add an old Pentium 4 to my network, and installed slackware 14.1 on it. It has two network interfaces: an ethernet controller (Via Rhine-III, module via_rhine) and an ancient mini-pci wifi (Intersil ISL3890, module prism54). I added static ip for the ethernet card to /etc/rc.d/rc.inet1.conf in the eth0* variables, and expected to simply run wicd-client to set up the wireless. But at boot time i get a message about "Any ESSID" being selected for the eth0 interface, (cannot paste, output is not seen in dmesg output).
What dmesg does show is:
Code:
eth0: resetting device
eth0: uploading firmware...
prism54: request_firmware() failed for 'isl3890'
eth0: islpci_reset: failure
and this is seen 3 times in a row.

Output of iwlist scan:
Code:
lo       Interface doesn't support scanning
eth0     No scan results
eth1     Interface doesn't support scanning
Running ifconfig wlan0 results in:

Code:
wlan0:   error fetching interface information: Device not found
I expected wlan0 to point to the wireless, but it seems the wireless is on eth0.

ifconfig eth0:

Code:
eth0: flags=4096<BROADCAST,MULTICAST> mtu 1500
      ether 00:30:b4:00:00:00 (Ethernet)
      (...)
      device interrupt 16
ifconfig eth1:

Code:
eth1: flags=4096<BROADCAST,MULTICAST> mtu 1500
      ether 00:0c:76:76:a9:a0 (Ethernet)
      (...)
Running ifconfig eth0 up:
Code:
SIOCSIFFLAGS: No such file or directory
Running ifconfig eth1 up works, but network is unreachable even if i assign a static ip address/subnet mask to eth1 in /etc/rc.d/rc.inet1.conf. What's also strange is that when ifconfig is run afterwards, no "inet" address is shown, only an "inet6" address.

Then, i ran wicd-client. A wired connection is shown, selected as default and running ifconfig without parameters shows only lo is up, though i can now ping the address i assigned to eth0 in rc.inet1.conf. Pinging another computer fails with "connect: Network is unreachable".

Hardware failure can be ruled out, because i backed up the files on the harddisk through the network (wire as well as wireless) while running the Windows XP that was on it. Internet also worked.

I would much prefer the ethernet cable interface to be at eth0, and the wireless at wlan0...

lspci does show that the number in front of the prism controlles is smaller than the number in front of the rhine controller.

Any help at all would be greatly appreciated.
 
Old 08-17-2014, 01:42 PM   #2
bormant
Member
 
Registered: Jan 2008
Posts: 295

Rep: Reputation: 172Reputation: 172
Quote:
Code:
prism54: request_firmware() failed for 'isl3890'
First try to download firmware
https://github.com/jolicloud/linux-f...rism54/isl3890
and place it under /lib/firmware (or where prism54 wants see it), so error message goes off.
 
Old 08-17-2014, 02:45 PM   #3
Xiano
LQ Newbie
 
Registered: Jul 2014
Posts: 12

Original Poster
Rep: Reputation: Disabled
I put the firmware in /lib/firmware and the error went away.

Running ifconfig right after boot now shows eth0, eth1 and lo are up.
However, eth0 shows no inet v4 address.

I can ping the static ip's of both eth0 and eth1. Pinging other computer on network returns "Destination Host Unreachable".
dmesg shows eth1 driver is Rhine III and is loaded correctly (before eth0 ?!).
There's also this boot message:
Code:
/etc/rc.d/rc.M: eth0 information: 'Any ESSID'
I conclude that eth0 must be wireless and eth1 must be wired.

I removed the static ip in rc.inet1.conf of eth0 interface and rebooted.
Dmesg now shows eth0 is Rhine III, no mention anymore of eth1.

Wicd-client sees wired interface, but reports the address is 127.0.0.1.
Disconnecting wired and reconnecting with static ip passed via wicd-client enables pinging other address.
BUT: pinging succeeds for every address in subnet, even if not assigned to computer. Cannot actually connect to other computer.

Wicd-client keeps on scanning for wireless networks forever.

eth0 related messages:

Code:
eth0: resetting device...
eth0: uploading firmware...
eth0: firmware version: 1.0.4.3
eth0: firmware upload complete
eth0: interface reset complete
NET: Registered protocol family 10
IPv6: ADDRCONF(NETDEV_UP): eth0: link not ready
IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[EDIT] If both interfaces have static ip assigned in rc.inet1.conf, they both have an IPv4 address. If not eth0 only gets an inet6.
Either way firmware gets uploaded to eth0, and both the flags in ifconfig output now are:
Code:
eth0/1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>
Unfortunately I'm still quite new at networking in Linux, so that doesn't mean a lot to me. I figure i must be making a rookie mistake.

Last edited by Xiano; 08-17-2014 at 06:08 PM.
 
Old 08-17-2014, 07:18 PM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,983

Rep: Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728
There is a good guide to setting up networking at SlackDocs. http://docs.slackware.com/slackware:...e_your_network

When you have been configuring to use a static IP address, have you also been supplying a default gateway IP address (inside the quotes of GATEWAY="" in /etc/rc.d/rc.inet1.conf) as well as a DNS server IP address (e.g. 'nameserver 10.1.1.1' in /etc/resolv.conf)? In a home network, the gateway IP address and the nameserver IP address that is used is usually the local IP address of the modem/router used to connect to the internet.
 
Old 08-17-2014, 07:33 PM   #5
Xiano
LQ Newbie
 
Registered: Jul 2014
Posts: 12

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by allend View Post
When you have been configuring to use a static IP address, have you also been supplying a default gateway IP address (inside the quotes of GATEWAY="" in /etc/rc.d/rc.inet1.conf) as well as a DNS server IP address (e.g. 'nameserver 10.1.1.1' in /etc/resolv.conf)? In a home network, the gateway IP address and the nameserver IP address that is used is usually the local IP address of the modem/router used to connect to the internet.
I thought that a gateway was only necessary to connect the lan to the internet or another network, this is not relevant now. My setup is: i have two computers, each have an ethernet card and wifi. To connect to the internet i want to connect each separately by wifi. Since they then are connected to a router they can also connect to each other, but the problem is for this purpose the old one's wifi card is too slow, the earliest model of 802.11, and copying large amounts of data takes multiple hours. For this purpose i would like them both to be connected to each other by a cable, if i need to copy from one to the other this will be much faster (100Mbit/s). I didn't think gateway was necessary. For the one that is currently connected to the internet i didn't specify this either, i just connect to the wifi router and wicd takes care of everything. When the pentium 4 was still XP i just filled in a static ip on the linux one (10.0.0.x) and a subnet mask of (255.255.255.0), i did the same in the connection settings of XP and everything was ready to go, I could transfer files by ftp or samba. Wicd also takes care of dns/dhcp on the internet connection, i was just going to add the static ip's of the ethernet interfaces in the /etc/hosts file of both computers once i can get them to connect.
 
Old 08-17-2014, 08:05 PM   #6
Xiano
LQ Newbie
 
Registered: Jul 2014
Posts: 12

Original Poster
Rep: Reputation: Disabled
I got the cable connection working. One pc has it on eth0, i left eth0 settings blank for the other but filled in eth1 ip/netmask. Then ran ifconfig eth1 down (which i didn't run before) and /etc/rc.d/rc.inet1 eth1_start (thanks allend, i read the docs now) got the connection working: can ftp through the cable. But eth0 has no settings specified but still gets up, with only an inet6 address. Wicd-client keeps scanning for a wireless network forever and "Swich Off Wi-Fi" doesn't work. Furthermore, it displays the following in the status bar:
Code:
Connected to wired network (127.0.0.1)
which is not right. The eth1 interface does work perfectly though.

[EDIT]I've noticed "lo" was filled in in preferences for wired. *slaps forehead* This part is fixed.[/EDIT]

Also, this time in dmesg output there was a new line at the end:
Code:
eth0: timeout waiting for mgmt response 1000, triggering device
I've never had to download firmware to get a driver to work, could it be that the firmware's not working for me?

Last edited by Xiano; 08-17-2014 at 10:13 PM.
 
Old 08-17-2014, 08:43 PM   #7
Xiano
LQ Newbie
 
Registered: Jul 2014
Posts: 12

Original Poster
Rep: Reputation: Disabled
Update, some progress

Firmware must be working ok.
I did chmod -x rc.wicd and tried networkmanager instead. Networkmanager can find wireless networks, but when i try to connect to mine, it asks for the vault password, which i enter, then it says "(ssid) needs authentication" and i enter the router's psk, then i have to enter the vault password again and then it says WLAN interface: Configuring interface. It then asks me to input the vault password again, then the psk, and so on and keeps on doing that a couple of times until it says "Not connected". I am sure the psk i give is correct because the computer i'm using to write this is connected to the router with that password.

I'm hoping this rings a bell for someone.

[EDIT] I gave up on networkmanager too and moved on to trying to edit rc.inet1.conf. I put the connection settings in WLAN_*[0], because eth0 is my wireless.
rc.inet1 eth0_start output:
Code:
/etc/rc.d/rc.inet1: eth0 information: 'Any ESSID'
Invalid command: set
Invalid command: set
Invalid command: set
Successfully initialized wpa_supplicant
Then it pauses for half a minute or so and the eth0 interface has neither inet nor inet6 addresses afterwards. Flags is 4099<UP,BROADCAST,MULTICAST>. I closely followed the man page of rc.inet1.conf, section "Wireless parameters".

Last edited by Xiano; 08-17-2014 at 09:41 PM.
 
Old 08-17-2014, 10:58 PM   #8
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,983

Rep: Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728
If you can get a wired connection, then good! At this point I would suggest that you move from using static IP addressing to using DHCP. Most home modem/routers have the facility to act as DHCP servers with address space reservation that acts like static IP addressing. See whether you can get this working with your wired setup. Having DHCP available does simplify network administration.

It may be useful to try using wpa_supplicant directly with the -d option to debug the wireless connection, but you will need an appropriate /etc/wpa_supplicant.conf file. These are settings that I use for a WPA2 connection, with parameters you need to supply in angled brackets. I find I also need to specify the -Dwext option to wpa_supplicant for this to work.
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=root
eapol_version=1
ap_scan=1
fast_reauth=1

network={
  scan_ssid=0
  ssid=<yourSSID>
  proto=RSN
  key_mgmt=WPA-PSK
  pairwise= CCMP TKIP
  group=CCMP TKIP WEP104 WEP40
  psk=<yourPSK>
  priority=10
}
Note that wpa_supplicant only creates the encrypted connection to your router. You need to run dhcpcd to get further networking parameters before a full internet connection can be made. (If dhcpcd is already running, you may need to use 'pkill dhcpcd' to stop it first).

Looking at the logs in your modem/router may also give a clue to why the wireless connection is failing.
 
Old 08-18-2014, 05:57 AM   #9
Xiano
LQ Newbie
 
Registered: Jul 2014
Posts: 12

Original Poster
Rep: Reputation: Disabled
I have tried your wpa_supplicant.conf, but the wireless settings in rc.inet1 seemed to take precedence, so i removed them and tried again. Dhcpcd always prints out:

Code:
eth0: waiting for carrier
timed out
allowing 8 seconds for IPv4LL timeout
timed out
exited
...whatever i put in the wpa_supplicant.conf file. I also tried removing the cipher selection and so on until i was down to the first example in the wpa_supplicant.conf man page, but nothing works.

I don't have access to the logs in the router, the router was put here by the ISP (connected to TV-cable) and to change anything i have to go to their website. I can only change the password and activate port forwarding and firewall, no logs. I did activate ethernet debugging but there's nothing new in /var/log/debug. In /var/log/messages i get output stating eth0 is not configured in rc.inet1.conf.

I tried wpa_gui, which says "Could not get status from wpa_supplicant", and scanning shows no results.
 
Old 08-18-2014, 09:40 AM   #10
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: SlackwareŽ
Posts: 13,148
Blog Entries: 28

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Member Response

Hi,

Please post your '/etc/rc.d/rc.inet1.conf' file. I also suggest that you look at: Slackware Doc Project;
Quote:
Configure your new Slackware System; how to proceed after the installation has completed.

Hope this helps.
Have fun & enjoy!

 
Old 08-18-2014, 09:43 AM   #11
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 4,983

Rep: Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728Reputation: 1728
Just backing up a little to confirm.
Quote:
Hardware failure can be ruled out, because i backed up the files on the harddisk through the network (wire as well as wireless) while running the Windows XP that was on it. Internet also worked.
This same hardware was connecting with both wired and wireless connections when running Windows XP. Correct?
If so, do you have a record of the Windows XP network connection settings?

What is the output of the following commands run as root?
Code:
ip link
This shows available network interfaces. You may prefer 'iwconfig' to identify your wireless interface.
Code:
rfkill list
If the last command shows a hard block, then check for a physical switch that needs to be turned on. If a soft block is shown, then use 'rfkill unblock all'.
Code:
ip link set <your wireless interface> up
This should activate the wireless interface. You can confirm by running 'ip link' again.
Code:
iwlist scan | grep ESSID
This should show available access points. (Remove the pipe to grep for additional information such as ciphers)
 
Old 08-18-2014, 11:05 AM   #12
Xiano
LQ Newbie
 
Registered: Jul 2014
Posts: 12

Original Poster
Rep: Reputation: Disabled
Relevant lines in /etc/rc.d/rc.inet1.conf:
WLAN_MODE[0]=Managed
USE_DHCP[0]="yes"
WLAN_ESSID[0]=<ssid>
#WLAN_IWPRIV[0]="set AuthMode=WPAPSK | set EncrypType=TKIP | set WPAPSK=<key>"
#(tried with and without, with gives error)

"ip link":

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN mode DEFAULT qlen 1000
link/ether 00:0c:76:76:a9:a0 brd ff:ff:ff:ff:ff:ff
3: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN mode DEFAULT qlen 1000
link/ether 00:60:b3:92:54:d3 brd ff:ff:ff:ff:ff:ff

"iwlist scan" does indeed show my router in a list, before or after "ip link set eth0 up", yet wicd-client keeps scanning forever and networkmanager still can scan but not connect.

What's strange is that right after boot iwconfig shows eth0 has ESSID:"Draadloos", (meaning "wireless") but that's another network in my neighbourhood. I never specified to connect to that network. If i run "dhcpcd eth0" i can connect to that (wrong) wireless network which must be unsecured, apparantly it has something to do with authentication.
I thought it could have been the password i use. When the router was first installed it was a hex string but i changed it to something that uses the whole alphabet. I changed it back and tried again, but that wasn't it.

[EDIT] Also, i am absolutely certain the router uses TKIP. I verified in router settings on ISP's website. I also tried with someone else's D-Link DWA-131 usb dongle and after tinkering a bit that worked like a charm. If the card i have won't work i'm going to buy such a dongle.

Last edited by Xiano; 08-18-2014 at 11:33 AM.
 
Old 08-18-2014, 12:06 PM   #13
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: SlackwareŽ
Posts: 13,148
Blog Entries: 28

Rep: Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374Reputation: 2374
Member Response

Hi,

Why can you not post the whole '/etc/rc.d/rc.inet1.conf'? It is obvious you do not realize that wlan0[0] is assigned to the first device as indicated by the [0] for the eth0 device.You can overrule that with 'IFNAME' but that is not conventional.

Please read 'man rc.inet1.conf';
Quote:
rc.inet1.conf - Slackware network configuration file.

DESCRIPTION
rc.inet1.conf It consists basically of a series of variable array definitions. Array elements with the same index number will all belong to the same
network interface.

By default, index number `0' is used for the configuration of interface eth0, index number `1' is used for eth1 and so forth. The default interface
name can be overruled by the use of the variable IFNAME.

This is what a typical section of the file looks like for a card that is configured to use DHCP, showing all array variables with the index number
[0]:

# Config information for eth0:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]="yes"
DHCP_HOSTNAME[0]=""
DHCP_TIMEOUT[0]=""

Alternatively, here is an example for a card that uses a static IP address and has a non-default name ( ath0 instead of eth1 ). The array index is
[1] in this case.

# Config information for ath0 (using static IP address):
IFNAME[1]="ath0"
IPADDR[1]="192.168.3.11"
NETMASK[1]="255.255.255.0"
USE_DHCP[1]=""
DHCP_HOSTNAME[1]=""
GATEWAY="192.168.3.1"

GENERAL PARAMETERS
This is a list of network parameters you can set for any card (wired as well as wired). The example section is for `eth0' by default, i.e. the
array variables all have the array index [0]:

# Config information for eth0:

IPADDR[0]="" # Set this value to an actual IP address if you want static IP address assignment

NETMASK[0]="" # With a static IP address, you are required to also set a netmask (255.255.255.0 is common)

USE_DHCP[0]="yes" # If set to "yes", we will run a DHCP client and have the IP address dynamically assigned

DHCP_HOSTNAME[0]="mybox" # Tell the DHCP server what hostname to register

DHCP_TIMEOUT[0]=15 # The default timeout for the DHCP client to wait for server response is 30 seconds, but you might want a shorter wait.

IFNAME[0]="eth0:1" # Set up an IP alias.

HWADDR[0]="00:01:23:45:67:89"
# Overrule the card's hardware MAC address
Look at /etc/udev/rules.d/70-persistent-net.rules
Code:
# This file was automatically generated by the /lib/udev/write_net_rules
# program, run by the persistent-net-generator.rules rules file.
#
# You can modify it, as long as you keep each rule on a single
# line, and change only the value of the NAME= key.

# PCI device 0x8086:/sys/devices/pci0000:00/0000:00:1c.1/0000:03:00.0 (iwlwifi)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="58:91:cf:5c:3b:04", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="wlan*", NAME="wlan0"

# PCI device 0x10ec:/sys/devices/pci0000:00/0000:00:1c.5/0000:0a:00.0 (r8169)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="84:8f:69:c4:6a:e2", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
If you do not want to use eth0 then blank out in /etc/rc.d/rc.inet1.conf;
Code:
IPADDR[0]=""
NETMASK[0]=""
USE_DHCP[0]=""
DHCP_HOSTNAME[0]=""
To keep things clean and conventional then use in '/etc/rc.d/rc.inet1.conf';
Code:
# Default gateway IP address:
GATEWAY="192.168.xxx.xxx"

IFNAME[4]="wlan0"
IPADDR[4]="192.168.xxx.xxx"
NETMASK[4]="255.255.255.0"
WLAN_ESSID[4]=SomeESSID
HWADDR[4]="xx:xx:xx:xx:xx"  #your Device MAC address 
WLAN_MODE[4]=Managed
WLAN_KEY[4]="Your key goes here"
WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="auto"
Replace the xx variables above with your numbers.
Hope this helps.
Have fun & enjoy!
 
Old 08-19-2014, 05:54 PM   #14
Norseman01
Member
 
Registered: Nov 2012
Posts: 85

Rep: Reputation: Disabled
RE: http://www.linuxquestions.org/questions/slackware-14/

Quote:
Originally Posted by Xiano View Post
I'm trying to add an old Pentium 4 to my network, and installed slackware 14.1 on it. It has two network interfaces: an ethernet controller (Via Rhine-III, module via_rhine) and an ancient mini-pci wifi (Intersil ISL3890, module prism54). I added static ip for the ethernet card to /etc/rc.d/rc.inet1.conf in the eth0* variables, and expected to simply run wicd-client to set up the wireless. But at boot time i get a message about "Any ESSID" being selected for the eth0 interface, (cannot paste, output is not seen in dmesg output).
What dmesg does show is:
Code:
eth0: resetting device
eth0: uploading firmware...
prism54: request_firmware() failed for 'isl3890'
eth0: islpci_reset: failure
...(snip)
Any help at all would be greatly appreciated.
===============

OK guys- eth0 and eth-any-number is HARDWIRE
wlan0 and wlan-any-number is WIRELESS!
I run Slackware and /etc/rc.d/rc.inet1.conf has TWO sections. 1-Hardwire, 2-Wireless

The two have more than cable/no-cable differences.
AND I have had problems in the past with prismXX.

Let's start with the Prism : did you check the modules for any that mention prism? (/etc/rc.d/rc.modules[version-stuff-smp for multiprocessors, the other for single)
If you find any, probably should un-comment it to force it to load. If you don't find any that reference it, get on the web (use a friend's machine if necessary) and see if you can find a Prism module that fits your hardware and make sure it loads and runs properly. If it needs "updates" then go find/install them too.

The NICKNAME stuff in the wireless section of /etc/rc.d..... can cause problems too.
If so, comment out the sections (there are 2 or 3 of them) that contain it.

DISCONNECT the hardwire when setting up the wireless.
Make sure the wlan0 settings agree with the eth0 settings. Mods to that can be done in increments later. Yes, you can hardwire to one router and wireless to another, BUT try walking before running.


All that done - you should be up and running.

One last thought. If problems persist - take the pentium and reformat it's hard drive and put an older Slackware on it. (try 10.2) The older OS should have what is needed to get the older hardware working. I doubt you will find the Prism module source code (at least I never did) so re-compiling it is probably not going to happen.
Older (thus slower) machines make good light duty servers and ftp sites. Not so good for number crunching. Not so good for heavy graphics.

Slackware 10.2 turned out to be very stable. I still have it loaded and operational. I still use it to slap Window$ back into shape now and again as needed.


Norseman01
 
Old 08-19-2014, 09:56 PM   #15
perbh
Member
 
Registered: May 2008
Location: Republic of Texas
Posts: 304

Rep: Reputation: 55
Quote:
OK guys- eth0 and eth-any-number is HARDWIRE
wlan0 and wlan-any-number is WIRELESS!
Well, not always - depends on the driver. I have seen wireless coming up as ethX.
Mind you - that was some time back (rough guess, around slackware-12) - cannot remember which driver it was, but yes, I _have_ experienced it!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to make slackware setup network interfaces on boot? austinramsay Slackware 10 10-02-2013 02:13 PM
Two network interfaces on Slackware djake Linux - Networking 4 06-29-2008 04:04 PM
Slackware and virtual network interfaces... jademan83 Linux - Networking 4 08-23-2007 06:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 11:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration