LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 12-07-2018, 06:50 AM   #1
PetruM
LQ Newbie
 
Registered: Apr 2006
Location: Cluj-Napoca, Romania
Distribution: Slackware, Ubuntu 18.04 LTS
Posts: 15

Rep: Reputation: Disabled
Angry Cannot get hibernate to work on 14.2


Hi,

I can't seem to get hibernate to work. I have set up a swap partition (/dev/sdc2) and I have the Hibernate option in KDE. Once I click it, I'm logged out, my screen turns off and I can hear the PC fans speed up, but nothing happens, even if I leave it on for ten minutes.

If I do swapoff, mkswap /dev/sdc2, then swapon /dev/sdc2 and then attempt to hibernate, the PC will turn off, but then resume doesn't work.


Here's a copy of my /var/log/pm-suspend.log file:

Code:
Initial commandline parameters: 
Fri Dec  7 13:33:05 EET 2018: Running hooks for hibernate.
Running hook /usr/lib64/pm-utils/sleep.d/00logging hibernate hibernate:
Linux firefly 4.4.157 #2 SMP Fri Sep 21 00:36:59 CDT 2018 x86_64 Intel(R) Core(TM) i5-6400 CPU @ 2.70GHz GenuineIntel GNU/Linux
Module                  Size  Used by
pci_stub                1806  1
vboxpci                16316  0
vboxnetadp             19429  0
vboxnetflt             19918  0
vboxdrv               426667  3 vboxnetadp,vboxnetflt,vboxpci
ipv6                  337574  26
fuse                   85094  5
joydev                 10496  0
rt2800usb              21570  0
rt2x00usb              11387  1 rt2800usb
rt2800lib              79814  1 rt2800usb
rt2x00lib              42701  3 rt2x00usb,rt2800lib,rt2800usb
mac80211              612361  3 rt2x00lib,rt2x00usb,rt2800lib
cfg80211              527411  2 mac80211,rt2x00lib
crc_ccitt               1861  1 rt2800lib
rfkill                 18649  2 cfg80211
hid_generic             1551  0
usbhid                 38863  0
hid                   108027  2 hid_generic,usbhid
coretemp                6780  0
intel_rapl             11044  0
iosf_mbi                3821  1 intel_rapl
x86_pkg_temp_thermal     5665  0
intel_powerclamp        8978  0
kvm_intel             161137  0
kvm                   510755  1 kvm_intel
snd_hda_codec_realtek    73584  1
irqbypass               3583  1 kvm
snd_hda_codec_generic    61252  1 snd_hda_codec_realtek
crct10dif_pclmul        5461  0
i2c_dev                 6252  0
crc32_pclmul            3238  0
crc32c_intel           13583  0
psmouse               113450  0
i915                 1195903  0
evdev                  13220  27
snd_hda_codec_hdmi     39459  1
amdkfd                 73260  1
ghash_clmulni_intel     4701  0
serio_raw               5146  0
i2c_i801               16973  0
amd_iommu_v2            8390  1 amdkfd
intel_gtt              14002  1 i915
r8169                  77031  0
mii                     5271  1 r8169
radeon               1490294  8
hwmon                   4199  2 coretemp,radeon
ttm                    82705  1 radeon
drm_kms_helper        119698  2 i915,radeon
snd_hda_intel          30219  5
snd_hda_codec         108525  4 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_intel
drm                   323926  7 ttm,i915,drm_kms_helper,radeon
snd_hda_core           53138  5 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
agpgart                31988  3 drm,ttm,intel_gtt
snd_hwdep               6656  1 snd_hda_codec
i2c_algo_bit            6154  2 i915,radeon
fb_sys_fops             1730  1 drm_kms_helper
snd_pcm                93250  4 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel,snd_hda_core
syscopyarea             3458  1 drm_kms_helper
sysfillrect             3950  1 drm_kms_helper
sysimgblt               2608  1 drm_kms_helper
snd_timer              22402  1 snd_pcm
i2c_core               48117  7 drm,i915,i2c_i801,i2c_dev,drm_kms_helper,i2c_algo_bit,radeon
snd                    69563  17 snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec_generic,snd_hda_codec,snd_hda_intel
soundcore               6876  1 snd
mei_me                 19075  0
xhci_pci                5065  0
mei                    62863  1 mei_me
xhci_hcd              118009  1 xhci_pci
shpchp                 26680  0
wmi                     9259  0
thermal                11441  0
fan                     4535  0
8250_fintek             3214  0
tpm_tis                11588  0
tpm                    36580  1 tpm_tis
fjes                   21479  0
processor              29079  0
video                  30072  1 i915
acpi_pad               10898  0
button                  5943  1 i915
loop                   21505  0
              total        used        free      shared  buff/cache   available
Mem:        8109616      696300     6786656       21536      626660     6956988
Swap:      10485756           0    10485756
/usr/lib64/pm-utils/sleep.d/00logging hibernate hibernate: success.

Running hook /usr/lib64/pm-utils/sleep.d/00powersave hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/00powersave hibernate hibernate: success.

Running hook /usr/lib64/pm-utils/sleep.d/01grub hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/01grub hibernate hibernate: not applicable.

Running hook /usr/lib64/pm-utils/sleep.d/49bluetooth-generic hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/49bluetooth-generic hibernate hibernate: success.

Running hook /usr/lib64/pm-utils/sleep.d/49bluetooth-ibm hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/49bluetooth-ibm hibernate hibernate: not applicable.

Running hook /usr/lib64/pm-utils/sleep.d/55NetworkManager hibernate hibernate:
Having NetworkManager put all interaces to sleep...method return time=1544182385.488604 sender=:1.0 -> destination=:1.53 serial=1034 reply_serial=2
Done.
/usr/lib64/pm-utils/sleep.d/55NetworkManager hibernate hibernate: success.

Running hook /usr/lib64/pm-utils/sleep.d/75modules hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/75modules hibernate hibernate: not applicable.

Running hook /usr/lib64/pm-utils/sleep.d/90clock hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/90clock hibernate hibernate: not applicable.

Running hook /usr/lib64/pm-utils/sleep.d/94cpufreq hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/94cpufreq hibernate hibernate: success.

Running hook /usr/lib64/pm-utils/sleep.d/95led hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/95led hibernate hibernate: not applicable.

Running hook /usr/lib64/pm-utils/sleep.d/98video-quirk-db-handler hibernate hibernate:
Kernel modesetting video driver detected, not using quirks.
/usr/lib64/pm-utils/sleep.d/98video-quirk-db-handler hibernate hibernate: success.

Running hook /usr/lib64/pm-utils/sleep.d/99video hibernate hibernate:
/usr/lib64/pm-utils/sleep.d/99video hibernate hibernate: success.

Fri Dec  7 13:33:05 EET 2018: performing hibernate
Here's part of my lilo.conf:
Code:
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sdc1
  label = Linux
  read-only
  append=" resume /dev/sdc2"
/etc/fstab has
Code:
UUID=639908c4-b067-4a9a-a91d-600e086630ba none swap defaults 0 0
to handle the swap partition.
 
Old 12-07-2018, 06:56 AM   #2
Lysander666
Member
 
Registered: Apr 2017
Location: London
Distribution: Slackware 14.2 + Xfce
Posts: 903
Blog Entries: 2

Rep: Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788Reputation: 788
In lieu of a better answer, this may have something to do with the kernel. Whenever I've had issues with hibernate or suspend, it's because there is some incompatibility between my hardware and the kernel. For instance, I could not suspend on 4.4.88, but when the kernel was officially upgraded again, I had no issues. Anyway, I shall keep an eye on this thread and see what others say.
 
Old 12-07-2018, 09:55 AM   #3
allend
LQ 5k Club
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 5,051

Rep: Reputation: 1771Reputation: 1771Reputation: 1771Reputation: 1771Reputation: 1771Reputation: 1771Reputation: 1771Reputation: 1771Reputation: 1771Reputation: 1771Reputation: 1771
Try changing the line in /etc/fstab to
Code:
UUID=639908c4-b067-4a9a-a91d-600e086630ba swap swap defaults 0 0
or
Code:
/dev/sdc2 swap swap defaults 0 0

Last edited by allend; 12-07-2018 at 10:00 AM.
 
Old 12-07-2018, 10:45 AM   #4
PetruM
LQ Newbie
 
Registered: Apr 2006
Location: Cluj-Napoca, Romania
Distribution: Slackware, Ubuntu 18.04 LTS
Posts: 15

Original Poster
Rep: Reputation: Disabled
Already tried the second one, it yields the same result. Will try the first one soon.

EDIT: same thing.

Last edited by PetruM; 12-07-2018 at 03:55 PM.
 
Old 12-08-2018, 03:58 AM   #5
chrisretusn
Member
 
Registered: Dec 2005
Location: Philippines
Distribution: Slackware64-current
Posts: 880

Rep: Reputation: 332Reputation: 332Reputation: 332Reputation: 332
Quote:
Originally Posted by PetruM View Post
Here's part of my lilo.conf:
Code:
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sdc1
  label = Linux
  read-only
  append=" resume /dev/sdc2"
Try changing: append=" resume /dev/sdc2"
To: append = "resume=/dev/sdc2"
 
1 members found this post helpful.
Old 12-08-2018, 08:09 AM   #6
magicm
Member
 
Registered: May 2003
Distribution: Slackware
Posts: 149

Rep: Reputation: 88
Quote:
Like chrisretusn said: I used to have a similar append line
#append=" vt.default_utf8=0 resume=/dev/sda2"
But when I converted to using UUID and initrd I removed it, because I now build it into my initrd via this line in my mkinitrd.conf
Code:
RESUMEDEV="UUID=aaec3dc6-6df5-4442-9452-eeed013f8d03"
Here's the output of
blkid
Code:
root@igloo:~# blkid
/dev/sda1: UUID="6298dec6-6b39-4016-88c2-3f2fcb72d669" TYPE="ext4" PARTUUID="29724484-01"
/dev/sda2: UUID="aaec3dc6-6df5-4442-9452-eeed013f8d03" TYPE="swap" PARTUUID="29724484-02"
Interestingly, I don't have a swap defined in my fstab (well, I do, but it actually is from a drive that was replaced, so it can't be involved - so now I'll have to decide to remove it, or make its definition match what's running - probably the latter)

Regardless, hibernate works fine for me on 14.2 (x86_64)
 
Old 12-08-2018, 08:32 AM   #7
magicm
Member
 
Registered: May 2003
Distribution: Slackware
Posts: 149

Rep: Reputation: 88
Sorry - I may not have had enough coffee - my reply had to do with "suspend", not "hibernate" - also I use xfce
 
Old 12-10-2018, 12:30 AM   #8
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: Carrollton, Texas
Distribution: Slackware64 14.2
Posts: 3,093

Rep: Reputation: 1472Reputation: 1472Reputation: 1472Reputation: 1472Reputation: 1472Reputation: 1472Reputation: 1472Reputation: 1472Reputation: 1472Reputation: 1472
I've had no problems with lilo and hibernate on two Slackware64 14.2 computers, but I use the generic kernel and an initrd. Also note that I use LVM as well and the physical volume is encrypted.

The command I use to generate the initrd is...
Code:
$( /usr/share/mkinitrd/mkinitrd_command_generator.sh -k ${1} -a "-F -o /boot/initrd-${1}.gz -h /dev/cryptvg/swaplv" -r )
...where ${1} is the kernel version. My swap logical volume is at 16G for machine with 8G of RAM, so that's a bit of overkill. (I'll admit that I've never experimented with hibernating a machine that is massively using swap.)

The matching lilo stanza is...
Code:
# Linux bootable partition config begins
# initrd created with 'mkinitrd -c -k 4.4.157 -f ext4 -r /dev/cryptvg/rootlv -m xhci-pci:ohci-pci:ehci-pci:xhci-hcd:uhci-hcd:ehci-hcd:hid:usbhid:i2c-hid:hid_generic:hid-cherry:hid-logitech:hid-logitech-dj:hid-logitech-hidpp:hid-lenovo:hid-microsoft:hid_multitouch:jbd2:mbcache:ext4 -C /dev/sda2 -L -u -F -o /boot/initrd-4.4.157.gz -h /dev/cryptvg/swaplv'
image = /boot/vmlinuz-generic-4.4.157
  initrd = /boot/initrd-4.4.157.gz
  root = /dev/cryptvg/rootlv
  label = 4.4.157
  read-only
# Linux bootable partition config ends
That laptop hibernates just fine. The groups my primary user is in are
Code:
users lp wheel floppy video cdrom plugdev power netdev scanner docker burning
 
Old 12-10-2018, 05:50 PM   #9
hedron
Member
 
Registered: Jul 2009
Location: NYC
Distribution: Slackware64-multilib 14.2, SARPI
Posts: 294

Rep: Reputation: 27
Your swap partition must equal or exceed the amount of RAM you have.
 
  


Reply

Tags
hibernate, slackware


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Has anyone been able to get suspend/hibernate to work with Nvidia Optimus? Captain Obvious Linux - Hardware 4 01-06-2012 01:47 AM
Hibernate one distro, de-hibernate another Ulysses_ Linux - Software 8 12-28-2010 10:34 AM
[SOLVED] Cannot get to "sleep" or "hibernate" states succesfully with Slack 13.1 bogzab Slackware 14 06-03-2010 01:35 PM
13.1 Beta1 :: KDE SC 4.4.3 :: pm-hibernate works, KDE hibernate just locks the screen zordrak Slackware 7 05-12-2010 04:55 AM
cli hibernate works but gnome panel hibernate fails BCarey Linux - Desktop 1 06-08-2007 11:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration