-   Slackware (
-   -   cannot get an IP address (wireless) (

vonbiber 05-17-2013 08:19 AM

cannot get an IP address (wireless)
It used to work okay but for the last 3 or 4 days I haven't been able to get an IP address.
I get the signals all right.

What I use:
slackware 14.0 on a lenovo t430s
Connection thru Network Manager
My card is an
Intel Centrino Advanced-N 6205 AGN

Right now I'm running linux 3.9.2
I tried to revert to previous kernels (where I'm sure it worked ok) to no avail. Even on a live linux system
(SystemRescueCd 3.50) where it used to work I have the
same problem. (On SystemRescueCd 3.60 my card isn't
even detected but that's another story)

guanx 05-17-2013 09:45 AM

First try to remove /var/lib/dhcpcd/*
If that doesn't work, try to establish the link directly with wpa_supplicant and then run dhcpcd or dhclient on your wlan interface.

vonbiber 05-22-2013 03:17 AM

I tried to connect from a live linux system (wifislax) and I noticed
that some of the providers (including the one I was using) had red checks
and of course I couldn't connect to it.
Today I found another public provider and I was able to connect to it.
So I guess the problem is the ISP

All times are GMT -5. The time now is 03:03 PM.