-   Slackware (
-   -   Cannot compile mysql-workbench (

zeroberto 05-31-2011 09:59 AM

Cannot compile mysql-workbench

I'm using Slackware 13.37 x64 (upgraded to slackware-current) and I have trouble compiling mysql workbench 5.2.34.

The error is:

scintilla-marshal.c:2:25: fatal error: glib-object.h: No such file or directory
But I have that glib-object.h file:


$ locate glib-object.h

This is when I try to compile version 5.2.27:


./PlatGTK.cxx:13:21: fatal error: gdk/gdk.h: No such file or directory

$ locate gdk.h

Any suggestion?

business_kid 05-31-2011 10:46 AM


grep -n include /path/to/scintilla-marshal.c
That should show you exactly what it's looking for. As for the 5.2.27 error, gtk-1.2.x & gtk-2.x are not compatible and you may need both. gtk-2.x is certainly taking over.

zeroberto 05-31-2011 11:32 AM

The grep command gives me:

2:#include      <glib-object.h>
If I replace that with:


#include      </usr/include/glib-2.0/glib-object.h>
Then I get:


In file included from scintilla-marshal.c:2:0:
/usr/include/glib-2.0/glib-object.h:25:37: fatal error: gobject/gbinding.h: No such file or directory


$ locate gbinding.h

business_kid 06-01-2011 04:04 AM

I've never done anything with mysql, but I'm guessing you probably need gtk-2.x. It doesn't seem to like glib headers. Try reading up on compile time dependencies (different from run-time dependencies often) and make sure you have not configured it --with-something-you-haven't-got

tdos20 06-01-2011 09:55 AM

I have a feeling I had this same problem and traced it to having AlienBob's Multilib GCC installed, I "upgraded" these back to the originals and then the compilation completed, once the package was installed I re-installed the multilib compilers. The package works fine, if you need I can upload a copy somewhere

tronayne 06-01-2011 11:07 AM

Are you using the

Or, if not, maybe one of these might be missing?


This requires libsigc++, glibmm, cairomm, pangomm, gtkmm, libglademm,
ORBit2, GConf, libbonobo, gnome-mime-data, gnome-vfs, libgnome, wxGTK
or wxPython, lua.

Hope this helps some.

zeroberto 06-02-2011 12:30 AM

Yes, I always use the script from Actually, I had some similar problem compiling the libglademm, but then I downloaded the tgz package and installed it successfully.
I also have the multilib gccs from AliebBob installed. Will try later today without them to see how it goes.

tronayne 06-02-2011 08:29 AM

I'm not sure exactly when the light popped on in my head but I finally noticed that "This requires blah, blah, blah" in packages are in the order that you need to build and install them (I'd been building things in alphabetic order -- just because -- and kept having problems that got fixed by simply doing them in the order presented). Yeah, there's probably some note somewhere that tells you that but I have a bad habit of just jumping in and going for it that's been difficult for me to break.

I'd been thinking of trying MySQL Workbench for some time and your post triggered me to finally jump in and build the package and, step-by-step, I did that with no problems. I did choose wxGTK rather than wxPython (you have to choose one or the other; there's a note about interference between the two). This in straight-stock Slackware 13.37 64-bit (and sometime today I'm going to build in Slackware 13.37 32-bit on the machine I mainly use as a MySQL -- and PostgreSQL, too -- data base server). When I say straight-stock I mean a full install and the only thing I add is jdk from the extra directory on the DVD and any patches as they become available; the rest is, oh, src2pkg, VirtualBox, a few SlackBuilds here and there, (now, instead of and that's pretty much that.

Anyway, this worked for me.

Hope this helps some.

zasavage 06-02-2011 11:18 AM


Are you using multilib by any chance ?



zeroberto 06-03-2011 01:14 AM

Yes, I'm using multilib. Yesterday I installed back the gcc from DVD, but I got the same errors. Then I installed the multilib gcc again, and I was able to compile the libglademm, but I got some different error at building the mysql workbench packages. I don't remeber exactly, but it was something about libstdc++. Then I uninstalled all the compat32 packages, and I managed to brake the whole OS, so I had to reinstall it. Then on the newly installed Slackware64 (without the multilib and any other installed packages) I installed the required libraries that I built earlier but I got the same gdk error when I tried to compile the mysql workbench.

tdos20 06-03-2011 05:35 AM

Oh dear, doesn't sound like you're having much fun with this. I remember having similar problems but managed to compile it somehow, anyway heres a link to the slackpkg I used. If you have all the requirements installed you should be able to just install this pkg and then it will work (hopefully) if not it's simple to uninstall. Good luck.

zeroberto 06-03-2011 07:01 AM

Thanks tdos20, it works! It was complaining about missing libatkmm, but I installed it and it's ok now.

tdos20 06-03-2011 07:13 AM

No problem, it's quite a handy app to have if you use MySQL, can be a little buggy though so watch out.

All times are GMT -5. The time now is 06:45 AM.