-   Slackware (
-   -   Cannot compile 2.6.30 in -current, error in firmware/Makefile (

Romanus81 06-27-2009 10:19 AM

Cannot compile 2.6.30 in -current, error in firmware/Makefile
I tried compiling kernel 2.6.30 for -current but it always exits with this error:

/usr/src/test/linux-2.6.30/firmware/Makefile:163: *** multiple target patterns.  Stop.
My steps for building the kernel were

zcat /proc/config.gz > ~/kernel/2.6.30-a/.config
make O=/home/user/kernel/2.6.30-a/ oldconfig (accepted defaults for everything)
make O=/home/user/kernel/2.6.30-a/ menuconfig
make O=/home/user/kernel/2.6.30-a/

The same error occurs when I do 'make O=/home/user/kernel/2.6.30-a mrproper'

I have tried redownloading the source code, running 'make mrproper' on the source code directory, but I've gotten nothing. I'm running a pretty clean version of slackware -current.

And if anyone is wondering, the error is coming from these lines:

# Workaround for make < 3.81, where .SECONDEXPANSION doesn't work.
# It'll end up depending on these targets, so make them a PHONY rule which
# depends on _all_ the directories in $(firmware-dirs), and it'll work out OK.
PHONY += $(objtree)/$$(%) $(objtree)/$(obj)/$$(%)
$(objtree)/$$(%) $(objtree)/$(obj)/$$(%): $(firmware-dirs)

I've tried uncommenting it, but it doesn't work.

Ilgar 06-27-2009 10:53 AM

I searched for the error in Google and found this:


GNU make does not handle the spaces in the directory names given in the
generated makefiles. Gnumake instead reads a directory as two (or more
depending one the amount of spaces) targets separated by spaces.
So it may be some sort of syntax problem. Just today I compiled 2.6.30 on slackware64-current, all went fine.

Romanus81 06-27-2009 01:31 PM

that fix is for windows operating systems, I might try compiling on another linux system and seeing what happens with that.

Ilgar 06-27-2009 03:43 PM

Well yes that's why I only quoted the explanation. Your problem could be something else but my guess is that Make is misunderstanding something due to syntax error.

Bruce Hill 06-27-2009 05:40 PM

Your steps for building are not quite kosher. Additionally, you don't run "mrproper" on new source code; there will be no .o files in it.

This very simple kernel rebuild guide worked perfectly on Slackware for x86_64 with 2.6.30 for me.

mingdao@jeremiah:~/kernel$ uname -a
Linux jeremiah 2.6.30-bh #4 SMP Wed Jun 17 15:30:16 CST 2009 x86_64 Intel(R) Core(TM)2 Duo CPU    T8300  @ 2.40GHz GenuineIntel GNU/Linux

All times are GMT -5. The time now is 12:29 PM.