-   Slackware (
-   -   cannot build Mesa with --enable-gbm and vsync doesn't work on cape verde gpu (

Holering 09-03-2013 01:27 PM

cannot build Mesa with --enable-gbm and vsync doesn't work on cape verde gpu
Compiling Mesa 9.2 gives me this error:

  CC    s_atifragshader.lo
In file included from ../../../src/mesa/swrast/s_aatriangle.c:273:0:
../../../src/mesa/swrast/s_aatritemp.h: In function 'rgba_aa_tri':
../../../src/mesa/swrast/s_aatritemp.h:196:10: error: implicit declaration of function 'omp_get_thread_num' [-Werror=implicit-function-declaration]
cc1: some warnings being treated as errors
gmake[4]: *** [s_aatriangle.lo] Error 1
gmake[4]: *** Waiting for unfinished jobs....
^Cgmake[4]: *** [pack.lo] Error 1
gmake[3]: *** [all-recursive] Interrupt
gmake[2]: *** [all] Interrupt
gmake[1]: *** [all-recursive] Interrupt
make: *** [all-recursive] Interrupt

Using Slackware64 14 and installed glamor-egl and llvm-3.3 from slackware-current but always get this error. Also get it if I build with radeonsi driver support only.

Vsync doesn't even work with radeon driver and my cape verde GPU (radeon hd 7750). This is using a minimal Mesa-9.2 build without radeonsi or gbm build options.

Would appreciate any help!


WhiteWolf1776 09-03-2013 01:49 PM

Going to head out on a limb here and say... some of the deps are out of date for that build on slackware-14.

A list of them are here:

may have better luck with -current if you need the newer mesa builds.

jon lee 09-03-2013 03:21 PM

What are your ./configure options? It works for me following the LFS configure. (Although I started out with slackware, I generally follow the lfs book to upgrade anything).

You do realize one of the bindings on mesa is qt, under some circumstances you may end up having to (re)compile qt and kde against your new mesa.

Holering 09-17-2013 09:40 AM

Rebuilt entire system from source but still can't get vsync working. Actually can't get direct rendering to work now. Keep getting this error

bash-4.2$ glxinfo | grep direct
Xlib:  extension "NV-GLX" missing on display ":0.0".
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

Forgot to mention before, I used to have nvidia proprietary drivers installed before using open source radeon drivers with my new radeon hd 7750 card. Looking around the net it seems many others have had similar, if not, the same problem, switching drivers this way. Archlinux users suggest completely purging nvidia-drivers and xorg modules but I have no idea how that translates to manual administration (ala LFS).

As a note, my Mesa dependencies are up to date according to the LFS link provided with Mesa-9.2.0. Also built system using xorg from Slackware-current (64-bit).

Appreciate the responses!

Wildwizard, thanks for your help from post below! That seems to have worked. Unfortunately, open source drivers for cape verde GPU's are extremely under-developed. It appears the radeonsi driver hangs with recent git repository (mesa) including older versions, and only software rendering works. Can get better performace and what seems to be hardware acceleration with basic radeon driver, but no vsync still persists.

Have reverted to FGLRX for the time being and finally found a program that can customize and output user made edid files. This is the best program I've found to do that; it's located here: It's for Windows but haven't found anything like it for Linux. FGLRX doesn't accept custom modelines in xorg.conf (maybe one if you're lucky). For the record, OpenCL performance is outstanding in FGLRX drivers and seems to be the best around.

Going to mark this thread as solved since mesa3d needs further development for radeonsi driver.


wildwizard 09-17-2013 05:14 PM

You can find nvidia contamination in the following locations :-


And don't forget the kernel driver in


Also if your multilib enabled check the same sites in /usr/lib

All times are GMT -5. The time now is 12:58 PM.