-   Slackware (
-   -   Can someone help clarify this for me? Concerning making a DVD iso... (

barnac1e 06-04-2012 11:48 AM

Can someone help clarify this for me? Concerning making a DVD iso...
Hi, I know what I want to do and this is make a DVD installation iso of Slackware64.

I happened to find this readme:

and so I want to do the first option. I don't understand though how exactly to do those commands he says to issue from within my browser. And I specifically want Slackware64-current from this exact link:

so can someone tell me from a terminal how to use the commands from the first URL and do they need to be changed to specify Slackware64-current somewhere?

TobiSGD 06-04-2012 11:54 AM

To do that you need a local copy of the Slackware repository you want to use.
After you have downloaded the repository you can launch those commands (you don't need to adapth the for Slackware64 -current).
But it is much easier to just use AlienBobs's mirror-slackware-current-script, it automates all the tasks for you.

barnac1e 06-04-2012 11:57 AM

Okay, thanks a lot!

damgar 06-04-2012 11:59 AM

This is a couple of days old, but I don't know who's server it actually is. Googling shows several places the iso can be downloaded. Like Tobi said though, the easiest way I know is to just use Eric's script which will generate the iso's for you.

barnac1e 06-04-2012 12:03 PM

Thanks damgar!

That's what I need. I had just gone to the mirrors via and was looking from there.

By the way, assuming I get my networking going from this iso, what command do I issue to update the system? Is slapt-get a default package management in Slackware? I have only used it to install things in Salix. So could I run slapt-get update perhaps in slackware?

barnac1e 06-04-2012 12:05 PM

Well, I hate sound stupid but to use alien bob's script, how do I execute it? I tried typing as root the location of the file but that didn't work.

TracyTiger 06-04-2012 12:14 PM

Dot Slash
To run a command in the current directory, which may not be in your PATH variable, explicitly reference the current directory.


where is the file you want to execute.

Edit: The file also has to be executable ... chmod +x

TobiSGD 06-04-2012 12:21 PM

Also don't forget to make the script executable first.

Regarding slapt-get, no, it is not installed by default, but you can easily use slackpkg to keep the system up to date. just uncomment a mirror in /etc/slackpkg/mirrors and then follow the instructions here:

barnac1e 06-04-2012 12:24 PM

@Tracy Tiger

I just tried doing that as root, and I got "permission denied". Why could that be?

barnac1e 06-04-2012 12:25 PM

Oh, okay. TObiSGD, thanks. By the way, that shell script is just for slackware-current, but is there one for Slackware64-current?

TobiSGD 06-04-2012 12:37 PM

Have a look inside the script, it is well documented.
If you look inside the script you can see that you can invoke it with the -a option to specify which architecture you want, so in your case try it with

./ -a X86_64
Alternatively you can change the ARCH variable in the script or set it on the commandline to the wanted architecture.

barnac1e 06-04-2012 12:39 PM

Okay, cool. I will try that then. I will remember to first make it executable as well. I will consider this thread solved. Thanks!

barnac1e 06-04-2012 12:46 PM

Hmm... I tried the above shell script adjustment and got an error. What should I do?

root[Downloads]# ./ -a x86.64
Mon Jun 4 12:45:08 CDT 2012 [6018]: Cannot find slackware-current directory:
Use '-f' parameter to force the creation of this directory.
Aborting now...

TobiSGD 06-04-2012 12:58 PM

Exactly what is mentioned there:The script expects to be some directories to be in place. If they aren't it asks you to start the script with the -f option added, which causes the script to create those directories.

barnac1e 06-04-2012 01:01 PM

Okay, that's what I thought but just double checking.

All times are GMT -5. The time now is 09:26 PM.