-   Slackware (
-   -   Can samsung smart pc pro UEFI-boot a 32-bit slackware installation? (

michaelslack 03-25-2013 06:16 PM

Can samsung smart pc pro UEFI-boot a 32-bit slackware installation?
This may be a dumb question, but I've installed regular 32-bit slackware-current (about a month ago) using CSM/BIOS mode on a samsung smart pc pro. I didn't install (e)lilo, but rather was (CSM-)booting using the usb bootstick made during setup. Since elilo and other uefi-friendly updates have been made to slackware-current (including the newer kernel with the samsung-uefi-booting-bricking-because-of-terrible-firmware issue workarounds) I've tried to set it up to uefi-boot.

Now I've tried setting up elilo and it starts, seems to find the kernel, but then shuts down and the machine resets. It occurs to me that it may be simply because it's a 32-bit system. Is this the case?

I should add that I was prompted to ask this because of the following comment on another post:


Originally Posted by jtsn (Post 4918714)
UEFI itself is either 64 bit only or 32 bit only on x86. This is at the choice of the firmware vendor, not of user. Of course, all mainstream PC UEFI firmwares go for 64 bit, because only this is supported by Windows. The only way to get into real mode (and from there into a CPU mode of your choice) is the CSM, which emulates a BIOS.

If it should be able to boot using uefi, let me know and I'll follow up with a more detailed post including configuration etc.

Thanks in advance,


jtsn 03-27-2013 10:39 AM



Note: For Linux to access UEFI Runtime Services, the UEFI Firmware processor architecture and the Linux kernel processor architecture must match. This is independent of the bootloader used.

Note: If the UEFI Firmware arch and Linux Kernel arch are different, then the "noefi" kernel parameter must be used to avoid the kernel panic and boot successfully. The "noefi" option instructs the kernel not to access the UEFI Runtime Services.

michaelslack 03-28-2013 07:44 PM

Thanks for the reference but adding the single "noefi" kernel command-line parameter did not fix the problem.

Interestingly though, after reading this on another post:

Originally Posted by ruario (Post 4918487)
You could already do this. Just grab the 64-bit kernel and modules packages from Slackware64 (e.g. kernel-generic-3.2.29-x86_64-1 and kernel-modules-3.2.29-x86_64-1 on 14.0) and install these instead of their 32-bit counterparts.

...I succeeded in uefi-booting my 32-bit slackware system (which I had installed in CSM/legacy mode and had been CSM-booting with a usb bootstick up until now)! I used the newest huge kernel from slackware64 (and installed the kernel-modules package).

I wonder if anything else is needed - can I simply run the 32-bit system with a slackware64 kernel and forget about it? Or will I run into problems e.g. if I start trying to compile software? I guess, thinking about it Alien Bob's multilib stuff is just replacement glibc libraries etc, no change to the kernel, so I guess this is (partly) what is meant when he says slackware64 is "multilib ready"; so there probably should be no problem.



All times are GMT -5. The time now is 02:10 AM.