LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-13-2013, 07:15 AM   #1
zw963
LQ Newbie
 
Registered: Jan 2011
Posts: 12

Rep: Reputation: 0
Can not connected to a AP use Slackware 14.1 network manager


Hi, all.

I have some trouble when tried to switch to new network manager,
it always tips `... is disconnected' even when I connect to a no password AP.

But if I `chmod -x /etc/rc.d/rc.network-manager`, old script can work. (rc.inet1.conf, wpa_suppliacant.conf), so, it not drive problem.

Thank you for every help.
 
Old 11-14-2013, 05:27 AM   #2
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,881

Rep: Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045
From the email to root titled " Welcome to Linux (Slackware 14.1)! "
Quote:
With NetworkManager or wicd, it's
a good idea to remove any existing network configuration in
/etc/rc.d/rc.inet1.conf first. This can be done by running netconfig
and setting the machine to use loopback. Then, if you're using
NetworkManager run it a second time and select NetworkManager.
 
1 members found this post helpful.
Old 11-14-2013, 12:18 PM   #3
zw963
LQ Newbie
 
Registered: Jan 2011
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by allend View Post
From the email to root titled " Welcome to Linux (Slackware 14.1)! "
Thanks. I have test, it still no worked. But I found use network manager, it connnect to AP first,(get dhcped IP address) and redisconnect it.

So, is it something make network manager refuse to service for me?

btw: I use root.... relative to this ??

I have get some logs message..

```
Nov 15 01:53:22 2530p NetworkManager[711]: get_secret_flags: assertion `is_secret_prop (setting, secret_name, error)' failed
Nov 15 01:53:39 2530p dhcpcd[1711]: wlan0: no IPv6 Routers available
Nov 15 01:53:46 2530p NetworkManager[711]: <warn> Activation (wlan0) failed for connection 'TP-LINK_PocketAP_763732'
Nov 15 01:53:46 2530p NetworkManager[711]: <warn> Connection disconnected (reason -3)
Nov 15 01:53:46 2530p NetworkManager[711]: <warn> Connection disconnected (reason -3)
Nov 15 01:54:07 2530p dhcpcd[1711]: wlan0: ipv6rs_sendprobe: sendmsg: Cannot assign requested address
Nov 15 01:54:28 2530p NetworkManager[711]: <warn> Activation (wlan0) failed for connection 'TP-LINK_PocketAP_763732'
Nov 15 01:54:28 2530p NetworkManager[711]: <warn> Connection disconnected (reason -3)
Nov 15 01:54:28 2530p NetworkManager[711]: <warn> Connection disconnected (reason -3)
Nov 15 01:55:41 2530p dhcpcd[1711]: wlan0: ipv6rs_sendprobe: sendmsg: Cannot assign requested address
Nov 15 01:56:01 2530p NetworkManager[711]: <warn> Activation (wlan0) failed for connection 'TP-LINK_PocketAP_763732'
Nov 15 01:56:01 2530p NetworkManager[711]: <warn> Connection disconnected (reason -3)
Nov 15 01:56:01 2530p NetworkManager[711]: <warn> Connection disconnected (reason -3)

```
 
Old 11-14-2013, 05:19 PM   #4
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,881

Rep: Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045
Those error messages have been generated as your wlan0 interface has attempted to get an IPv6 address from your TP-LINK_PocketAP_763732 router. I suspect that they are irrelevant as you are likely using IPv4.
It suggests that NetworkManager is successfully initialising your wlan0 interface, but it is not getting the appropriate information from your router.
Have you configured your connection and connection secrets via nm-applet running in a GUI and used the Save for all users option?
 
1 members found this post helpful.
Old 11-14-2013, 11:01 PM   #5
zw963
LQ Newbie
 
Registered: Jan 2011
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by allend View Post
Those error messages have been generated as your wlan0 interface has attempted to get an IPv6 address from your TP-LINK_PocketAP_763732 router. I suspect that they are irrelevant as you are likely using IPv4.
It suggests that NetworkManager is successfully initialising your wlan0 interface, but it is not getting the appropriate information from your router.
Have you configured your connection and connection secrets via nm-applet running in a GUI and used the Save for all users option?
Thanks. I can start nm-applet GUI, and select corresponding ssid, and click to connect, it let me to input a password, I input it, it seem like connected, but later, it disconnected again, I have tested in a no password AP, it still can not connected, like previous.

>> used the Save for all users option?

Sorry, what means this ? where is ` Save for all '?
 
Old 11-14-2013, 11:37 PM   #6
allend
Senior Member
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 3,881

Rep: Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045
Quote:
Sorry, what means this ? where is ` Save for all '?
On the General tab of the connection editor, select "All users may connect to this network"

On the Wi-Fi tab, supply your SSID and set Mode to Infrastructure.
On the Wi-FI Security tab, set Security to WPA & WPA2 Personal and supply your password.
On the IPv4 Settings tab, set Method to Automatic (DHCP).
On the IPv6 Settings tab, set Method to Ignore.
 
1 members found this post helpful.
Old 11-16-2013, 05:20 AM   #7
zw963
LQ Newbie
 
Registered: Jan 2011
Posts: 12

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by allend View Post
On the General tab of the connection editor, select "All users may connect to this network"

On the Wi-Fi tab, supply your SSID and set Mode to Infrastructure.
On the Wi-FI Security tab, set Security to WPA & WPA2 Personal and supply your password.
On the IPv4 Settings tab, set Method to Automatic (DHCP).
On the IPv6 Settings tab, set Method to Ignore.
Thanks very much, I have resoved this problem by your's tips.

the problem cause is: I add a dhcpcd in my .bashrc. it cause nm can not start dhcpcd correctly.
the correct dhcpcd is /sbin/dhcpcd -B -K -L -G -c /usr/libexec/nm-dhcp-client.action -h your's hostname
but I start it use dhcpcd & because some local-connection reason...

I have another problem to resolve, here is link.
http://www.linuxquestions.org/questi...ed-4175484777/

can you help me? Thanks you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Eduroam setup in Slackware (NO Network Manager) business_kid Linux - Laptop and Netbook 2 09-20-2013 02:15 AM
[SOLVED] help with network manager in slackware 13.37 thelastblack Slackware 7 07-15-2011 09:32 AM
WICD tray icon says not connected, WICD manager says conneted to wired network?!?! intheshadows Linux - Newbie 1 12-24-2009 12:15 PM
Network manager for slackware? okos Slackware 9 07-18-2009 07:13 AM
Slackware network-manager-pptp package Cyhaxor Slackware 6 09-28-2007 10:50 PM


All times are GMT -5. The time now is 01:21 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration