-   Slackware (
-   -   Can I build usb wlan (TL-WN822N) drivers as part of kernel? (

Ongbuntu 09-18-2013 11:57 PM

Can I build usb wlan (TL-WN822N) drivers as part of kernel?

I have two questions regarding the use of TL-WN822N usb wireless from TP-LINK.

1) Can I compile the driver for TL-WN822N as part of kernel bzImage or must I build it as a module?

2) I actually tried compiling the driver as part of bzImage and receive the error that 'htc_7010.fw not found' during boot. I did include the firmware in my kernel .config under "Drivers -> General Setup -> Load Firmware..."
and also confirmed that the firmware htc_7010.fw is in the /usr/src/linux-3.2.29-test/firmware/atheros/htc_7010.fw.

I am not sure if I got this error because it is a usb device and cannot be compile as part of kernel.

would appreciate if someone can advice me on this. Thank you.


Ongbuntu 09-19-2013 12:03 AM

I think I might have posted the question under the wrong session. Intended to post it under slackware instead of slackware installation.

Would appreciate if mod can help to move the thread to the appropriate section. Thanks!


cynwulf 09-20-2013 07:04 AM

There are three hardware revisions:

I am assuming you have v2...?

It's best to just boot an existing distro/live cd and get the lsusb output - if you haven't done that already.

For v2 hardware it's the ath9k_htc module you need to build into your kernel. The firmware should be included in the kernel, but will be installed into /lib/firmware when you run 'make firmware_install'. If you want to actually build firmware into the kernel instead of allowing the module to load it from userspace, I believe that's possible, though I've never tried it myself.

I would also suggest getting the latest 3.2.x from and building that instead of 3.2.29

Ongbuntu 09-20-2013 11:45 AM

Hi cynwulf,

Thanks for the advice. I managed to build the firmware into the kernel using htc_7010.fw in /lib/firmware.

I am not too familiar with linux file system and was under the impression that the firmware should be located in /usr/src/linux-3.2.29/lib/firmware...

Just in case anyone else is trying, it works with kernel 3.2.29 :)


All times are GMT -5. The time now is 04:18 AM.