LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-01-2006, 01:57 AM   #1
nykey
Member
 
Registered: Nov 2003
Location: Tg-Jiu, Romania
Distribution: OpenSUSE 11.1 / echo "Windows XP" > Trash
Posts: 360

Rep: Reputation: 30
Can't mount CD-ROM after passed hdc=ide-scsi parameter to kernel !


Since now I've never burned a CD under Linux. Now after I installed NeroLINUX logged in as root it warned me I should pass "hdc=ide-scsi" parameter to kernel in lilo.conf (so I did), rebooted, started NeroLINUX again even erased and burned my rewritable cd smooth. Now when I wanted to check the CD to see if all files were burned and I tried to mount de CD-ROM drive I've got an error like:
Code:
root@nykey:~# mount /dev/cdrom
mount: you must specify the filesystem type
Now here is my line from /etc/fstab:
Code:
/dev/cdrom       /mnt/cdrom       auto        noauto,owner,ro  0   0
I've tried passing all fstypes I know and neither one worked. Could someone give some indications ?


<EDIT> SORRY ABOUT THIS. I've found out I only had to replace /dev/cdrom with /dev/sr0 . <EDIT>

Last edited by nykey; 06-01-2006 at 02:15 AM.
 
Old 06-01-2006, 02:33 AM   #2
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
change '/dev/cdrom' to '/dev/hdc' in your fstab and that should hopefully fix it.

regards,
...drkstr
 
Old 06-01-2006, 03:54 AM   #3
nykey
Member
 
Registered: Nov 2003
Location: Tg-Jiu, Romania
Distribution: OpenSUSE 11.1 / echo "Windows XP" > Trash
Posts: 360

Original Poster
Rep: Reputation: 30
Fixed it. Actually I had to replace /dev/cdrom with /dev/sr0. It is so obvious I'm a bit ashame for posting a thread 'bout this .
 
Old 06-01-2006, 10:20 AM   #4
dennisk
Member
 
Registered: May 2004
Location: Southwestern USA
Distribution: CentOS
Posts: 279

Rep: Reputation: 30
While NeroLINUX may require "hdc=ide-scsi" cdrecord, itself doesn't. You can easily burn CDs by running

"cdrecord -scanbus dev=ATAPI"

That will ID where your CD-ROM Drive is on the bus and

"cdrecord -v dev=ATAPI:0,0,0 someiso.iso"

Will do the actual burning, just adjust the dev= part to match the output of scanbus.

You can make the iso with

"mkisofs"

CDs are not like floppies where you put down a filesystem first than write files on top of it. with CDs everything must be done in one shot since once the dye layer is burned away you can't change it without destroying the data.

If you've burned a CD with WinXP you know that Windows opens a tmp folder and you then copy files to it. Behind the scences Windows rolls those files into an ISO than burns the ISO to the CD and deletes the ISO.

Dennisk

Last edited by dennisk; 06-01-2006 at 10:21 AM.
 
Old 06-01-2006, 05:49 PM   #5
drkstr
Senior Member
 
Registered: Feb 2006
Location: Seattle, WA: USA
Distribution: Slackware 11.0
Posts: 1,191

Rep: Reputation: 45
Quote:
Fixed it. Actually I had to replace /dev/cdrom with /dev/sr0.
Oops, my mistake. No more LQ for me when it is past my bed time.

Quote:
It is so obvious I'm a bit ashame for posting a thread 'bout this .
There's no reason to be ashamed, we all over look the obvious every once in a while. I just did this by replying without thinking it though all the way myself. In my opinion that is much worse then asking the question in the first place.

Glad you got it working!

regards,
...drkstr
 
Old 06-02-2006, 04:24 AM   #6
evilDagmar
Member
 
Registered: Mar 2005
Location: Right behind you.
Distribution: NBG, then randomed.
Posts: 480

Rep: Reputation: 31
Quote:
Originally Posted by nykey
Fixed it. Actually I had to replace /dev/cdrom with /dev/sr0. It is so obvious I'm a bit ashame for posting a thread 'bout this .
Pfft. Don't worry about it. This is still one of the most common problems people have with burners, and you posting about it means probably 2-3 people who ran into the same issue are now looking at the solution to their problem, having found this post with a search engine.
 
Old 06-02-2006, 05:06 AM   #7
nykey
Member
 
Registered: Nov 2003
Location: Tg-Jiu, Romania
Distribution: OpenSUSE 11.1 / echo "Windows XP" > Trash
Posts: 360

Original Poster
Rep: Reputation: 30
Yeah, that's a fact. Hope this helps someone. Cause now after I recompiled my kernel to v2.6 I needed to change the
Quote:
append="hdc=ide-scsi"
line in /etc/lilo.conf with
Quote:
append="hdc=ide-cd"
and modify my /etc/fstab from
Quote:
/dev/sr0 /mnt/cdrom auto noauto,users,ro 0 0
back to
Quote:
/dev/hdc /mnt/cdrom auto noauto,users,ro 0 0
because scsi emulation is no longer needed in v2.6 kernel series.
 
Old 06-03-2006, 03:26 PM   #8
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,519

Rep: Reputation: 62
I'm a little tired here, but I believe in 2.6 kernels you don't need the hdc=ide-scsi" anymore. It's been depracated. Altho I dont use the nero burner.

Last edited by Old_Fogie; 06-09-2006 at 11:48 AM.
 
Old 06-03-2006, 03:53 PM   #9
nykey
Member
 
Registered: Nov 2003
Location: Tg-Jiu, Romania
Distribution: OpenSUSE 11.1 / echo "Windows XP" > Trash
Posts: 360

Original Poster
Rep: Reputation: 30
Yeah, that's what I said, that I don't need the hdc=ide-scsi kernel parameter anymore in v2.6 kernel and switched back to hdc=ide-cd. Also replaced /dev/sr0 with /dev/cdrom. I had those options (ide-scsi and /dev/sr0) from when I had v2.4 kernel and needed emulation.
 
Old 06-03-2006, 08:55 PM   #10
Old_Fogie
Senior Member
 
Registered: Mar 2006
Distribution: SLACKWARE 4TW! =D
Posts: 1,519

Rep: Reputation: 62
oh lol, i didnt realize.

but I dont think you need to pass anything to lilo for your cd rom at all anymore.

i'm pretty sure you dont need that in your lilo anymore, the kernel should do it for you know.

Last edited by Old_Fogie; 06-09-2006 at 11:48 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
IDE-SCSI emulation on /dev/hdc mrgrieves Linux - Software 8 06-28-2004 10:23 AM
How To-enable IDE-SCSI for my CD-ROM cbjhawks Linux - Hardware 3 11-13-2003 12:52 PM
making CD-RW and CD-Rom ide-scsi ? GloVe Linux - Hardware 2 11-03-2003 02:24 PM
bad dmesg output when using ide-scsi boot parameter for IDE CD/DVD-ROM Locura Slackware 7 09-29-2003 02:36 AM
What does that mean hdc= ide - scsi dark_light Linux - General 1 07-03-2003 04:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 08:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration