-   Slackware (
-   -   Can't get internet working on Slackware 9.1, kernel 2.4.22, realtek 8139 with dhcp (

ygnas 02-27-2004 07:52 AM

Can't get internet working on Slackware 9.1, kernel 2.4.22, realtek 8139 with dhcp
Got this problem here:
DHCPD[rand-numer]: Timed-out waiting for a valid response
I'm on slack 9.1, kernel 2.4.22, NIC: Realtek 8139 i use a direct cable to connect to the internet, my dns servers/gateways/ip are assigned by dhcp, dhcp is working because i have internet on XP. I've Read the other posts @, none worked. I tried to add dns servers to resolv.conf and netconfig eth0 again. Also my NIC is recognized so i don't know what else can be wrong. Please help me.


P.S. I'm a newbie be patient :)

Mogwa_ 02-27-2004 08:03 AM

how do you connect to the internet?

you say NIC and then say diecect cable connection.

are you on cable with a network card in the pc?

ygnas 02-27-2004 08:49 AM

I connect using dhcp, with an ethernet card.

Mogwa_ 02-27-2004 09:15 AM

then you should be able to do

ifconfig eth0 down
ifconfig eth0 -dynamic up
dhcpcd -B

see what you get from that.

ygnas 02-27-2004 09:54 AM

Thanks a lot! I owe you. Could you please explain what dhcpd -B does? And what's the difrecne between ifconfig eth0 up and ifconfig eth0 -dynamic up?
Thanks again.

Mogwa_ 02-27-2004 10:11 AM

ifconfig is the tool for setting your network addapters config

ifconfig eth0 up bring the adapter up but if you use ifconfig eth0 -dynamic up it tells the adapter it will be getting a dynamic ip address.

dhcpcd is the tool for getting a dynamic ip address from the dhcp server so
when dhcpcd -B is used it sends out a request for an IP address.

buttersoft 03-02-2004 12:06 PM

Thanks also. This should be the end to my first Slack problem. Otherwise an excellent install.

All times are GMT -5. The time now is 06:47 AM.