LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 05-14-2014, 08:22 PM   #16
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: BunsenLabs Linux
Posts: 465

Original Poster
Blog Entries: 2

Rep: Reputation: 119Reputation: 119

Okey-doke:

http://imgur.com/bagnJL9

That's what I get at first- and I suspect (after actually reading the whole thing) is where the problemo lies.... Hopefully you'll have some insight on that.

If I type "exit" to continue, I get the kernel panic....but it's obviously because of the errors above....

It seems to be looking in /sbin for the initrd? Why, when I specified /boot/initrd in the initrd line of GRUB?
 
Old 05-14-2014, 08:38 PM   #17
colorpurple21859
LQ Veteran
 
Registered: Jan 2008
Location: florida panhandle
Distribution: Slackware Debian, Fedora, others
Posts: 7,470

Rep: Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619Reputation: 1619
You might have to include the module for ata1, whatever that may be, in the initrd.gz
 
1 members found this post helpful.
Old 05-14-2014, 10:12 PM   #18
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: BunsenLabs Linux
Posts: 465

Original Poster
Blog Entries: 2

Rep: Reputation: 119Reputation: 119
I sweear! My computers must be haunted or something!

I installed Crunchbang on anotherr partition on the laptop. I configured Slackware's LILO to boot the Crunchbang.....but the entry doesn't even show up in the boot menu....

I've wasted DAYS trying to dual boot Crunchbang and Slackware, with LILO and Grub...and nothing works!

WTH is going on here???!!!!!!
 
Old 05-15-2014, 12:04 AM   #19
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: BunsenLabs Linux
Posts: 465

Original Poster
Blog Entries: 2

Rep: Reputation: 119Reputation: 119
[Not the topic of this thread...but related] -S.G.

Well guys, at least I got the laptop's LILO figured out!

It seems, the trick is, when dual-booting another Linux distro with Slackware/LILO:

First, temporarily mount the other OS's filesystem in /mnt on Slackware.
Then, set up the entry for the new OS in /etc/lilo.conf, specifying the path to the other OS's kernel and initrd(if used) through /mnt - i.e.

Code:
image = /mnt/boot/<vmlinuz.name of other OS's kernel>
Then run

Code:
/sbin/lilo
Then go back and edit the lilo.conf entry for the new OS, by removing the /mnt path....

DO NOT run /sbin/lilo again after doing the above!

Reboot and choose the new entry for your other OS...and VIOLA[sic]!

Why this works? Apparently, the /sbin/lilo when updating/checking the new entry, only sees kernels in the host OS (the one which contains LILO). So when it sees "/boot/vmlinuz.whatever, it looks in Slackware's /boot only...doesn't see the other OS's kernelk there, and thus returns an error and doesn't add the other OS to the bootlist.

By mounting the other OS's filesystem and then specifying that path, we trick /sbin/lilo into finding the kernel.

Then we remove the /mnt path, because obviously the other OS's filesystem won't be there after we exit Slackware; but LILO will indeed see it when actually booting.

_______

So...the laptop is now booting Slackware and Crunchbang with LILO.

That was relatively fast!

NOW if I could just figure out the why GRUB won't boot Slackware on the desktop.

I'll wait and see if you guys come up with anything on that (I think Richard Cranium may figure it out) and if not....I'll just boot the desktop's Slackware up in huge kernel, and install LILO on the desktop, now that I at least know how to get LILO to boot Crunchbang.

Darn, this has been a ridiculous waste of time!

Last edited by Sumguy; 05-15-2014 at 11:47 AM. Reason: Added "Not the topic of this thread"
 
Old 05-15-2014, 11:44 AM   #20
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: BunsenLabs Linux
Posts: 465

Original Poster
Blog Entries: 2

Rep: Reputation: 119Reputation: 119
Thumbs up

And...

VIOLA[sic]!

I FINALLY SOLVED THE GRUB2 PROBLEM!!!!!!!

I'm posting this from my desktop right now...in Slackware on the generic kernel!!!!

What did I do, you may ask?

Last night, I booted up Slack with the huge kernel (the only way I could boot it from GRUB) and deleted the initrd.gz file, and then used the mkinitrd_command_generator.sh to generate a new initrd.gz - then tried booting into the generic kernel from Crunchbang/GRUB2, without even changing my Grub.cfg entries (still had the old entry for the generic kernel, which wasn't working before)...and here I am.

It was as simple as that!

Woo-hooo! Now I can rest!

My thanks to everyone who tried to help! Gotta love this forum!
 
Old 05-15-2014, 12:35 PM   #21
Richard Cranium
Senior Member
 
Registered: Apr 2009
Location: McKinney, Texas
Distribution: Slackware64 15.0
Posts: 3,858

Rep: Reputation: 2225Reputation: 2225Reputation: 2225Reputation: 2225Reputation: 2225Reputation: 2225Reputation: 2225Reputation: 2225Reputation: 2225Reputation: 2225Reputation: 2225
Cool. The error message in the picture that you had posted implied that grub couldn't/didn't find your initrd but I didn't get around to making a post telling you that.

I'm glad that you solved it. A lot of our problems are due to attention to detail. I cannot tell you how many times I've upgraded/changed my kernel and forgotten to re-run lilo. (That's why I changed over to grub since I can interactively set up the boot after I *bleeped* it up.)

There should be a "thumbs up" smiley. (I guess that would be rude in some other cultures, though.)
 
Old 05-15-2014, 01:08 PM   #22
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-15.0
Posts: 11,113

Rep: Reputation: Disabled
Quote:
Originally Posted by Sumguy View Post
And...

VIOLA[sic]!
Et voilą! (be careful when spelling French words :-)
 
Old 05-15-2014, 03:07 PM   #23
Sumguy
Member
 
Registered: Jul 2010
Location: Rural Kentucky, USA.
Distribution: BunsenLabs Linux
Posts: 465

Original Poster
Blog Entries: 2

Rep: Reputation: 119Reputation: 119
Quote:
Originally Posted by Didier Spaier View Post
Et voilą! (be careful when spelling French words :-)
I know...I do it on purpose- I was listening to an online radio broadcast by this man who is pretty intelligent; with only a high-school education, he has argued 6 cases before the Supreme Court on his own behalf- and won three of them... and yet, reading from a book on his radio show, when he came to "voilą", he said "viola" (Not on-purpose. And it wasn't a book about stringed musical instruments... )

I thought that was the funniest darn thing I had ever heard...so I'm just spreading the humor.

Quote:
Originally Posted by Richard Cranium View Post
Cool. The error message in the picture that you had posted implied that grub couldn't/didn't find your initrd but I didn't get around to making a post telling you that.

I'm glad that you solved it. A lot of our problems are due to attention to detail. I cannot tell you how many times I've upgraded/changed my kernel and forgotten to re-run lilo. (That's why I changed over to grub since I can interactively set up the boot after I *bleeped* it up.)

There should be a "thumbs up" smiley. (I guess that would be rude in some other cultures, though.)
LOL. Thank.

I'll tell ya, I was just about ready to throw in the towel! [Trouble was, I couldn't decide if I should do so by: Deleting Slackware; Throwing my computer out the window; or a .12-gauge slug to the head!]
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] setting up initrd / generic kernel in Grub2...can't load generic Ubunoob001 Slackware 12 03-20-2015 07:32 AM
Help regarding dual boot slack 14 with other Linux (uses grub/grub2 and UUID) Lilgamesh Slackware 5 04-03-2013 02:14 PM
Generic vs Huge kernel in Slack 12 techyranger Slackware 4 01-23-2008 01:30 PM
slack 12, switch to generic kernel from huge kernel, using grub? jaguarrh Slackware 8 09-19-2007 06:29 AM
Slack 11 kernel-generic-2.6.17.13 file sys error during bootup acummings Slackware 2 04-25-2007 10:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration