LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 04-05-2006, 10:42 AM   #1
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Rep: Reputation: 30
Can't get a network connection


Hello,

I have used Linux for a number of years. I started with Red Hat 9 and went up through Fedora. I recently decided to try Slackware. I installed Slackware 10.2 on a seperate partition and everything installed fine. However I can't get my network to see anything beyond itself. The connection works fine on Fedora.

I have a SBC DSL connection. I am connected via ethernet to a SpeedStream 4100 DSL Modem. The modem says it is configured with PPP on the modem. I tried netconfig and nothing. I manually configured /etc/rc.d/rc.inet1.conf to show only DHCP="yes". I configured it with a static IP address. I set it to 192.168.0.2 on one attempt and 192.168.0.10 on another. My modems IP address is 192.168.0.1. I can ping the loopback, 127.0.0.1 and I can ping the static IP when set, but I can't even ping the modem. Not even when I set the GATEWAY="192.168.0.1"

Any suggestions. I have run out of ideas.
 
Old 04-05-2006, 11:06 AM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Umm..have you set any network masks? Probably not the case, but it just might prevent you from "seeing" somewhere..
 
Old 04-05-2006, 11:11 AM   #3
b0nd
Senior Member
 
Registered: Jan 2005
Distribution: Slackware, BackTrack, Windows XP
Posts: 1,020

Rep: Reputation: 45
Quote:
Originally Posted by JMJ_coder
I can ping the loopback, 127.0.0.1
you can ping that even if you don't have NIC.

Quote:
and I can ping the static IP when set, but I can't even ping the modem. Not even when I set the GATEWAY="192.168.0.1"
successfully pinging yourself (static IP) indicates that NIC is working fine.
So issue may be that IP forwarding kinda thing is not working.

post the "Ethernet" section part of your "config" file.
/usr/src/linux version/.config

Edit: ya, as bOuncer said........network mask too could be the problem


regards

Last edited by b0nd; 04-05-2006 at 11:13 AM.
 
Old 04-05-2006, 11:47 AM   #4
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Original Poster
Rep: Reputation: 30
I can't find any netmask information. The modem information page doesn't seem to provide it and on Slackware, it can't get that information, I think, until it connects to a DHCP server. When I set the static IP the mask was 255.255.255.0.

Here is the Ethernet section of /usr/src/linux-2.4.31/.config:

#
# Ethernet (10 or 100Mbit)
#
CONFIG_NET_ETHERNET=y
# CONFIG_SUNLANCE is not set
CONFIG_HAPPYMEAL=m
# CONFIG_SUNBMAC is not set
# CONFIG_SUNQE is not set
CONFIG_SUNGEM=m
CONFIG_NET_VENDOR_3COM=y
CONFIG_EL1=m
CONFIG_EL2=m
CONFIG_ELPLUS=m
CONFIG_EL16=m
CONFIG_EL3=m
CONFIG_3C515=m
# CONFIG_ELMC is not set
# CONFIG_ELMC_II is not set
CONFIG_VORTEX=m
CONFIG_TYPHOON=m
CONFIG_LANCE=m
CONFIG_NET_VENDOR_SMC=y
CONFIG_WD80x3=m
# CONFIG_ULTRAMCA is not set
CONFIG_ULTRA=m
# CONFIG_ULTRA32 is not set
CONFIG_SMC9194=m
CONFIG_NET_VENDOR_RACAL=y
CONFIG_NI5010=m
CONFIG_NI52=m
CONFIG_NI65=m
CONFIG_AT1700=m
CONFIG_DEPCA=m
CONFIG_HP100=m
CONFIG_NET_ISA=y
CONFIG_E2100=m
CONFIG_EWRK3=m
CONFIG_EEXPRESS=m
CONFIG_EEXPRESS_PRO=m
CONFIG_HPLAN_PLUS=m
CONFIG_HPLAN=m
CONFIG_LP486E=m
CONFIG_ETH16I=m
CONFIG_NE2000=m
CONFIG_NET_PCI=y
CONFIG_PCNET32=m
CONFIG_AMD8111_ETH=m
CONFIG_ADAPTEC_STARFIRE=m
CONFIG_AC3200=m
CONFIG_APRICOT=m
CONFIG_B44=m
CONFIG_CS89x0=m
CONFIG_TULIP=m
# CONFIG_TULIP_MWI is not set
# CONFIG_TULIP_MMIO is not set
CONFIG_DE4X5=m
CONFIG_DGRS=m
CONFIG_DM9102=m
CONFIG_EEPRO100=m
# CONFIG_EEPRO100_PIO is not set
CONFIG_E100=m
# CONFIG_LNE390 is not set
CONFIG_FEALNX=m
CONFIG_NATSEMI=m
CONFIG_NE2K_PCI=m
CONFIG_FORCEDETH=m
# CONFIG_NE3210 is not set
# CONFIG_ES3210 is not set
CONFIG_8139CP=m
CONFIG_8139TOO=m
# CONFIG_8139TOO_PIO is not set
CONFIG_8139TOO_TUNE_TWISTER=y
CONFIG_8139TOO_8129=y
# CONFIG_8139_OLD_RX_RESET is not set
CONFIG_SIS900=m
CONFIG_EPIC100=m
CONFIG_SUNDANCE=m
# CONFIG_SUNDANCE_MMIO is not set
CONFIG_TLAN=m
CONFIG_VIA_RHINE=m
# CONFIG_VIA_RHINE_MMIO is not set
CONFIG_WINBOND_840=m
CONFIG_NET_POCKET=y
CONFIG_ATP=m
CONFIG_DE600=m
CONFIG_DE620=m

#
# Ethernet (1000 Mbit)
#
CONFIG_ACENIC=m
# CONFIG_ACENIC_OMIT_TIGON_I is not set
CONFIG_DL2K=m
CONFIG_E1000=m
# CONFIG_E1000_NAPI is not set
# CONFIG_MYRI_SBUS is not set
CONFIG_NS83820=m
CONFIG_HAMACHI=m
CONFIG_YELLOWFIN=m
CONFIG_R8169=m
CONFIG_SK98LIN=m
CONFIG_TIGON3=m
CONFIG_FDDI=y
CONFIG_DEFXX=m
CONFIG_SKFP=m
# CONFIG_HIPPI is not set
CONFIG_PLIP=m
CONFIG_PPP=m
CONFIG_PPP_MULTILINK=y
CONFIG_PPP_FILTER=y
CONFIG_PPP_ASYNC=m
CONFIG_PPP_SYNC_TTY=m
CONFIG_PPP_DEFLATE=m
CONFIG_PPP_BSDCOMP=m
CONFIG_PPPOE=m
CONFIG_SLIP=m
CONFIG_SLIP_COMPRESSED=y
CONFIG_SLIP_SMART=y
# CONFIG_SLIP_MODE_SLIP6 is not set
 
Old 04-05-2006, 12:55 PM   #5
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: SlackwareŽ
Posts: 13,731
Blog Entries: 37

Rep: Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916
Quote:
Originally Posted by JMJ_coder
Hello,

I have used Linux for a number of years. I started with Red Hat 9 and went up through Fedora. I recently decided to try Slackware. I installed Slackware 10.2 on a seperate partition and everything installed fine. However I can't get my network to see anything beyond itself. The connection works fine on Fedora.

I have a SBC DSL connection. I am connected via ethernet to a SpeedStream 4100 DSL Modem. The modem says it is configured with PPP on the modem. I tried netconfig and nothing. I manually configured /etc/rc.d/rc.inet1.conf to show only DHCP="yes". I configured it with a static IP address. I set it to 192.168.0.2 on one attempt and 192.168.0.10 on another. My modems IP address is 192.168.0.1. I can ping the loopback, 127.0.0.1 and I can ping the static IP when set, but I can't even ping the modem. Not even when I set the GATEWAY="192.168.0.1"

Any suggestions. I have run out of ideas.
Hi,

What is the output of;

Code:
#dmesg |grep eth
#ifconfig -a
#route -n               #edit 04-06-06

Last edited by onebuck; 04-06-2006 at 06:05 AM.
 
Old 04-05-2006, 02:08 PM   #6
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Original Poster
Rep: Reputation: 30
Hello,

dmseg |grep eth0 shows eth0 link up

ifconfig -a shows eth0 but no IP address. Only
UP BROADCAST RUNNING MULTICAST

route will only show loopback and won't accept route -a as a valid command.

I initiated IP Fowarding with
#/etc/rc.d/rc.ip_forward start

still nothing.
 
Old 04-05-2006, 02:23 PM   #7
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
dhcpcd eth0
 
Old 04-05-2006, 02:30 PM   #8
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Original Poster
Rep: Reputation: 30
Hello,

Already tried

dhcpcd eth0

DHCP is initialized but doesn't assign me an IP address.
 
Old 04-06-2006, 06:04 AM   #9
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: SlackwareŽ
Posts: 13,731
Blog Entries: 37

Rep: Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916
Quote:
Originally Posted by JMJ_coder
Hello,

dmseg |grep eth0 shows eth0 link up

ifconfig -a shows eth0 but no IP address. Only
UP BROADCAST RUNNING MULTICAST

route will only show loopback and won't accept route -a as a valid command.

I initiated IP Fowarding with
#/etc/rc.d/rc.ip_forward start

still nothing.
Hi,

Sorry about the typo!

Should be route -n .

If your are not showing a route then the dhcp is not functioning.

Whey are you initiating ip_forward ?
 
Old 04-06-2006, 08:33 AM   #10
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Original Poster
Rep: Reputation: 30
Hello,

The command

#route -n

returns only the loopback.


I also tried

#dhclient

which returned:

No broadcast interfaces found - exiting

and

#dhclient eth0

which returned:

eth0 not found.

If the DHCP is not working, how do I fix it?
 
Old 04-06-2006, 09:58 AM   #11
mdarby
Member
 
Registered: Nov 2004
Location: Columbus, Ohio
Distribution: Slackware-Current / Debian
Posts: 795

Rep: Reputation: 30
Code:
ifconfig eth0 up
dhcpcd eth0
?
 
Old 04-08-2006, 06:39 PM   #12
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Original Poster
Rep: Reputation: 30
Sorry, I've been away.

No the commands

Code:
ifconfig eth0 up
dhcpcd eth0
do not work.

ifconfig eth0 up
does bring eth0 up, but it doesn't have an ip address.
dhcpcd eth0 seems to work (i.e. no errors) but after a minute it is done and still no ip address. I think it is timing out.

I looked and I think the netmask is 255.255.255.0
that is what it is set to in Fedora which has a working network connection.

Perhaps I need to edit a config file.

I have edited /etc/rc.d/rc.inet1.conf and entered
USE_DHCP[0]="yes"
and
GATEWAY="192.168.0.1"
 
Old 04-09-2006, 07:18 AM   #13
onebuck
Moderator
 
Registered: Jan 2005
Location: Summer Midwest USA, Central Illinois, Winter Central Florida
Distribution: SlackwareŽ
Posts: 13,731
Blog Entries: 37

Rep: Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916Reputation: 2916
Quote:
Originally Posted by JMJ_coder
Sorry, I've been away.

No the commands

Code:
ifconfig eth0 up
dhcpcd eth0
do not work.

ifconfig eth0 up
does bring eth0 up, but it doesn't have an ip address.
dhcpcd eth0 seems to work (i.e. no errors) but after a minute it is done and still no ip address. I think it is timing out.

I looked and I think the netmask is 255.255.255.0
that is what it is set to in Fedora which has a working network connection.

Perhaps I need to edit a config file.

I have edited /etc/rc.d/rc.inet1.conf and entered
USE_DHCP[0]="yes"
and
GATEWAY="192.168.0.1"

Hi,

Might I suggest that you try a static IP setup first.

edit: edit the /etc/rc.d/init1.conf and disable dhcp=no for now

Code:
#ifconfig eth0 192.168.0.10       #setup IP
#route add default gw 192.168.0.1 #gateway
#ping 192.168.0.1                 #ping gw
#ping google.com                  #ping to test dns
#ping 64.233.187.99               #ping ip

note: if the ping google.com fails then the dns is not setup properly. Edit /etc/resolv.conf to show your dns.
You could edit the /etc/rc.d/rc.init1.conf to reflect the static information and then just do ;
Code:
#/etc/rc.d/rc.inet1 restart
If you get the static to work then you can go back and setup for dhcp.

BTW, is your router setup with WEP and MAC filtering? If so then disable the functions until you get the link setup. After that you can enable WEP and Mac filtering.

Last edited by onebuck; 04-09-2006 at 07:21 AM.
 
Old 04-09-2006, 06:05 PM   #14
JMJ_coder
Member
 
Registered: Apr 2006
Distribution: Fedora
Posts: 478

Original Poster
Rep: Reputation: 30
Hello,

I set up the static IP and gateway. But no connection. I don't understand. There is a physical connection and I configure it to be on the same local LAN, but it will not ping at all.

I don't have a router. It is a DSL Modem, SpeedStream 4100. It is configured with PPPoE on the modem. The connection works fine with Windows XP (at least it did when I used to have Windows) and Fedora. So it does work, but not under Slackware so far.

The first issue that needs to be addressed is just basic connectivity between my NIC, a Netgear FA311/FA312 and the DSL Modem. Until I can ping the modem (IP 192.168.0.1, netmask 255.255.0.0), the issue of trying to reach a DHCP server seems moot.
 
Old 04-09-2006, 11:37 PM   #15
Alien_Hominid
Senior Member
 
Registered: Oct 2005
Location: Lithuania
Distribution: Hybrid
Posts: 2,247

Rep: Reputation: 53
Are you sure your modem didn't broke somehow. If you have a possibility, try using live cd and check if the problem disappears.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
network connection bayonetblaha Ubuntu 2 02-05-2006 02:09 PM
network connection Ammad Linux - General 1 09-11-2005 01:07 PM
Network Connection InsaneBob Linux - Software 2 08-30-2003 06:26 PM
Network Connection Lucsi Linux - Newbie 1 07-15-2002 06:16 AM
Connection to network tohhwee Linux - Networking 2 05-04-2001 11:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 05:24 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration