LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-08-2004, 06:47 PM   #1
dvm
Member
 
Registered: Sep 2004
Posts: 62

Rep: Reputation: 16
can't connect to internet through PPP


Hi to everyone, this is my first post on the forum, so please bear with me.
I've installed Slack 10.0 a few weeks ago and finally after a lot of reinstallations and experimenting (I also had to set up greek, see I'm Greek) and a bad memory chip I think I've got a pretty good configuration (for now).

My last big problem is connecting to the Internet through PPP. I have two pc's (the other running WinXP) which are connected in a LAN. Each of the pc's has each own modem (US Robotics on the XP, Supra on the slack). The Windows box is succesfully sharing its 'net connection through the classic 192.168.0.1-2 thing. I do have internet when XP gets connected.

The problem is I can't get my slack to see the 'net when I use the modem on that machine. I can connect to my ISP with KPPP and ping the remote machine but that's all. I can't even ping the nameservers the ISP has given me. I could connect after changing the /etc/ppp/options file and asked noauth for PAP. But still I can't get to a web site (I can't even send or receive e-mail).

I think it should have something to do with the firewall settings but have no idea how to change them. Does anyone have any idea? Thanks in advance for you time guys.
 
Old 09-08-2004, 06:56 PM   #2
blk96gt
Member
 
Registered: Jun 2004
Location: Nacogdoches, TX
Distribution: Ubuntu 7.04
Posts: 230

Rep: Reputation: 30
Have you tried using pppsetup to do some of the configuration? When I had to get my girlfriends modem working, I had the same problems that you're having. It would get connected, but I wasn't able to go anywhere. The problem I ended up having was that I didn't have the nameservers correct. I ended up running pppsetup first to configure, and then using kppp to dial in. I'm not sure how much sense this makes or help much it will help, but it's worth a shot.
 
Old 09-08-2004, 07:15 PM   #3
dvm
Member
 
Registered: Sep 2004
Posts: 62

Original Poster
Rep: Reputation: 16
Thanks for the reply but no, no luck! It completely re-worked my /etc/ppp/options file and still had to uncomment noauth (I guess this has to do with my ISP) but the same thing hapens, connection established but no 'net. With further reading I've uncovered this:

If pppd refuses to set up a default route, it is because (quite correctly) it refuses to remove/replace an existing default route.
The usual reason that this error occurs is that some distributions set up a default route via your Ethernet card as opposed to setting up a specific network route.
See the Linux NAG and the Net2/3 HOWTOs for information on correctly setting up your Ethernet card and associated routes.
An alternative to this is that your LAN uses a gateway/router already and your routing table has been set up to point the default route at this.
Fixing up this last situation can require a fair bit of IP networking knowledge and is beyond the scope of this HOWTO. It is suggested you obtain some expert advice (via the news groups of from someone locally you can ask).

Anyone?
 
Old 09-10-2004, 07:49 AM   #4
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 309

Rep: Reputation: 31
echo "1025 4096" > /proc/sys/net/ipv4/ip_local_port_range

some ISPs think that all the people in the world should use windows
 
Old 09-10-2004, 06:34 PM   #5
dvm
Member
 
Registered: Sep 2004
Posts: 62

Original Poster
Rep: Reputation: 16
I think my ports are already open. Doing a
"cat /proc/sys/net/ipv4/ip_local_port_range" produced:
1024 4999
which is already greater than the range you are suggesting me. Also I don't know if this matters but I have been able to connect in the past to my ISP with SuSE linux. I still think it's a firewall problem. I'm reading "Running Linux" but I don't want to change the order and jump straight to security. I'm still back in the "configuring X" chapter. Thanks for your help anyway.

PS. Does anyone know how I poweroff the computer? I've tried poweroff and halt and shutdown -h now but all stop after wrighting Power Down or something and the computer stays on until I press the button on the box. I think my kernel is compiled with APM. It's the default 2.4.26 kernel of slack 10.
 
Old 09-11-2004, 12:26 AM   #6
theMonkeY
Member
 
Registered: Jun 2004
Posts: 58

Rep: Reputation: 15
for the power problem:
edit /etc/rc.d/rc.modules

and uncomment (remove the leading #) from /sbin/modprobe apm

for the net problem:
if it is a firewall issue, see if the file /etc/rc.firewall exists. If it does, move it somewhere else for now so that any startup scripts cannot start it. Try that for one session and see if it works.

If the internet happens to work with rc.firewall removed, re-post here.
 
Old 09-12-2004, 12:30 PM   #7
dvm
Member
 
Registered: Sep 2004
Posts: 62

Original Poster
Rep: Reputation: 16
Nope, couldn't find a /etc/rc.firewall script. Does this mean that I don't use a firewall? I guess it must be the gateway problem I mentioned above. I'll try to look more into it once I have the time. Thanks for the apm answer, worked like a charm ;-)
 
Old 09-13-2004, 03:55 AM   #8
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 309

Rep: Reputation: 31
I think that the problem is with the default route.
try this way:
ifconfig eth0 down
add the name server in /etc/resolv.conf
start the modem link
If it start working we'll find something and for the net card
 
Old 09-13-2004, 06:40 AM   #9
db391
Member
 
Registered: Jun 2004
Location: Britain
Distribution: Slackware
Posts: 186

Rep: Reputation: 31
its an issue of correctly setting up /etc/ppp/options and /etc/ppp/pap-secrets:

your /etc/ppp/options shuold look like this:

/dev/ttyS0
connect 'chat -v "" AT OK ATDT08456614681 CONNECT'
username myusername
defaultroute
usepeerdns
auth

also /etc/ppp/pap-secrets i dont remember the exact syntax but its like:

echo '"myusername" * "mypassword" *' > /etc/ppp/pap-secrets

then to connect just type pppd
and to disconnect type killall pppd.

to know if you connected properly type tail /var/log/messages where you should get four IP addresses.
 
Old 09-13-2004, 06:42 AM   #10
db391
Member
 
Registered: Jun 2004
Location: Britain
Distribution: Slackware
Posts: 186

Rep: Reputation: 31
Quote:
some ISPs think that all the people in the world should use windows
well those isps suck!! use tiscali as they are (unofficially) linux compatible.
 
Old 09-13-2004, 07:26 PM   #11
dvm
Member
 
Registered: Sep 2004
Posts: 62

Original Poster
Rep: Reputation: 16
Thanks Ipolit, your answer has fixed my problem. This is my first post with a direct connection from my linux box.
Can you be so kind now to tell me how to change the default route when the modem goes up and reset the old route when it goes down? Even though I don't find it pretty hard to do an "ifconfig eth0 down". The purpose of connecting with the second modem was so I wouldn't have to open the winxp box in the first place. But sometimes samba is usefull. I do plan on reading the NAG how-to but it's quite huge and I'm still reading Running Linux and doing a dissertation so I don't have much time for that as well.

Once again, greatly appreciate it mate!

PS: Thanks to everyone else as well for trying!

Last edited by dvm; 09-13-2004 at 07:27 PM.
 
Old 09-14-2004, 01:50 AM   #12
Ipolit
Member
 
Registered: Nov 2003
Location: Bulgaria
Distribution: Vector Linux, Morphix
Posts: 309

Rep: Reputation: 31
try this
netconfig
and when it asks you for your gateway don't put anything
but you won't be able to access Internet with Slack Box through your windows machine
Luck
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with ppp connect please_die Red Hat 4 05-14-2005 03:07 AM
I've got a OK ppp connection, but cannot connect anywhere! minike Slackware 21 04-15-2005 04:13 PM
gnome-ppp ,howto use command line to connect internet lupang Linux - Software 0 04-11-2005 03:50 AM
Machines connect to my ppp server but can´t use internet gomen Linux - Networking 0 08-08-2003 06:35 AM
PPP won't Connect CalcAE Linux - Networking 1 06-16-2002 06:18 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 06:52 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration