LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 09-03-2010, 04:31 AM   #61
GazL
LQ Guru
 
Registered: May 2008
Distribution: CRUX
Posts: 5,548
Blog Entries: 14

Rep: Reputation: 3394Reputation: 3394Reputation: 3394Reputation: 3394Reputation: 3394Reputation: 3394Reputation: 3394Reputation: 3394Reputation: 3394Reputation: 3394Reputation: 3394

Quote:
Originally Posted by sahko View Post
Is nv of any use now that theres nouveau?
Although personally i wouldnt bother installing it, it seems worthless now.
I don't believe 'nv' is of much use. From what I remember I think the xorg guys were recommending that anyone still using 'nv' use 'vesa' instead as it's better maintained. I certainly found my card (a GT140) runs better on the 'vesa' driver than it does with 'nv'.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 09-03-2010, 05:11 AM   #62
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, fedora,Xubuntu, others
Posts: 4,661

Rep: Reputation: 836Reputation: 836Reputation: 836Reputation: 836Reputation: 836Reputation: 836Reputation: 836
I've never used nv. Used either vesa driver or Nvidia's drivers. The nv driver has always shifted the display 3/4 off the screen with my video card. With the nouveau driver loaded during bootup, X(without a xorg.conf) and xorgsetup insist on using the nv driver .
 
Old 09-03-2010, 05:15 AM   #63
ponce
LQ Guru
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 5,597

Rep: Reputation: Disabled
you can try
Code:
removepkg xf86-video-nv
then
Code:
X -configure
 
Old 09-03-2010, 11:00 AM   #64
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 2,479

Original Poster
Rep: Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084
Thanks, dolphin77 - good information.
I just uploaded a radeon_ucode package for those who need it - it's in the same directory as the other stuff.
 
Old 09-03-2010, 01:24 PM   #65
allend
LQ 5k Club
 
Registered: Oct 2003
Location: Melbourne
Distribution: Slackware-current
Posts: 5,448

Rep: Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034Reputation: 2034
Just joined the party!
Quote:
01:00.0 VGA compatible controller: nVidia Corporation G72 [GeForce 7300 LE] (rev a1)
When I first started X without a /etc/X11/xorg.conf file, the VESA driver was selected for use. This worked, but on logout the terminal screen was being started about halfway across the screen.
Created a minimal xorg.conf file.
Code:
Section "Device"
    Identifier     "Device1"
    Driver         "nouveau"
EndSection
With the nouveau driver things are working well as a 2D display (so no desktop effects that depend on compositing).
glxinfo reports "direct rendering: Yes"
I am able to switch between the X display and the six virtual consoles without problem although I need to get used to using Alt-F8 to get back to the X display instead of Alt-F7.
My two monitors were correctly detected and can be manipulated using xrandr.
Keyboard and mouse are fine.

In short - All OK to date.
 
Old 09-03-2010, 03:19 PM   #66
erjc
LQ Newbie
 
Registered: Aug 2010
Posts: 4

Rep: Reputation: 1
Quote:
Originally Posted by GazL View Post
I don't believe 'nv' is of much use. From what I remember I think the xorg guys were recommending that anyone still using 'nv' use 'vesa' instead as it's better maintained.
nv is entirely dependent on corporate support and NVIDIA have clearly lost interest.

http://en.wikipedia.org/wiki/Graphic...nd_FOSS#NVIDIA

Quote:
Originally Posted by dolphin77 View Post
For those who runs 2.6.35.x on a notebook, powersaving is now working. All you need to do is add additional option dynclks=1
Code:
root@darkstar:/home/vladimir# cat /etc/modprobe.d/radeon.conf 
options radeon modeset=1 dynclks=1
and the line
Code:
echo mid > /sys/class/drm/card0/device/power_profile
for example to rc.local.

After this KDE effects still works, but the machine produces much less heat and doesn't roll the fan most of the time.
Inital pm stuff went in .35, more coming in .36.
Handle with care.

http://wiki.x.org/wiki/radeonBuildHo...wer-management

Quote:
Originally Posted by igadoter View Post
Code:
direct rendering: Yes
This is now useless info as software rendering reports "yes" as well.

LIBGL_DEBUG=verbose glxinfo | grep OpenGL

will give useful info.

Last edited by erjc; 09-03-2010 at 05:49 PM. Reason: typo, cut/paste foobarage
 
Old 09-03-2010, 04:15 PM   #67
igadoter
Senior Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: many, primary Slackware
Posts: 1,596
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
This is now useless info as software rendering reports "yes" as well.

LIBGL_DEBUG=verbose & glxinfo | grep OpenGL

will give useful info.
Thank you. This may explain why I am unable to allow desktop effects on KDE 4.5.1 (AlienBob's packages). I may have only software rendering despite the fact that my Intel card has support for OpenGL.

Last edited by igadoter; 09-03-2010 at 04:19 PM. Reason: addons
 
Old 09-04-2010, 03:09 AM   #68
shadowx
LQ Newbie
 
Registered: Feb 2010
Location: Bulgaria
Distribution: Slackware
Posts: 10

Rep: Reputation: 3
Thumbs up testing report

The new packages seem to work without any problems on slackware64-current with custom 2.6.35 kernel /Video card is nvidia 8200 onboard/ and the latest nvidia driver (256.53).

Last edited by shadowx; 09-04-2010 at 03:44 PM. Reason: fixed a typo
 
Old 09-04-2010, 04:02 AM   #69
Daedra
Senior Member
 
Registered: Dec 2005
Location: Springfield, MO
Distribution: Slackware64-14.2
Posts: 1,620

Rep: Reputation: 424Reputation: 424Reputation: 424Reputation: 424Reputation: 424
I got around to trying nouveau and it seems to be working fine.

Thanks for these packages Robby
 
Old 09-04-2010, 08:52 AM   #70
wadsworth
Member
 
Registered: Aug 2007
Distribution: Slackware64 13.37
Posts: 215

Rep: Reputation: 65
I'm using an nvidia 9600GT and kernel 2.6.35.4.

First attempt with nouveau driver and KMS enabled resulted in a completely corrupted display
and a locked-up computer. I was unable to switch to another VT, but could reboot with "Alt+SysRq+{r,e,i,s,u,b}"

Second attempt, I passed "nomodeset" to the kernel (disabling KMS) and the nouveau driver seemed to work fine.
I had 3D acceleration enabled and performance was good.

I then had to re-blacklist the nouveau driver in order to use the nvidia proprietary drivers (256.53).

I think I could switch to the nouveau drivers, if I could slow down the GPU fan.
(Stay away from video cards with loud fans!)

Last edited by wadsworth; 09-04-2010 at 09:02 AM.
 
Old 09-05-2010, 01:55 PM   #71
erjc
LQ Newbie
 
Registered: Aug 2010
Posts: 4

Rep: Reputation: 1
Looks like the KDE guys need to start talking to the Xorg/Mesa/Kernel driver guys.

http://blog.martin-graesslin.com/blo...orkspaces-4-5/
 
1 members found this post helpful.
Old 09-05-2010, 11:01 PM   #72
rworkman
Slackware Contributor
 
Registered: Oct 2004
Location: Tuscaloosa, Alabama (USA)
Distribution: Slackware
Posts: 2,479

Original Poster
Rep: Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084Reputation: 1084
Quote:
Originally Posted by erjc View Post
Looks like the KDE guys need to start talking to the Xorg/Mesa/Kernel driver guys.

http://blog.martin-graesslin.com/blo...orkspaces-4-5/
Yes indeed. With my new Xorg stuff, I can't start kde-4.5.1 at all unless I disable compositing completely:

Code:
$ cat /etc/X11/xorg.conf.d/no-composite.conf 
Section "Extensions"
  Option "Composite" "Disable"
EndSection
I don't normally use kde anyway, so this isn't a showstopper for *me* - but I suspect some folks won't like it at all :-)
 
Old 09-06-2010, 09:16 PM   #73
TSquaredF
Member
 
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 544

Rep: Reputation: Disabled
I'm using these packages on two computers, a Toshiba laptop:
Quote:
$ /sbin/lspci | grep VGA
01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
and an HP desktop:
Quote:
/sbin/lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation 82G33/G31 Express Integrated Graphics Controller (rev 02)
I'm also using Eric's KDE-4.5.X packages. I am the only user of the laptop, where I'm using KMS, & I turn off desktop effects anyway, so all worked well there. However, it worked for me on the desktop, but would not start KDE for the other two users of the machine. It would start fluxbox & XFCE, so it didn't take more than a day or so for me to realize that I had to turn off KDE's desktop effects for the other users. Now all is well for everyone.
Regards,
Bill
 
Old 09-06-2010, 11:18 PM   #74
tomtomjkw
Member
 
Registered: Jan 2008
Distribution: Slackware64-current
Posts: 146

Rep: Reputation: 33
Hi

Quote:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03)
Kde 4.5.1, desktop effects off. Another boring, flawless update. Thx Robby.
 
Old 09-07-2010, 02:06 AM   #75
igadoter
Senior Member
 
Registered: Sep 2006
Location: wroclaw, poland
Distribution: many, primary Slackware
Posts: 1,596
Blog Entries: 1

Rep: Reputation: Disabled
Quote:
Originally Posted by tomtomjkw View Post
Hi
Kde 4.5.1, desktop effects off. Another boring, flawless update. Thx Robby.
For me the same. KDE doesn't work with desktop effects enabled. I have an Intel 82.. card.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No updates in Testing? war1025 Debian 2 07-08-2009 12:16 PM
[Call for testing] ibus SlackBuild grissiom Slackware 6 05-19-2009 10:39 AM
Testing is inadequate for new updates Lsatenstein Fedora 3 12-24-2006 11:19 AM
security updates for testing branch uselpa Debian 4 09-15-2006 01:09 AM
Anyone tried 2.6.11 in updates/testing ? snecklifter Fedora 7 04-08-2005 09:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration