-   Slackware (
-   -   Call for testing - MATE SlackBuilds (

chess 03-22-2013 12:04 PM

Call for testing - MATE SlackBuilds
I've created an initial set of SlackBuild scripts to build and install MATE desktop environment 1.5 (development branch) on Slackware. I'd greatly appreciate testers, suggestions, patches etc.

Screenshots here:

Github repo:

willysr 03-22-2013 12:15 PM

cloning and start building it :)


dugan 03-22-2013 12:27 PM

Did you tell Pat? Remember, he's promised support to whoever starts this project.

chess 03-22-2013 12:30 PM

Thanks willysr - @dugan yes I emailed back and forth w/ Pat about it a few days ago but I'll drop him another email now that I've made it public. Thanks for the reminder. And, I would definitely like this to be a community project so contributors etc. are welcome. Most people around here are a lot smarter than me so I'm sure the scripts will be greatly improved with other people's input. Thanks!

willysr 03-22-2013 12:46 PM

Chess, i think this line caused some minor problem:

PACKAGE="$(ls -t $TMP/$(ls ${package}*.{xz,bz2,tar.gz} | rev | cut -f2- -d - | rev)-*txz | head -n 1)"
it caused this kind of output
ls: cannot access mate-doc-utils*.bz2: No such file or directory
ls: cannot access mate-doc-utils*.tar.gz: No such file or directory

chess 03-22-2013 12:48 PM

@willysr - yes, it's a harmless error. the script is using the source to determine the package name. Most of the sources are .tar.xz but some are bz2 and others are .tar.gz. Everything installs ok. I'll work on the build script though.

willysr 03-22-2013 12:54 PM

what if you used a wildcard of "*" such as:

PACKAGE="$(ls -t $TMP/$(ls ${package}*.* | rev | cut -f2- -d - | rev)-*txz | head -n 1)"

ponce 03-22-2013 12:56 PM

I just noticed a minor thing in extra/mate-applets.SlackBuild: at the end it runs a find with some arguments, but the last (mate-invest-applet) is not there, so I changed the find line to avoid interrupting the script

find $PKG/usr/share/mate/help/$i/* -maxdepth 0 -type d ! -name C -exec rm -rf {} \; || true
EDIT: mate-document-viewer requires mate-keyring.

EDIT2: forgot to say I tried these on slackware64-current.

chess 03-22-2013 01:01 PM

@willysr - yes, I had considered that - just need to make sure it won't accidentally install a package with a partial name, e.g. package-foo and package-foo-bar. But something like that should work.

@ ponce - thanks for that - I'll make that fix.

ponce 03-22-2013 01:09 PM


Originally Posted by willysr (Post 4916643)
what if you used a wildcard of "*" such as:

PACKAGE="$(ls -t $TMP/$(ls ${package}*.* | rev | cut -f2- -d - | rev)-*txz | head -n 1)"

for this seems to me that Pat does

to extract the VERSION fom the sources tarball, like

VERSION=${VERSION:-$(echo $PKGNAM-*.tar.?z* | rev | cut -f 3- -d . | cut -f 1 -d - | rev)}
maybe can be useful in assembling the package name :)

ponce 03-22-2013 01:31 PM

also mate-power-manager, like mate-document-viewer, needs mate-keyring.

Bazzaah 03-22-2013 01:45 PM

I may well give this a go - I used to like Gnome2.

One question if I may - can you disable tooltips in Mate? Y'know, those annoying little boxes that pop to tell you something obvious? :)

willysr 03-22-2013 01:49 PM

Yes, i think mate-keyring and libmatekeyring should be on extra since it's needed by some modules in extra mentioned by ponce

Myk267 03-22-2013 01:58 PM

Thanks for the this, chess! I installed base and the faenza icon set, and everything's running smooth and fast so far.

Edit: Compiled and installed on Slackware 14, 64 bit!

chess 03-22-2013 02:15 PM

@ponce - I'll change the build script, thanks. Good suggestion. As to mate-keyring, hm, upstream told me that the packages would pick up gnome-keyring which is included in Slackware default. I'll need to look at those compile flags again or move mate-keyring and libmatekeyring back into /base.

All times are GMT -5. The time now is 07:32 AM.