LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 11-15-2015, 12:36 PM   #1
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,972

Rep: Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231
Call for testers: SlackBuild Scripts for letsencrypt


I have pushed my letsencrypt SlackBuild script on my personal github account (letsencrypt branch) and have a public beta testing before i push it to SBo.

Basically you need 4 additional new python modules (already submitted to SBo and still in pending) before you can install letsencrypt.

The letsencrypt SlackBuild itself will install apache and nginx plugins in it's default location.

Any suggestion for improvements are welcome
 
Old 12-03-2015, 07:14 AM   #2
StreamThreader
Member
 
Registered: Mar 2012
Location: Ukraine/Odesa
Distribution: Slackware
Posts: 130

Rep: Reputation: 13
Letsencrypt open public beta.

Anybody tested this slackbuild script?
 
Old 12-03-2015, 11:50 AM   #3
suppy
Member
 
Registered: Mar 2012
Location: Sweden
Distribution: Slackware
Posts: 83

Rep: Reputation: 58
I intend to in the next few days, when I have the time
 
Old 12-03-2015, 01:02 PM   #4
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,972

Original Poster
Rep: Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231
i rebased to the latest SBo updates and bump it to 0.1.0 (public beta). Not really tested against new dependencies, since it was released like 1d ago, but i will do more test this weekend

The SlackBuild script can be found here: https://github.com/willysr/slackbuil...em/letsencrypt

Last edited by willysr; 12-03-2015 at 01:09 PM.
 
3 members found this post helpful.
Old 12-04-2015, 06:41 AM   #5
Lucifer4o
Member
 
Registered: Mar 2010
Distribution: Slackware Current
Posts: 54

Rep: Reputation: 16
So .. I tried it. And it will not work:

Code:
Traceback (most recent call last):
  File "/usr/bin/letsencrypt", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib64/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 2603, in <module>
  File "/usr/lib64/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 666, in require
  File "/usr/lib64/python2.7/site-packages/setuptools-0.6c11-py2.7.egg/pkg_resources.py", line 565, in resolve
pkg_resources.DistributionNotFound: six
 
Old 12-04-2015, 06:48 AM   #6
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,972

Original Poster
Rep: Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231
Please note that those deps are first level dep only, so you need to build the queue for all deps so that it resolves
 
Old 12-04-2015, 07:14 AM   #7
Chuck56
Member
 
Registered: Dec 2006
Location: Colorado
Distribution: Slackware
Posts: 510

Rep: Reputation: 106Reputation: 106
What's not to like about a "free, automated, and open certificate authority (CA)"?

Thanks for posting about this and the slackbuild willysr. This looks like a great alternative to self-signed certificates. I'm going test drive this over the weekend.
 
Old 12-04-2015, 07:20 AM   #8
Lucifer4o
Member
 
Registered: Mar 2010
Distribution: Slackware Current
Posts: 54

Rep: Reputation: 16
OK. I did resolve them, but it appears there is packages that are not in your list of dependancies:

Python/six
libraries/ipaddress
Python/pyasn1
Python/idna

Last edited by Lucifer4o; 12-04-2015 at 07:24 AM.
 
1 members found this post helpful.
Old 12-04-2015, 08:00 AM   #9
Lucifer4o
Member
 
Registered: Mar 2010
Distribution: Slackware Current
Posts: 54

Rep: Reputation: 16
OK ... so using the webroot authentication I was able to receive certificates ... and then I was unable to install them.

Quote:
[Fri Dec 04 15:54:50.002263 2015] [ssl:emerg] [pid 5861:tid 140183934678912] SSL Library Error: error:140E6118:SSL routines:SSL_CIPHER_PROCESS_RULESTR:invalid command
[Fri Dec 04 15:56:53.005593 2015] [ssl:emerg] [pid 5882:tid 140143487276928] AH01898: Unable to configure permitted SSL ciphers
[Fri Dec 04 15:56:53.005627 2015] [ssl:emerg] [pid 5882:tid 140143487276928] SSL Library Error: error:0906D06C:PEM routines:PEM_read_bio:no start line (Expecting: DH PARAMETERS) -- Bad file contents or format - or even just a forgotten SSLCertificateKeyFile?
[Fri Dec 04 15:56:53.005640 2015] [ssl:emerg] [pid 5882:tid 140143487276928] SSL Library Error: error:0906D06C:PEM routines:PEM_read_bio:no start line (Expecting: EC PARAMETERS) -- Bad file contents or format - or even just a forgotten SSLCertificateKeyFile?
[Fri Dec 04 15:56:53.005654 2015] [ssl:emerg] [pid 5882:tid 140143487276928] SSL Library Error: error:140E6118:SSL routines:SSL_CIPHER_PROCESS_RULESTR:invalid command
Never mind! This was entirely my issue!

All works well ... we only need apache plugin (or comprehensive guide how to make it work!)

Last edited by Lucifer4o; 12-04-2015 at 09:30 AM.
 
Old 12-04-2015, 10:58 AM   #10
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,972

Original Poster
Rep: Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231
Quote:
Originally Posted by Lucifer4o View Post
OK. I did resolve them, but it appears there is packages that are not in your list of dependancies:

Python/six
libraries/ipaddress
Python/pyasn1
Python/idna
this is what i get from sqg:
Quote:
configobj
mock
python-requests
pytz
python2-pythondialog
pysetuptools
zope.interface
zope.event
zope.component
pyrfc3339
idna
ipaddress
enum34
six
pycparser
cffi
pyasn1
cryptography
pyOpenSSL
psutil
python-parsedatetime
python-configargparse
werkzeug
ndg_httpsclient
augeas
python-augeas
pyparsing
 
1 members found this post helpful.
Old 12-04-2015, 10:59 AM   #11
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,972

Original Poster
Rep: Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231
Quote:
Originally Posted by Lucifer4o View Post
All works well ... we only need apache plugin (or comprehensive guide how to make it work!)
Apache Plugin is also installed on my build script, but it was designed for ubuntu's apache
 
Old 12-04-2015, 11:22 AM   #12
Lucifer4o
Member
 
Registered: Mar 2010
Distribution: Slackware Current
Posts: 54

Rep: Reputation: 16
Your script is working great ... all else is "Let's encrypt"'s problem (don't mind me - sometimes I ask before I search).
 
Old 12-06-2015, 12:02 PM   #13
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,972

Original Poster
Rep: Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231
I updated the README for more detailed information about obtaining the certificates and renewal process
You can grab the latest one here: https://github.com/willysr/slackbuilds/tree/letsencrypt
 
1 members found this post helpful.
Old 12-08-2015, 03:48 AM   #14
StreamThreader
Member
 
Registered: Mar 2012
Location: Ukraine/Odesa
Distribution: Slackware
Posts: 130

Rep: Reputation: 13
willysr thanks you!
Letsencrypt slackbuild script worked. Dependencies very important, and all it exist on slackbuilds.org.
 
Old 12-08-2015, 10:37 AM   #15
willysr
Senior Member
 
Registered: Jul 2004
Location: Jogja, Indonesia
Distribution: Slackware-Current
Posts: 3,972

Original Poster
Rep: Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231Reputation: 1231
Quote:
Originally Posted by StreamThreader View Post
willysr thanks you!
Letsencrypt slackbuild script worked. Dependencies very important, and all it exist on slackbuilds.org.
Thanks for testing
Now it's in pending queue
 
1 members found this post helpful.
  


Reply

Tags
letsencrypt


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox Text-to-Speech addon call for testers romagnolo Linux - Software 7 10-06-2014 10:22 AM
Call for Testers: MATE 1.8 willysr Slackware 137 08-06-2014 01:50 AM
Call for Testers: Cinnamon SlackBuilds willysr Slackware 72 06-05-2014 04:08 PM
Teslagrad Linux alpha: call for testers kabamaru Linux - Games 1 07-10-2013 01:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 10:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration