-   Slackware (
-   -   Cairo Dock error "No protocol specified". Docky Gtk cannot open display: :0 (

nando321 02-02-2013 02:26 PM

Cairo Dock error "No protocol specified". Docky Gtk cannot open display: :0
Hello again. This time I am trying to find out what's going on with Cairo Dock and Docky, when I type in the terminal as root and as non-root (normal user) as well I get that output for Cairo Dock:

No protocol specified
And Docky:

[Info 16:17:33.908] Docky version: 2.1.0 bzr stacks-2.1.0 r1556
[Info 16:17:33.943] Kernel version:
[Info 16:17:33.943] CLR version: 2.0.50727.1433
No protocol specified
[Warn 16:17:33.984] [Gtk] cannot open display: :0
The Docky packages that I've installed are from .deb's to .tgz's that I could convert using alien (I boot the Ubuntu Live DVD, install alien and do the convertion).
What I couldn't do though is install the packages of cairo using sbopkg, I can add them to the queue and download them but the building always fails.

So, that's all I can tell you about it. Any ideas will be appreciated.
Thanks in advance.

nando321 02-02-2013 04:41 PM

I've got something now. By removing and installing cairo-dock again and its plugins it is working now but I've already had a big fight with this message before and nothing could fix it. This is the damned window that appears every time I log in:

Do you want to activate OpenGL?
(To not show this dialog, launch the dock from the Application menu,
or with the -o option to force OpenGL and -c to force cairo.)
I'm telling ya, I've tried all the options with this but nothing solved the problem I tried disabling cairo from the startup, I tried "cairo-dock -c -o", "cairo-dock -c", "cairo-dock -o -c" but none of this options have worked out the problem!

All times are GMT -5. The time now is 03:20 PM.