LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 08-11-2019, 01:28 PM   #1
BerzinTehvs
Member
 
Registered: Mar 2005
Location: Latvia
Distribution: Slackware
Posts: 54

Rep: Reputation: 15
Bulding of kernel 4.19.66 on Slack64-14.2


Hi!
I have a strange problem: when I try to build k4.19.66 on one of my Slackware64 14.2 boxes, i get an error:

CALL scripts/checksyscalls.sh
DESCEND objtool
In file included from <stdin>:1:0:
/usr/include/libelf/libelf.h:28:5: error: "__LIBELF_INTERNAL__" is not defined [-Werror=undef]
#if __LIBELF_INTERNAL__

I can not find any obvious differences among boxes (all are up-to-date), except the one - the box with problem is upgraded from 14.2, the other were clean-installed.
 
Old 08-11-2019, 08:51 PM   #2
ehartman
Member
 
Registered: Jul 2007
Location: Delft, The Netherlands
Distribution: Slackware
Posts: 830

Rep: Reputation: 406Reputation: 406Reputation: 406Reputation: 406Reputation: 406
Quote:
Originally Posted by BerzinTehvs View Post
except the one - the box with problem is upgraded from 14.2, the other were clean-installed.
Upgraded from 14.2 to -current or from 14.1 to 14.2 ??
And did you install the (optional, in /extra) llvm 8.0 package (for 14.2)?
 
Old 08-14-2019, 10:23 AM   #3
BerzinTehvs
Member
 
Registered: Mar 2005
Location: Latvia
Distribution: Slackware
Posts: 54

Original Poster
Rep: Reputation: 15
No, I upgraded from 14.1 to 14.2

and no - llvm8 does not help.

Last edited by BerzinTehvs; 08-14-2019 at 10:28 AM.
 
Old 08-14-2019, 12:13 PM   #4
Labinnah
Member
 
Registered: May 2014
Location: Łódź, Poland
Distribution: Slackware-current
Posts: 126

Rep: Reputation: 71
You probably have old libelf library installed. In Slackware now is elfutils witch provide libelf.h header.

If you still wand use libelf, maybe this patch helps you:
https://github.com/NixOS/nixpkgs/pul...0c18b161832471
 
Old 08-14-2019, 12:23 PM   #5
BerzinTehvs
Member
 
Registered: Mar 2005
Location: Latvia
Distribution: Slackware
Posts: 54

Original Poster
Rep: Reputation: 15
I will try to re-install evrth under devel first - all clean installed 14.2 boxes do not have such problem.
 
Old 08-14-2019, 12:36 PM   #6
Labinnah
Member
 
Registered: May 2014
Location: Łódź, Poland
Distribution: Slackware-current
Posts: 126

Rep: Reputation: 71
Problem is not what you not installed, but what you don't uninstalled. libelf was replaced by elfutils between 14.1 and 14.2. If you not installed libelf deliberately you should remove it.
Code:
+--------------------------+
Fri Aug 21 21:17:48 UTC 2015
...
l/elfutils-0.163-x86_64-1.txz: Added.
...
l/libelf-0.8.13-x86_64-5.txz: Removed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
bulding only a kernel and shell imagine_me2 Linux - Kernel 4 08-05-2010 05:51 AM
Bulding a new kernal, ramdisk os 48MB BIG?????? wufo Ubuntu 0 01-24-2009 01:24 PM
gonna start bulding lfs 6. advice needed liljhand Linux From Scratch 5 02-20-2005 01:34 PM
bulding a gcc toolchain with uclibc behmjose Programming 1 02-29-2004 09:54 PM
Bulding SMP file server artur Linux - General 3 04-17-2002 01:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration