LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Slackware (http://www.linuxquestions.org/questions/forumdisplay.php?f=14)
-   -   Building xorg.conf from scratch :-) (http://www.linuxquestions.org/questions/showthread.php?t=4175446484)

slacktroll 01-20-2013 01:17 PM

Building xorg.conf from scratch :-)
 
So hello everyone. I guess no one else on this forum wants a legacy xorg.conf but i do. Please take opinions in another thread. This is simply for building a nice and clean xorg.conf without the need of ugly /usr/share/X11/xorg.conf.d/ directory, udev.

My xorg.conf looks like this at the moment:
Code:

Section "Device"
      Option    "DRI"                "true" # [<bool>]
      Option    "ColorKey"                  #     
      Option    "VideoKey"                  # <i>
      Option    "FallbackDebug"      "false"      # [<bool>]
      Option    "Tiling"            "true"        # [<bool>]
      Option    "LinearFramebuffer"  "true"      # [<bool>] 
      Option    "Shadow"            "false"        # [<bool>]
      Option    "SwapbuffersWait"    "false"        # [<bool>]
      Option    "TripleBuffer"      "false"      # [<bool>]
      Option    "XvMC"                      # [<bool>]     
      Option    "XvPreferOverlay"          # [<bool>]
      Option    "DebugFlushBatches" "false"        # [<bool>]
      Option    "DebugFlushCaches"  "false"        # [<bool>]
      Option    "DebugWait"          "false"        # [<bool>]
      Option    "HotPlug"            "true"      # [<bool>]
      Option    "RelaxedFencing"    "true"        # [<bool>]
      Option    "BufferCache"        "true" # [<bool>]       
      Option    "Throttle" "false"
      Option    "ZaphodHeads" "LVDS1" #ignored :(
      Option      "AccelMethod"  "sna" #ignore :(

      Identifier  "Card0"
      Driver      "intel"
      BusID      "PCI:0:2:0"

EndSection
Section "Screen"
 Identifier "Default Screen"
 Device "Card0"
 Monitor "Generic Monitor"
 DefaultDepth 24
 SubSection "Display"
  Depth 16
  Modes "1024x768"
 EndSubSection
 SubSection "Display"
  Depth 24
  Modes "1024x768"
 EndSubSection
EndSection

Obvious, the autoconfiguration for xorg is just stupid, the above settings will improve performance very much on a intel card hence the stupid default settings (such as vsync debug crap etc).

Any thoughts or addons?
Purpose is to be able to disable udev completely as i don't want to follow systemd and udev things in the future.

Didier Spaier 01-20-2013 04:52 PM

I think you are missing the options for your keyboard and pointing device, among others.

I would just do a "grep Option /var/log/Xorg.0.log", change the options which imply udev's usage, and write all options in the config file. Else you can take xorg.conf-vesa as a basis.

In addition you will have to populate yourself the /dev directory and load all the kernel modules you need, but I assume that you are well aware of that.

There may be other caveat, like you won't be able to use an initrd to start Linux (it seems).

FWIW I quote below CHANGES_AND_HINTS.TXT from Slackware 13.37:
Code:

The Slackware installer uses udev to initialize your hardware, including the
  network interface card(s).  This has positive consequences for network 
  installations (using NFS, FTP, HTTP or SMB).  You no longer have to run the 
  'pcmcia' and 'network' scripts prior to running 'setup' - the network 
  interface will be created and intialized by udev.  If a DHCP server is 
  found on your local network, the setup program will let you choose between 
  automatic configuration of your network interface using DHCP or specifying 
  a static IP address.  Using udev, the commandline for fully unattended 
  configuration and startup of the dropbear SSH server has changed slightly. 
  Suppose you want to boot the 'hugesmp' kernel, use DHCP for interface eth0,
  and you have a us-english keyboard layout: the commandline to auto-start 
  the SSH daemon in the installer would become: 
      hugesmp.s kbd=us nic=auto:eth0:dhcp
  Note: if you do not want to use udev, the "auto" keyword in that example 
  commandline must be replaced with the actual name of the network module for 
  your card.  If you do not want to use udev, you must add the parameter 
  "noudev" to the command line that boots the Slackware installer, and the
  original ("old") Slackware hardware configuration scripts will be used.
  Also note that this is not supported...


STDOUBT 01-20-2013 06:50 PM

Quote:

Originally Posted by slacktroll (Post 4874205)
Purpose is to be able to disable udev completely as i don't want to follow systemd and udev things in the future.

Excuse me for bumping in, slacktroll, but I am wondering if it has been confirmed that Slackware will be "forced" to take in systemd and etcetera? I feel much like you do, which is "old school" is "best school". However, I don't have the technical prowess nor the time to "beat Slackware into submission" (like I used to do with Windows many moons ago) if it becomes one of those 'operating system 2.0' monstrosities. I would be more inclined to just say "F-it!", and switch to a BSD. Lennart Pottering and his ilk are a scourge, IMO, and I am highly skeptical about the direction of GNU/Linux in general.

the3dfxdude 01-20-2013 07:54 PM

I also have a question as I have just been reading about mdev. How do the BSD folks create their xorg.conf under the latest Xorg? I can only assume they fall back to more of a traditional approach. Here is one reason, see evdev under mdev notes: http://wiki.gentoo.org/wiki/Mdev#Notes

What's the deal with Xorg using a linux-centric udev? In the event that BSD doesn't have udev, then there has to be another 'way'. Considering we used to use an xorg.conf, I don't think we loose anything by not using udev.

Also, I was just comparing xfce's session manager between 4.6 and 4.10, and it's sad that it lost 'the somewhat usable' HAL, to a less featureful xfce when we aren't on red-hat-centric systemd.

Oh, I almost forgot to mention, there is still /etc/X11/xorg.conf-vesa as a starting point.


All times are GMT -5. The time now is 02:47 PM.