LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-04-2013, 04:33 PM   #1
aalireza
LQ Newbie
 
Registered: Jan 2011
Posts: 15

Rep: Reputation: 0
Building problem of "some" 32-bit programs in Slackware64 multilib


Hello,
Following the instructions in "http://alien.slackbook.org/dokuwiki/doku.php?id=slackware:multilib", I have managed to install Skype through Sbopkg. But somehow I'm unable to install some packages like "yawp":
Code:
Processing yawp

yawp:
Found yawp-0.4.3.tar.bz2 in /var/cache/sbopkg.
Checking MD5SUM:
  MD5SUM check for yawp-0.4.3.tar.bz2 ... OK
Building package for yawp...
yawp-0.4.3/
yawp-0.4.3/config.h.in
yawp-0.4.3/LICENSE-GPL2
yawp-0.4.3/po/
yawp-0.4.3/po/tr.po
yawp-0.4.3/po/sort_list.sh
yawp-0.4.3/po/fr.po
yawp-0.4.3/po/plasma_applet_yawp.pot
yawp-0.4.3/po/cs.po
yawp-0.4.3/po/af.po
yawp-0.4.3/po/ru.po
yawp-0.4.3/po/sk.po
yawp-0.4.3/po/CMakeLists.txt
yawp-0.4.3/po/es.po
yawp-0.4.3/po/sl.po
yawp-0.4.3/po/it.po
yawp-0.4.3/po/he.po
yawp-0.4.3/po/pl.po
yawp-0.4.3/po/uk.po
yawp-0.4.3/po/extract_messages.sh
yawp-0.4.3/po/lists/
yawp-0.4.3/po/lists/days_long.list
yawp-0.4.3/po/lists/wind.list
yawp-0.4.3/po/lists/weather.list
yawp-0.4.3/po/lists/pressure.list
yawp-0.4.3/po/lists/us_states.list
yawp-0.4.3/po/lists/days.list
yawp-0.4.3/po/lists/countries.list
yawp-0.4.3/po/add_new_weather_strings.sh
yawp-0.4.3/po/de.po
yawp-0.4.3/applet/
yawp-0.4.3/applet/pageanimator.h
yawp-0.4.3/applet/us_states.lst
yawp-0.4.3/applet/yawpresource.qrc
yawp-0.4.3/applet/configdialog/
yawp-0.4.3/applet/configdialog/dlgaddcity.h
yawp-0.4.3/applet/configdialog/yawpconfig.h
yawp-0.4.3/applet/configdialog/dlgtimezone.h
yawp-0.4.3/applet/configdialog/yawpconfig.cpp
yawp-0.4.3/applet/configdialog/dlgtimezone.cpp
yawp-0.4.3/applet/configdialog/dlgaddcity.cpp
yawp-0.4.3/applet/weatherservice.cpp
yawp-0.4.3/applet/paneldesktopinterface.h
yawp-0.4.3/applet/yawp.cpp
yawp-0.4.3/applet/yawpday.h
yawp-0.4.3/applet/yawp_theme15.svg
yawp-0.4.3/applet/utils.h
yawp-0.4.3/applet/yawpdefines.h
yawp-0.4.3/applet/CMakeLists.txt
yawp-0.4.3/applet/weatherdataprocessor.h
yawp-0.4.3/applet/painter/
yawp-0.4.3/applet/painter/panelpainter.cpp
yawp-0.4.3/applet/painter/desktoppainter.cpp
yawp-0.4.3/applet/painter/desktoppainter.h
yawp-0.4.3/applet/painter/abstractpainter.h
yawp-0.4.3/applet/painter/panelpainter.h
yawp-0.4.3/applet/painter/abstractpainter.cpp
yawp-0.4.3/applet/statemachine.h
yawp-0.4.3/applet/yawp.h
yawp-0.4.3/applet/yawpdefines.cpp
yawp-0.4.3/applet/weatherservice.h
yawp-0.4.3/applet/ionlistmodel.cpp
yawp-0.4.3/applet/utils.cpp
yawp-0.4.3/applet/plasma-applet-yawp.desktop.in
yawp-0.4.3/applet/countries.lst
yawp-0.4.3/applet/paneldesktopinterface.cpp
yawp-0.4.3/applet/countrymap.cpp
yawp-0.4.3/applet/yawpday.cpp
yawp-0.4.3/applet/pageanimator.cpp
yawp-0.4.3/applet/statemachine.cpp
yawp-0.4.3/applet/iconnames.conf
yawp-0.4.3/applet/countrymap.h
yawp-0.4.3/applet/ionlistmodel.h
yawp-0.4.3/applet/weatherdataprocessor.cpp
yawp-0.4.3/applet/ui/
yawp-0.4.3/applet/ui/dlgaddcity.ui
yawp-0.4.3/applet/ui/yawpsettingspage.ui
yawp-0.4.3/applet/ui/yawppanelpage.ui
yawp-0.4.3/applet/ui/yawplocationspage.ui
yawp-0.4.3/applet/ui/yawpthemepage.ui
yawp-0.4.3/applet/ui/dlgtimezone.ui
yawp-0.4.3/make_svg_icons.sh
yawp-0.4.3/CMakeLists.txt
yawp-0.4.3/logger/
yawp-0.4.3/logger/streamlogger_definitions.h.in
yawp-0.4.3/logger/CMakeLists.txt
yawp-0.4.3/logger/streamlogger.cpp
yawp-0.4.3/logger/streamlogger.h
yawp-0.4.3/CHANGELOG
yawp-0.4.3/COPYRIGHT
yawp-0.4.3/LICENSE-LGPL-2
yawp-0.4.3/Messages.sh
yawp-0.4.3/TODO
yawp-0.4.3/LICENSE-BSD
yawp-0.4.3/install.sh
yawp-0.4.3/unittest/
yawp-0.4.3/unittest/iontest.h
yawp-0.4.3/unittest/weatherenginetest.cpp
yawp-0.4.3/unittest/iontest.cpp
yawp-0.4.3/unittest/weatherenginetest.h
yawp-0.4.3/unittest/CMakeLists.txt
yawp-0.4.3/unittest/streamloggertest.cpp
yawp-0.4.3/unittest/plasmoidtest_fullview.h
yawp-0.4.3/unittest/weatherservicetest.cpp
yawp-0.4.3/unittest/configtest.cpp
yawp-0.4.3/unittest/plasmoidtest_main.cpp
yawp-0.4.3/unittest/plasmoidtest_fullview.cpp
yawp-0.4.3/ions/
yawp-0.4.3/ions/ion_google.cpp
yawp-0.4.3/ions/ion_accuweather.h
yawp-0.4.3/ions/units.h
yawp-0.4.3/ions/kde43/
yawp-0.4.3/ions/kde43/ion-wunderground.desktop
yawp-0.4.3/ions/kde43/ion-google.desktop
yawp-0.4.3/ions/kde43/ion-accuweather.desktop
yawp-0.4.3/ions/CMakeLists.txt
yawp-0.4.3/ions/ion-wunderground.desktop
yawp-0.4.3/ions/ion_wunderground.cpp
yawp-0.4.3/ions/ion-google.desktop
yawp-0.4.3/ions/ion-accuweather.desktop
yawp-0.4.3/ions/ion_wunderground.h
yawp-0.4.3/ions/ion_google.h
yawp-0.4.3/ions/ion_accuweather.cpp
yawp-0.4.3/README
-- The C compiler identification is GNU 4.8.0
-- The CXX compiler identification is GNU 4.8.0
-- Check for working C compiler: /usr/bin/32/gcc
-- Check for working C compiler: /usr/bin/32/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/32/g++
-- Check for working CXX compiler: /usr/bin/32/g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.8.4 (using /usr/lib/qt/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found.
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
CMake Error at /usr/share/apps/cmake/modules/FindPackageHandleStandardArgs.cmake:198 (MESSAGE):
  Did not find automoc4 (Automoc4Config.cmake, install
  git://anongit.kde.org/automoc).  (missing: AUTOMOC4_EXECUTABLE)
Call Stack (most recent call first):
  /usr/share/apps/cmake/modules/FindAutomoc4.cmake:49 (find_package_handle_standard_args)
  /usr/share/apps/cmake/modules/FindKDE4Internal.cmake:423 (find_package)
  /usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
  CMakeLists.txt:23 (FIND_PACKAGE)


-- Configuring incomplete, errors occurred!
or "cwp":

Code:
Processing cwp

cwp:
Found 98925-cwp-1.6.9.tar.bz2 in /var/cache/sbopkg.
Checking MD5SUM:
  MD5SUM check for 98925-cwp-1.6.9.tar.bz2 ... OK
Building package for cwp...
cwp-1.6.9/
cwp-1.6.9/plasma-cwp.cpp
cwp-1.6.9/plasma-cwp-popup-applet.cpp
cwp-1.6.9/COPYING
cwp-1.6.9/plasma-applet-cwp.desktop
cwp-1.6.9/ChangeLog
cwp-1.6.9/config.ui
cwp-1.6.9/plasma-cwp-data-provider.h
cwp-1.6.9/po/
cwp-1.6.9/po/fr.po
cwp-1.6.9/po/it.po
cwp-1.6.9/po/nb.po
cwp-1.6.9/po/zh_CN.po
cwp-1.6.9/po/el.po
cwp-1.6.9/po/pl.po
cwp-1.6.9/po/ro.po
cwp-1.6.9/po/extract_messages.sh
cwp-1.6.9/po/nl.po
cwp-1.6.9/po/background.list
cwp-1.6.9/po/de.po
cwp-1.6.9/po/br.po
cwp-1.6.9/po/CMakeLists.txt
cwp-1.6.9/po/sr.po
cwp-1.6.9/po/plasma_applet_cwp.pot
cwp-1.6.9/po/create_list_files.sh
cwp-1.6.9/po/ru.po
cwp-1.6.9/po/sr@latin.po
cwp-1.6.9/po/satellite.list
cwp-1.6.9/po/tr.po
cwp-1.6.9/po/hu.po
cwp-1.6.9/po/es.po
cwp-1.6.9/version.h
cwp-1.6.9/plasma-cwp-popup-applet.h
cwp-1.6.9/plasma-cwp-paint-helper.h
cwp-1.6.9/plasma-cwp-paint-helper.cpp
cwp-1.6.9/plasma-cwp-pixmap-dialog.cpp
cwp-1.6.9/README
cwp-1.6.9/plasma-cwp-graphics-widget.h
cwp-1.6.9/plasma-cwp.h
cwp-1.6.9/CMakeLists.txt
cwp-1.6.9/data/
cwp-1.6.9/data/br_weather_com.xml
cwp-1.6.9/data/freemeteo_com_celsius.xml
cwp-1.6.9/data/www_accuweather_com_world_celsius.xml
cwp-1.6.9/data/www_accuweather_com_us_fahrenheit.xml
cwp-1.6.9/data/freemeteo_com_fahrenheit.xml
cwp-1.6.9/data/pogodynka_pl.xml
cwp-1.6.9/data/www_accuweather_com_us_celsius.xml
cwp-1.6.9/data/wetter_com.xml
cwp-1.6.9/data/www_weather_com.xml
cwp-1.6.9/data/satellite_images.xml
cwp-1.6.9/data/www_weather_com.cn.xml
cwp-1.6.9/data/de_weather_com.xml
cwp-1.6.9/data/myforecast_com_celsius.xml
cwp-1.6.9/data/myforecast_com_fahrenheit.xml
cwp-1.6.9/data/www_accuweather_com_world_fahrenheit.xml
cwp-1.6.9/data/ilmeteo_it.xml
cwp-1.6.9/data/espanol_weather_com.xml
cwp-1.6.9/data/uk_weather_com.xml
cwp-1.6.9/data/in_weather_com.xml
cwp-1.6.9/data/fr_weather_com.xml
cwp-1.6.9/data/www_gismeteo_com.xml
cwp-1.6.9/plasma-cwp-pixmap-dialog.h
cwp-1.6.9/config.h
cwp-1.6.9/plasma-cwp-data-provider.cpp
cwp-1.6.9/plasma-cwp-graphics-widget.cpp
cwp-1.6.9/images/
cwp-1.6.9/images/background_rounded_rectangle_black.png
cwp-1.6.9/images/weather-windy.svgz
cwp-1.6.9/images/background_rounded_rectangle_white.png
cwp-1.6.9/images/wind_unknown.svgz
cwp-1.6.9/images/weather-windy.png
cwp-1.6.9/images/background_circle_black.png
cwp-1.6.9/images/wind_arrow.svgz
cwp-1.6.9/images/wind_var.svgz
cwp-1.6.9/images/background_rectangle_white.png
cwp-1.6.9/images/background_rectangle_black.png
cwp-1.6.9/images/background_circle_white.png
cwp-1.6.9/images/background_rounded_rectangle_grey.png
cwp-1.6.9/images/background_circle_grey.png
cwp-1.6.9/images/satellite_image.svgz
cwp-1.6.9/images/background_rectangle_grey.png
cwp-1.6.9/config.cpp
cwp-1.6.9/plasma-cwp-pixmap-list-dialog.h
cwp-1.6.9/plasma-cwp-pixmap-list-dialog.cpp
-- The C compiler identification is GNU 4.8.0
-- The CXX compiler identification is GNU 4.8.0
-- Check for working C compiler: /usr/bin/32/gcc
-- Check for working C compiler: /usr/bin/32/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/32/g++
-- Check for working CXX compiler: /usr/bin/32/g++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for Q_WS_X11
-- Looking for Q_WS_X11 - found
-- Looking for Q_WS_WIN
-- Looking for Q_WS_WIN - not found.
-- Looking for Q_WS_QWS
-- Looking for Q_WS_QWS - not found.
-- Looking for Q_WS_MAC
-- Looking for Q_WS_MAC - not found.
-- Found Qt-Version 4.8.4 (using /usr/lib/qt/bin/qmake)
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so;/usr/lib/libXft.so;/usr/lib/libXau.so;/usr/lib/libXdmcp.so;/usr/lib/libXpm.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found.
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE  
-- Looking for _POSIX_TIMERS
-- Looking for _POSIX_TIMERS - found
CMake Error at /usr/share/apps/cmake/modules/FindPackageHandleStandardArgs.cmake:198 (MESSAGE):
  Did not find automoc4 (Automoc4Config.cmake, install
  git://anongit.kde.org/automoc).  (missing: AUTOMOC4_EXECUTABLE)
Call Stack (most recent call first):
  /usr/share/apps/cmake/modules/FindAutomoc4.cmake:49 (find_package_handle_standard_args)
  /usr/share/apps/cmake/modules/FindKDE4Internal.cmake:423 (find_package)
  /usr/share/cmake-2.8/Modules/FindKDE4.cmake:95 (FIND_PACKAGE)
  CMakeLists.txt:5 (find_package)


-- Configuring incomplete, errors occurred!
or "fontforge" (full log:"http://pastebin.com/4YYn5ftK"):
Code:
fontforge:
Found fontforge_full-20120731-b.tar.bz2 in /var/cache/sbopkg.
Checking MD5SUM:
  MD5SUM check for fontforge_full-20120731-b.tar.bz2 ... OK
Found cidmaps.tgz in /var/cache/sbopkg.
Checking MD5SUM:
  MD5SUM check for cidmaps.tgz ... OK
Found freetype-2.4.10.tar.xz in /var/cache/sbopkg.
Checking MD5SUM:
  MD5SUM check for freetype-2.4.10.tar.xz ... OK
Building package for fontforge...
...
/tmp/ccGvTR07.s: Assembler messages:
/tmp/ccGvTR07.s:742: Error: expecting string instruction after `rep'
/tmp/ccGvTR07.s:745: Error: expecting string instruction after `rep'
make[1]: *** [ustring.lo] Error 1
make[1]: Leaving directory `/tmp/SBo/fontforge-20120731-b/Unicode'
make: *** [libgunicode] Error 2
I'm doing the same thing here:
Code:
. /etc/profile.d/32dev.sh
then "sbopkg", changing Arch to "x86_64" and removing "64" from "LIBDIRSUFFIX". Why these packages have problems but Skype doesn't?



P.S.1 For Skype I didn't have to remove "64" from "LIBDIRSUFFIX" because the option wasn't there. Might the problem be related to this matter?
 
Old 06-05-2013, 09:24 AM   #2
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 6,721

Rep: Reputation: 4084Reputation: 4084Reputation: 4084Reputation: 4084Reputation: 4084Reputation: 4084Reputation: 4084Reputation: 4084Reputation: 4084Reputation: 4084Reputation: 4084
The error for the first two programs would indicate that you do not have the automoc4 package installed (it's in the "L" series).

The error "expecting string instruction after `rep'" can be a sign of a partial upgrade using Slackware-current packages, in particular the binutils package. What is your version of Slackware and what is the version of your installed binutils package? The versions of Qt (4.8.4) and GCC (4.8.0) which are mentioned in the compilation output indicate that you are running Slackware-current.

Eric
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] gcc exits with "libXrender" error when building wmii for Slackware64-current markush Slackware 4 05-06-2012 05:49 AM
Multilib with Slackware64-bit riganta Slackware 2 06-11-2011 01:57 PM
Building WINE on Slackware64 multilib? Lufbery Slackware 12 07-19-2010 07:22 PM
[SOVLED] Problem with Slackware 13 x86_64 ATI driver on 2.6.32.3 using "multilib" ollebanan Slackware 5 01-24-2010 02:02 PM
Shouldn't "Slackware64" Become just "Slackware" and 32-bit Become "Slackware32"? foodown Slackware 6 06-23-2009 02:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 12:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration