-   Slackware (
-   -   Building mythtv- problem with a dependency (

jimtrenton 05-01-2013 10:59 AM

Building mythtv- problem with a dependency

I am using Slackware 14 64bit with, I believe, the latest patches and when trying to build the Mythtv package from Slackbuilds I'm experiencing a problem with building one of the dependencies.
I'm using queue files to select dependencies so I would think that part is ok.

The dependency I'm having problems is perl-http-message and the issue is:

Test Summary Report
t/message-charset.t  (Wstat: 512 Tests: 6 Failed: 0)
  Non-zero exit status: 2
  Parse errors: Bad plan.  You planned 43 tests but ran 6.
Files=15, Tests=517,  0 wallclock secs ( 0.07 usr  0.00 sys +  0.47 cusr  0.03 csys =  0.57 CPU)
Result: FAIL
Failed 1/15 test programs. 0/517 subtests failed.
make: *** [test_dynamic] Error 255

I have tried searching google for a solution but either I'm not searching for the right terms or there is not much about this. I not that familiar with programming and while I understand what it says in the error I have no idea what to do about it.

Please could someone push me in the right direction?


STDOUBT 05-02-2013 03:56 AM

I have not compiled mythtv on Slackware, nor have I used quefiles for installing stuff.
But the first thing I would try is (deep breath) chasing down and installing your dependencies (gasp) manually!
perl-http-message has several dependencies...
(perl-encode-locale, perl-lwp-mediatypes, perl-html-parser(which needs perl-html-tagset), perl-IO-HTML, perl-http-date)
All of this can be found on I'm not sure how "deep" the quefile system goes, so you might want to verify that it's finding all your dependencies.

Sorry if I'm just muddying the waters, but you're probably missing some.
It's also possible that x86_64 versions of some of those dependencies just don't exist. Have you set up your system to be "multi-lib"?

jimtrenton 05-02-2013 10:19 AM


Thanks STOUBT for the advice. I was missing a dependency, perl-IO-HTML to be exact. After adding it the whole thing builds and installs fine.

I guess I will treat this as a lesson and a warning. After years of manually checking dependencies and selecting packages I tried slackbuild queues for the first time. I have to admit that the queue files can make your life easier but putting too much faith into an automation that I have not done myself is BAD. Guess I'll be better off doing the dependency checks manually as before.

Marking as solved.

All times are GMT -5. The time now is 10:26 PM.