LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 06-30-2017, 02:14 PM   #16
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,260

Rep: Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827

If you even get going on software rendering, you'll sort it.
 
Old 06-30-2017, 03:45 PM   #17
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware has beern Main OpSys for decades while testing others to keep up
Posts: 1,427

Rep: Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338
You can get good info on what works in your Huge kernel with modinfo which will include firmware modules. Here's some good info ---
--- Understanding Modinfo ---


nVidia makes the following driver for your card

Code:
Version: 	375.66
Release Date: 	2017.5.4
Operating System: 	Linux 64-bit
So if you load the Huge kernel and install nVidia's 375.66 and use modinfo on that driver you can see all it needs to work. Rebuild your kernel with that, launch in VGA (no modeset) and install 375.66 on the new kernel. I think that covers it.
 
Old 07-02-2017, 10:58 AM   #18
wowbaggerHU
Member
 
Registered: Feb 2017
Location: Hungary
Distribution: Slackware
Posts: 37

Original Poster
Rep: Reputation: Disabled
I did some testing:
  • efifb doesn't work with 4.9.34 for some reason (with 4.4.74 it produces 800x600):
Code:
root@janos-mobile:~# dmesg | fgrep fb                                      
[    0.360060] PCI: MMCONFIG for domain 0000 [bus 00-3f] at [mem 0xf8000000-0xfbffffff] (base 0xf8000000)
[    0.384675] PCI: MMCONFIG for domain 0000 [bus 00-3f] at [mem 0xf8000000-0xfbffffff] (base 0xf8000000)
[    0.385007] PCI: MMCONFIG at [mem 0xf8000000-0xfbffffff] reserved in ACPI motherboard resources
[    0.394168] pci 0000:00:1f.3: reg 0x20: [io  0xefa0-0xefbf]
[    0.449352] system 00:01: [mem 0xf8000000-0xfbffffff] could not be reserved
  • nouveau surprisingly works: I provides fb-console when I compile it in. I haven't checked graphical mode yet.
  • there still is no image with the latest nvidia.ko in the initrd, even though the driver is loaded:
Code:
root@janos-mobile:~# lsmod | grep nvidia                              
nvidia_drm             40973  0
nvidia_modeset        782816  1 nvidia_drm
nvidia              12296880  1 nvidia_modeset
root@janos-mobile:~# dmesg | fgrep nv     
[    0.030200] efi_bgrt: Ignoring BGRT: invalid version 0 (expected 1)
[    1.789549] rtc_cmos 00:02: alarms up to one month, y3k, 114 bytes nvram, hpet irqs
[    2.715483] nvidia: loading out-of-tree module taints kernel.
[    2.715498] nvidia: module license 'NVIDIA' taints kernel.
[    2.723623] nvidia 0000:01:00.0: enabling device (0006 -> 0007)
[    2.723792] nvidia-nvlink: Nvlink Core is being initialized, major device number 247
[    4.148113] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  375.66  Mon May  1 14:33:30 PDT 2017
[    4.149008] [drm] [nvidia-drm] [GPU ID 0x00000100] Loading driver
root@janos-mobile:~# cat /proc/cmdline 
BOOT_IMAGE=dev000:\EFI\Slackware\vmlinuz  root=/dev/rootvg/root-lv vga=normal nomodeset vt.default_utf8=1 ipv6.disable=1 thinkpad-acpi.brightness-enable=1 ro ro
root@janos-mobile:~# modinfo nvidia
filename:       /lib/modules/4.9.34-janos/kernel/drivers/video/nvidia.ko
alias:          char-major-195-*
version:        375.66
supported:      external
license:        NVIDIA
srcversion:     68751AFD79A210CEFFB8758
alias:          pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        
vermagic:       4.9.34-janos SMP mod_unload 
parm:           NVreg_Mobile:int
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_UpdateMemoryTypes:int
parm:           NVreg_InitializeSystemMemoryAllocations:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_MapRegistersEarly:int
parm:           NVreg_RegisterForACPIEvents:int
parm:           NVreg_CheckPCIConfigSpace:int
parm:           NVreg_EnablePCIeGen3:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_TCEBypassMode:int
parm:           NVreg_UseThreadedInterrupts:int
parm:           NVreg_MemoryPoolSize:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_RmMsg:charp
parm:           NVreg_AssignGpus:charp
root@janos-mobile:~#
  • I have tried installing 340.102, but I have hit some compilation/module load errors
 
Old 07-02-2017, 03:18 PM   #19
wowbaggerHU
Member
 
Registered: Feb 2017
Location: Hungary
Distribution: Slackware
Posts: 37

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by wowbaggerHU View Post
I did some testing:
  • I have tried installing 340.102, but I have hit some compilation/module load errors
I eventually managed to compile and load the 340.102 driver version, but still no framebuffer console for me.
Hints for compiling the module:
forum thread
patch for 4.9.x

Code:
root@janos-mobile:~# lsmod | grep nvidia                                   
nvidia              10554909  0
root@janos-mobile:~# modinfo nvidia                                                                  
filename:       /lib/modules/4.9.34-janos/kernel/drivers/video/nvidia.ko
alias:          char-major-195-*
version:        340.102
supported:      external
license:        NVIDIA
alias:          pci:v000010DEd00000E00sv*sd*bc04sc80i00*
alias:          pci:v000010DEd00000AA3sv*sd*bc0Bsc40i00*
alias:          pci:v000010DEd*sv*sd*bc03sc02i00*
alias:          pci:v000010DEd*sv*sd*bc03sc00i00*
depends:        
vermagic:       4.9.34-janos SMP mod_unload 
parm:           NVreg_Mobile:int
parm:           NVreg_ResmanDebugLevel:int
parm:           NVreg_RmLogonRC:int
parm:           NVreg_ModifyDeviceFiles:int
parm:           NVreg_DeviceFileUID:int
parm:           NVreg_DeviceFileGID:int
parm:           NVreg_DeviceFileMode:int
parm:           NVreg_RemapLimit:int
parm:           NVreg_UpdateMemoryTypes:int
parm:           NVreg_InitializeSystemMemoryAllocations:int
parm:           NVreg_UsePageAttributeTable:int
parm:           NVreg_MapRegistersEarly:int
parm:           NVreg_RegisterForACPIEvents:int
parm:           NVreg_CheckPCIConfigSpace:int
parm:           NVreg_EnablePCIeGen3:int
parm:           NVreg_EnableMSI:int
parm:           NVreg_MemoryPoolSize:int
parm:           NVreg_RegistryDwords:charp
parm:           NVreg_RmMsg:charp
parm:           NVreg_AssignGpus:charp                                          
root@janos-mobile:~# dmesg | grep nv
[    0.030170] efi_bgrt: Ignoring BGRT: invalid version 0 (expected 1)
[    1.618544] rtc_cmos 00:02: alarms up to one month, y3k, 114 bytes nvram, hpet irqs
[    2.528627] nvidia: loading out-of-tree module taints kernel.
[    2.528642] nvidia: module license 'NVIDIA' taints kernel.
[    2.535403] nvidia 0000:01:00.0: enabling device (0006 -> 0007)
[    2.535798] [drm] Initialized nvidia-drm 0.0.0 20150116 for 0000:01:00.0 on minor 0
root@janos-mobile:~# cat /proc/cmdline 
BOOT_IMAGE=dev000:\EFI\Slackware\vmlinuz  root=/dev/rootvg/root-lv vga=normal nomodeset vt.default_utf8=1 ipv6.disable=1 thinkpad-acpi.brightness-enable=1 ro ro
root@janos-mobile:~#
 
Old 07-02-2017, 03:52 PM   #20
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,260

Rep: Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827
In the stuff you showed, the module seemed to load, not to barf.

What's 'nomodeset' doing in the kernel command line options? Surely, that needs to come out.
 
Old 07-02-2017, 04:04 PM   #21
wowbaggerHU
Member
 
Registered: Feb 2017
Location: Hungary
Distribution: Slackware
Posts: 37

Original Poster
Rep: Reputation: Disabled
In the end I also tried to switch back to the built-in Intel card, but that did not yield any graphics output either (with my own kernel).
Only with the old distro kernel, and there nouveau worked as well when the NVidia card was enabled.
 
Old 07-02-2017, 04:05 PM   #22
wowbaggerHU
Member
 
Registered: Feb 2017
Location: Hungary
Distribution: Slackware
Posts: 37

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by business_kid View Post
What's 'nomodeset' doing in the kernel command line options? Surely, that needs to come out.
Nomodeset was recommended here when using the old NVidia driver.
 
Old 07-03-2017, 03:11 AM   #23
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,260

Rep: Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827
Nomodeset prevents the kernel module from making settings adjustments. It's the sort of thing that goes in when you have video trouble (e.g. video crashing/going AWOL halfway through the boot). If the system works well, you won't want it.
 
Old 07-03-2017, 08:38 PM   #24
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware has beern Main OpSys for decades while testing others to keep up
Posts: 1,427

Rep: Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338
Quote:
Originally Posted by business_kid View Post
Nomodeset prevents the kernel module from making settings adjustments. It's the sort of thing that goes in when you have video trouble (e.g. video crashing/going AWOL halfway through the boot). If the system works well, you won't want it.
I also mentioned "nomodeset" as my personal preference is to forego higher bootup resolution in favor of graphics and boot simplicity. I see now that for some reason OP really wants higher resolution during bootup, so nomodeset does indeed need to come out.
 
Old 07-04-2017, 04:30 AM   #25
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,260

Rep: Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827
I have the same issue. I don't like high resolution on bootup, as the fonts become tiny. I have a 1600x900 17.3" laptop screen. What I did was to load the Red Hat terminus fonts. They go big - up to 32 points. In rc.local, I have the line
Code:
setfont ter-928n
in the sequence. I don't load the 32 point font as it's too big for the console and causes side issues.

I forget where I got them, but I'm sure you'll find them.
 
Old 07-06-2017, 07:21 AM   #26
wowbaggerHU
Member
 
Registered: Feb 2017
Location: Hungary
Distribution: Slackware
Posts: 37

Original Poster
Rep: Reputation: Disabled
In deed my problem is not that the framebuffer console fonts are tiny or unreadable.
There is nothing displayed at all.

In the meantime I tried removing nomodeset, and recompiled my kernel with the EFI frame buffer disabled, and I got the framebuffer console working with the integrated Intel card.
Switching over to the NVidia discrete card however meant that I lost everything on the bootup console again, plus the graphical GUI did not come up either.
I will have to debug that issue further. Perhaps the X logs may tell me some information...
 
Old 07-06-2017, 05:56 PM   #27
enorbet
Senior Member
 
Registered: Jun 2003
Location: Virginia
Distribution: Slackware has beern Main OpSys for decades while testing others to keep up
Posts: 1,427

Rep: Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338Reputation: 1338
Please forgive me if this question is too basic, but you do realize you don't need a frameuffer to see the bootup process, right? Basic VGA or VESA output is a requirement in all video cards, AFAIK. That's why there is a fundamental option in /etc/lilo.conf for "VGA = normal"

Last edited by enorbet; 07-06-2017 at 05:59 PM.
 
Old 07-07-2017, 03:20 AM   #28
wowbaggerHU
Member
 
Registered: Feb 2017
Location: Hungary
Distribution: Slackware
Posts: 37

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by enorbet View Post
Please forgive me if this question is too basic, but you do realize you don't need a frameuffer to see the bootup process, right? Basic VGA or VESA output is a requirement in all video cards, AFAIK. That's why there is a fundamental option in /etc/lilo.conf for "VGA = normal"
Yes, currently there is no explicit framebuffer device driver compiled into the kernel or as a module.
The intel graphics driver shows the boot process okay, and so does nouveau when the nvidia card is enabled.
With the proprietary nvidia driver however there is nothing shown on the screen.

In my case the "vga = normal" setting is a remnant of the original kernel parameter string from elilo.conf.
 
Old 07-07-2017, 05:09 AM   #29
wowbaggerHU
Member
 
Registered: Feb 2017
Location: Hungary
Distribution: Slackware
Posts: 37

Original Poster
Rep: Reputation: Disabled
I managed to make some further progress:
With the most recent nvidia driver (375.66) I managed to get the graphical GUI working, but still no text console for me.
So during a boot, I am basically flying blind, which is unacceptable for me.

Other part of the picture is (as I mentioned earlier) that intel graphics driver shows the boot process okay, and so does nouveau when the nvidia card is enabled.
 
Old 07-08-2017, 03:43 AM   #30
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,260

Rep: Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827Reputation: 827
Ok, you're making progress.
You have the Intel card singing; the Nvidia card comes once the module is loaded, or when you start X?

Either way, it seems you're down to boot options. You have a couple of ways to go
1. Fix your Nvidia boot arrangement. Those lilo or grub video parameters may matter to you.
2. Boot on the Intel card and switch over to nvidia later.
3. Load the Nvidia module in an initrd and see if that improves things.

I would try them in that order
 
  


Reply

Tags
kernel compile, slackware 14.2, thinkpad


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Make errors when building from kernel source 3.10.7 in seperate output directory duffman Slackware 12 10-14-2014 09:50 PM
Dual display on older LCD Projector and notebook screen surahyo Linux - Laptop and Netbook 2 08-24-2011 09:17 AM
Installing Linux into Notebook with Broken LCD pigsa Linux - Hardware 10 04-15-2011 02:41 AM
VAIO notebook: no HDD light, no LCD display gentoojedi Linux - Laptop and Netbook 2 12-20-2005 11:41 PM
Debian VideoCard/LCD drivers Sony Notebook cwainright Linux - Newbie 1 10-06-2005 09:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 01:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration