-   Slackware (
-   -   building kdebluetooth from Slackbuilds on Slackware64-current (

gtludwig 06-13-2009 11:31 PM

building kdebluetooth from Slackbuilds on Slackware64-current
Hi all,

Hope this helps someone! I first intended this as a call-for-help topic, but since I started to poke around, I began to feel more confidant and thought of making this a how-to. But, in the end I found out I really am at a loss...

I've been trying to get a bluetooth (v2.0) dongle to work in Slackware64-current and since I came across the kdebluetooth project it seemed a good idea to give it a try. From I got the slackbuild script and the source files.

Since I had everything I might need, I untarred the SBo package and copied the source package inside the directory created during the extraction process. A quick peak at kdebluetooth.SlackBuild and all seems well.

As root I fired away

# kdebluetooth.SlackBuild --clean-after
The slackbuild finished and have showed me I have come to a build problem. It stopped because it couldn't find kde-config and asked me if kde was installed correctly. By typing in a console kde and hitting tab key twice, I found out there's a kde4-config instead of a kde-config. So I created a symlink kde-config to kde4-config in /var/bin/, I issued the same build command and it worked, at least until it stops again...

So I went back to the SlackBuild script and changed the arch type from i486 to x86_64.

Again issuing build command and it stops at qt check... Luckily I had needed to build qt4 from SlackBuild when I ran slackware-current. So another check its build script, changing the arch type and building qt4... boy! this takes a little some time!

While it builds, I'm decided to do some maintenance on my laptop, in three easy comands, I am slackware64-current again! Thanks to a great tool called slackpkg (update && install-new && upgrade-all).

Qt4's SlackBuild finished building and it installed OK, but i got this very enligthened error:

checking for Qt... configure: error: Qt (>= Qt 3.2 and < 4.0) (headers and libraries) not found. Please check your installation!
For more details about this problem, look at the end of config.log.

err, hmm... which config.log? slocate gives me a few alternatives, but nothing related to kdebluetooth... any tips?

Thanks in advance!

knudfl 06-14-2009 03:36 AM

'kdebluetooth' is for KDE 3.x / qt3 only.
Hence the line ... " error: Qt (>= Qt 3.2 and < 4.0) "
where ' >= ' means later than (more than) or equal to,
and ' < ' means less than ( 4.0 )

The config.log is found in /tmp/SBo/kdebluetooth-1.0_beta8/
( May disapper with the '--clean-after' option ? ?
.... I never use that option, like to inspect results.)
Alternatively unpack kdebluetooth-1.0_beta8.tar.bz2 and run
./configure to watch the config.log .

May be you can use kdebluetooth4

samac 06-14-2009 04:04 AM

Or you could install the kde3 compatibility packages that are in /extra


gtludwig 06-14-2009 10:35 AM

err..., how do i install kdebluetooth4? got the package, but still haven't figured out how to use cmake...

thanks in advance,

EDIT: Nevermind this! I got it running!

amishtechie 06-27-2009 11:39 AM

May I ask how you got it running? Thank you. I have been having issues compiling kbluetooth4.

gtludwig 06-27-2009 05:59 PM


By "I got it running" I meant cmake, should've been more specific. I have been working too much, haven't had more time to play with kbluetooth...


All times are GMT -5. The time now is 11:54 PM.