-   Slackware (
-   -   Building Galeon from source (

abmhmd 05-10-2002 03:54 PM

Building Galeon from source
I'm trying to build Galeon from source and am now at the end of my wits. ./configure keeps complaining that mozilla not found. I won't bore you with everything I tried but here's where I'm at right now

I built mozilla rc1 from source. I'm using this right now

In I added /opt/gnome/lib/mozilla then did ldconfig

# export MOZILLA_FIVE_HOME=/opt/gnome/bin/mozilla
# export MOZILLA_HOME=/opt/gnome/bin/mozilla

# ./configure --with-mozilla-includes=/opt/gnome/include/mozilla --with-mozilla-libs=/opt/gnome/lib/mozilla --with-mozilla-home=/opt/gnome/bin/mozilla

Here's the tail of the error:

Error on option --get-default-source: unknown option.
Run 'gconftool-1 --help' to see a full list of available command line options.
Using config source for schema installation
Using ${prefix}/etc/gconf/schemas/ as install directory for schema files
checking for gcc version... 3.0.0
checking for PR_Init in -lnspr4... no
checking for PL_strcmp in -lplc4... no
checking for PL_NewHashTable in -lplds4... no
checking for xpcom... yes
checking for gdk_superwin_get_type in -lgtksuperwin... no
checking for gtk_moz_embed_get_type in -lgtkembedmoz... no
checking for Mozilla... no
configure: error:
*** Mozilla is required
*** A package for is available here:

Could someone please point me in the next direction?

Thanks in advance,
Arafat Mohamed

Zopito 05-10-2002 08:25 PM

I would try opening up the configure script with an editor to try and see where it is looking for mozilla. Search for mozilla in the file. About 6 months ago I tried to complile Galeon from source also, but I didn't have gnome, etc, so I built all that from source too. I had to hack it up pretty good and then it still didn't end up working out. If you have gnome, etc working properly you should be able to do it though.

pielud 05-22-2002 03:07 PM

I'm having the EXACT same problem, someone help us

All times are GMT -5. The time now is 06:44 PM.