-   Slackware (
-   -   building from source (

Protex 02-24-2004 04:52 PM

building from source
I was trying to compile gtkam from source. I've done it in the past with slack 9.1 and had no problem. On my new system, I ran into a problem. I wasn't overly concerned with it so I figured i would figure it out some other time.

Now I decided I wanted to update my kernel from 2.6.2-rc3 to 2.6.3. When I try and run make menuconfig i get this error.

bash-2.05b# make menuconfig
HOSTCC scripts/fixdep
In file included from /usr/include/bits/posix1_lim.h:126,
from /usr/include/limits.h:144,
from /usr/lib/gcc-lib/i486-slackware-linux/3.2.3/include/limits.h:132,
from /usr/lib/gcc-lib/i486-slackware-linux/3.2.3/include/syslimits.h:7,
from /usr/lib/gcc-lib/i486-slackware-linux/3.2.3/include/limits.h:11,
from scripts/fixdep.c:105:
/usr/include/bits/local_lim.h:36:26: linux/limits.h: No such file or directory
In file included from /usr/include/netinet/in.h:212,
from scripts/fixdep.c:107:
/usr/include/bits/socket.h:305:24: asm/socket.h: No such file or directory
scripts/fixdep.c: In function `use_config':
scripts/fixdep.c:193: `PATH_MAX' undeclared (first use in this function)
scripts/fixdep.c:193: (Each undeclared identifier is reported only once
scripts/fixdep.c:193: for each function it appears in.)
scripts/fixdep.c:193: warning: unused variable `s'
scripts/fixdep.c: In function `parse_dep_file':
scripts/fixdep.c:289: `PATH_MAX' undeclared (first use in this function)
scripts/fixdep.c:289: warning: unused variable `s'
make[1]: *** [scripts/fixdep] Error 1
make: *** [scripts/fixdep] Error 2

This didn't happen when I built my 2.6.2-rc3 kernel so I went back and tried that too and i get the same error.

The only major stuff i've taken out of the Default Slack install are anything referencing the 2.4.x kernel and I upgraded to the Gnome in slackware-current.

Any ideas?

Tinkster 02-24-2004 06:34 PM

If you actually deleted
you may try to do a
ln -s /usr/src/linux-2.6.x/include/linux/ /usr/include/linux


Protex 02-24-2004 09:26 PM

I figured it out. I had to re-install the kernel headers. I don't understand why I need the 2.4.x headers if I don't use that kernel, but appearently I do. Seems to be working fine now. Thanks for the suggestion.

All times are GMT -5. The time now is 11:57 AM.