-   Slackware (
-   -   building brasero package fails on Slackware 14.1 (

slacksam 11-28-2013 08:47 AM

building brasero package fails on Slackware 14.1
When I try building brasero 2.28.3 (from on Slackware 14.1 (i686), it fails with the following error message:

brasero-project-parse.o: In function `brasero_project_save_audio_project_playlist':
brasero-project-parse.c:(.text+0x1de5): undefined reference to `totem_pl_parser_write_with_title'
collect2: error: ld returned 1 exit status

although "totem_pl_parser" is installed.

Does anybody know, what went wrong?

kikinovak 11-28-2013 10:28 AM

I had no success in building Brasero on 14.1 either. Older versions just won't compile, and newer versions increasingly depend on the unholy GNOME kitchen sink. I'll look further into this, but it looks like Xfburn is the way to go on desktop environments other than KDE.

BTW, totem-pl-parser is an optional dependency that enables Brasero to handle M3U playlists.

willysr 11-28-2013 10:29 AM

actually totem-pl-parser is not needed to build brasero
You have 2 options for now
- remove totem-pl-parser and rebuilt brasero
- use higher version of brasero (2.32.1). I have tested here and it works even with totem-pl-parser from SBo installed, but it does require some tweak..

Please test my changes here

slacksam 11-28-2013 11:42 AM

@willysr: THANK YOU! It works!

First I tried the original slackbuild with version 2.32.1 and it compiled without error, but when I installed and tried to start it, it exited with the error message:

(brasero:30548): GLib-GIO-ERROR **: Settings schema 'org.gnome.brasero.config' is not installed

Trace/breakpoint trap

So I removed totem-pl-parser, compiled version 2.28.3 without error and it worked fine.

Then I installed totem-pl-parser again and tried your new slackbuild for version 2.32.1 and it works GREAT! :)

willysr 11-28-2013 12:25 PM

Yes, that's the same error i got after building the first one without making any tweak, so that's why i need to modify it a little bit and tested it as well on 64 bit VM

Good to know it's working fine :)

All times are GMT -5. The time now is 06:23 PM.