LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices


Reply
  Search this Thread
Old 02-14-2020, 03:27 PM   #1
unInstance
Member
 
Registered: Jan 2020
Distribution: Slackware/FreeBSD
Posts: 54

Rep: Reputation: 8
build profanity with omemo support


My setup:
  • SlackWare 5.4.13
  • libsignal-protocol-c 2.3.2 (built from github)

Problem:
I want to build profanity with omemo support.
I use slackbuild but I give it latest profanity release from github
and it builds if I do not change slackbuild. If I add --enable-omemo, then I can see the following stuff
Code:
checking for libsignal... no
configure: libsignal >= 2.3.2 not found, checking for libsignal 2.3.x...
checking for libsignal... no
configure: error: libsignal-protocol-c is required for OMEMO support

Last edited by unInstance; 02-14-2020 at 03:29 PM.
 
Old 02-14-2020, 04:25 PM   #2
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,217

Rep: Reputation: Disabled
If you want to build it with omemo support, you will have to build yourself a package for libsignal-protocol-c from the source files here as the is no SlackBuilkd for it @ https://slackbuilds.org/. Good luck.
 
Old 02-14-2020, 05:16 PM   #3
unInstance
Member
 
Registered: Jan 2020
Distribution: Slackware/FreeBSD
Posts: 54

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by Didier Spaier View Post
If you want to build it with omemo support, you will have to build yourself a package for libsignal-protocol-c from the source files here as the is no SlackBuilkd for it @ https://slackbuilds.org/. Good luck.
I wrote that i did it. But profanity does not see it.
 
Old 02-14-2020, 05:23 PM   #4
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,217

Rep: Reputation: Disabled
Quote:
Originally Posted by unInstance View Post
I wrote that i did it. But profanity does not see it.
Sorry for my distraction. But then, how/where is it installed? To be sure, please type as root:
updatedb
then provide the output of:
locate libsignal.so
 
Old 02-14-2020, 07:58 PM   #5
crts
Senior Member
 
Registered: Jan 2010
Posts: 1,844

Rep: Reputation: 627Reputation: 627Reputation: 627Reputation: 627Reputation: 627Reputation: 627
Just as an FYI, I created a Slackbuild for libsignal-protocol-c last year when I was playing around with profanity. I did not submit to slackbuilds.org because the version of profanity there does not support OMEMO. Therefore I thought that there is probably no demand for libsignal-protocol-c. Since this came up now I did submit the Slackbuild. With any luck it will show up over the weekend. If you want you can click on "My Slackbuilds" in my signature and download the Slackbuild from there.

I was able to successfully run ./configure with this for profanity version 0.8.1. The build itself fails at a later stage, though, but maybe we can take this one step at a time.

Last edited by crts; 02-14-2020 at 07:59 PM.
 
Old 02-14-2020, 08:25 PM   #6
crts
Senior Member
 
Registered: Jan 2010
Posts: 1,844

Rep: Reputation: 627Reputation: 627Reputation: 627Reputation: 627Reputation: 627Reputation: 627
UPDATE: I have successfully build profanity 0.8.1 with './configure --enable-omemo'. You write that you are using Slackware 5.4.13. I assume that is Slackware current? I have build on Slackware 14.2.

Please let me know if the Slackbuild (libsignal-protocol-c) works for you.
 
Old 02-15-2020, 11:54 AM   #7
unInstance
Member
 
Registered: Jan 2020
Distribution: Slackware/FreeBSD
Posts: 54

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by Didier Spaier View Post
Sorry for my distraction. But then, how/where is it installed? To be sure, please type as root:
updatedb
then provide the output of:
locate libsignal.so
No locate output.
This is what make install installs:
Code:
build [master] % sudo make install
[  1%] Built target protobuf-c
[ 76%] Built target curve25519
[100%] Built target signal-protocol-c
Install the project...
-- Install configuration: ""
-- Up-to-date: /usr/local/include/signal/signal_protocol.h
-- Up-to-date: /usr/local/include/signal/signal_protocol_types.h
-- Up-to-date: /usr/local/include/signal/curve.h
-- Up-to-date: /usr/local/include/signal/hkdf.h
-- Up-to-date: /usr/local/include/signal/ratchet.h
-- Up-to-date: /usr/local/include/signal/protocol.h
-- Up-to-date: /usr/local/include/signal/session_state.h
-- Up-to-date: /usr/local/include/signal/session_record.h
-- Up-to-date: /usr/local/include/signal/session_pre_key.h
-- Up-to-date: /usr/local/include/signal/session_builder.h
-- Up-to-date: /usr/local/include/signal/session_cipher.h
-- Up-to-date: /usr/local/include/signal/key_helper.h
-- Up-to-date: /usr/local/include/signal/sender_key.h
-- Up-to-date: /usr/local/include/signal/sender_key_state.h
-- Up-to-date: /usr/local/include/signal/sender_key_record.h
-- Up-to-date: /usr/local/include/signal/group_session_builder.h
-- Up-to-date: /usr/local/include/signal/group_cipher.h
-- Up-to-date: /usr/local/include/signal/fingerprint.h
-- Up-to-date: /usr/local/include/signal/device_consistency.h
-- Up-to-date: /usr/local/lib/libsignal-protocol-c.a
-- Up-to-date: /usr/local/lib/pkgconfig/libsignal-protocol-c.pc
There is no .so file, what do I miss out on?
 
Old 02-15-2020, 12:01 PM   #8
unInstance
Member
 
Registered: Jan 2020
Distribution: Slackware/FreeBSD
Posts: 54

Original Poster
Rep: Reputation: 8
Quote:
Originally Posted by crts View Post
UPDATE: I have successfully build profanity 0.8.1 with './configure --enable-omemo'. You write that you are using Slackware 5.4.13. I assume that is Slackware current? I have build on Slackware 14.2.

Please let me know if the Slackbuild (libsignal-protocol-c) works for you.
Yes, I am indeed on current. Your slackbuild works! I managed to build latest profanity with omemo support.
Looks like I installed libsignal-protocol-c in a wrong way. I should have specified how I did it.
Thank you. Everything works.

Last edited by unInstance; 02-15-2020 at 12:03 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Automated profanity filter Kenny_Strawn LQ Suggestions & Feedback 21 01-04-2011 03:28 PM
We allow names containing profanity? dugan LQ Suggestions & Feedback 29 10-08-2010 10:45 AM
profanity filter? MartBrooks LQ Suggestions & Feedback 7 06-23-2002 09:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware

All times are GMT -5. The time now is 02:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration