LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-07-2011, 08:48 AM   #1
kikinovak
Senior Member
 
Registered: Jun 2011
Location: Montpezat (South France)
Distribution: Slackware, Slackware64
Posts: 1,410

Rep: Reputation: 630Reputation: 630Reputation: 630Reputation: 630Reputation: 630Reputation: 630
Bug in Slackware64 version of yp-tools


Hi,

The yp-tools have a bug in them in the 64bit-version. In the 32bit-version of Slackware, the various NIS tools are to be found in /usr/lib/yp/. In the 64bit-version, the tools are in /usr/lib64/yp, but some of the tools rely on other tools and try to find them in the wrong place, e. g. /usr/lib/yp.

A workaround is to create a /usr/lib/yp directory on the 64bit version and to symlink the tools from /usr/lib64/yp.

I don't know quite how to report this bug, so I post it here.
 
Click here to see the post LQ members have rated as the most helpful post in this thread.
Old 07-07-2011, 09:36 AM   #2
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,314

Rep: Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816
it could be useful if you post the names of the binaries/libraries that try to look for stuff in /usr/lib instead that /usr/lib64, or just post the full errors without the /ust/lib/yp symlink.
 
Old 07-07-2011, 11:44 PM   #3
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,314

Rep: Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816
I got no NIS where to try this atm, but running this simple sed fixes things for you without the symlink?
Code:
sed -i -e "s|^YPBINDIR.*|YPBINDIR=/usr/lib64/yp|" /usr/lib64/yp/{ypinit,ypxfr_1perday,ypxfr_1perhour,ypxfr_2perday}
(found them with "grep usr\/lib /usr/lib64/yp/*", maybe naive, but should do )

Last edited by ponce; 07-07-2011 at 11:49 PM.
 
Old 07-08-2011, 03:30 AM   #4
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 749

Rep: Reputation: 225Reputation: 225Reputation: 225
Looks like it can be fixed in the build by adding --libexecdir=/usr/lib64 to configure.
 
2 members found this post helpful.
Old 07-08-2011, 04:09 AM   #5
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,314

Rep: Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816
nice wildwizard I modified the slackbuild where it builds ypserv like this
Code:
--- yptools/yptools.SlackBuild.orig	2011-03-08 19:33:25.000000000 +0100
+++ yptools/yptools.SlackBuild	2011-07-08 09:10:19.928969470 +0200
@@ -201,6 +201,7 @@
 make clean
 ./configure \
   --libdir=/usr/lib${LIBDIRSUFFIX} \
+  --libexecdir=/usr/lib${LIBDIRSUFFIX}/yp \
   --enable-fqdn \
   --enable-yppasswd \
   $ARCH-slackware-linux

Last edited by ponce; 07-08-2011 at 04:10 AM.
 
Old 07-08-2011, 04:16 AM   #6
wildwizard
Member
 
Registered: Apr 2009
Location: Oz
Distribution: slackware64-14.0
Posts: 749

Rep: Reputation: 225Reputation: 225Reputation: 225
Quote:
Originally Posted by ponce View Post
nice wildwizard I modified the slackbuild where it builds ypserv like this
NB It is there twice, some bug with the build according to Pat's comments so you have to add it twice.
 
Old 07-08-2011, 04:28 AM   #7
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 2,314

Rep: Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816Reputation: 816
seems like in the second block it's enough: should be used by shell scripts for the YPBINDIR variable and the install location.
 
Old 07-08-2011, 04:56 AM   #8
Alien Bob
Slackware Contributor
 
Registered: Sep 2005
Location: Eindhoven, The Netherlands
Distribution: Slackware
Posts: 5,112

Rep: Reputation: Disabled
I sent this patch to Pat earlier today:

Code:
--- yptools.SlackBuild.orig     2011-07-08 10:04:00.560251285 +0200
+++ yptools.SlackBuild  2011-07-08 10:05:14.891000923 +0200
@@ -190,6 +190,8 @@
 rm -rf ypserv-$YPSERV
 tar xvf $CWD/ypserv-$YPSERV.tar.bz2 || exit 1
 cd ypserv-$YPSERV || exit 1
+# Make it 64-bit clean:
+sed -i -e "s,lib/yp,lib${LIBDIRSUFFIX}/yp,g" configure
 # --with-ndbm=yes
 # Support for this was discontinued upstream
 # --enable-tcp-wrapper
That should fix it.

Eric

Edit: I think ponce's patch is cleaner... I did not see that before I wrote this.

Last edited by Alien Bob; 07-08-2011 at 04:58 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] [Xorg-1.7.5 in Slackware64 -current] still no workie.. Xorg bug? GrapefruiTgirl Slackware 94 07-28-2010 08:23 AM
Slackware64-Current, GnuCash and Linuxdoc-tools kd5zex Slackware 1 02-25-2010 03:27 AM
slackware64-current glibc resolver bug? fancylad Slackware 8 01-31-2010 04:47 PM
slackware64-current : pulseaudio compilation fails, wrong version of libtool pokipoki08 Slackware 2 07-31-2009 11:59 PM
bug in new dvd+rw-tools 5.14 Axion Linux - Software 2 04-02-2004 10:42 PM


All times are GMT -5. The time now is 11:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration