LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware (https://www.linuxquestions.org/questions/slackware-14/)
-   -   Brother MFC-8910DW not responding at all (https://www.linuxquestions.org/questions/slackware-14/brother-mfc-8910dw-not-responding-at-all-4175658921/)

rkelsen 08-10-2019 08:23 AM

Brother MFC-8910DW not responding at all
 
Guys,

I hate posting stupid problems like this one, but it is driving me bonkers.

I've got a Brother MFC-8910DW, approx 7 years old. It is connected to my home router, and works when anyone else in the house prints to it.

I'm running Slackware64-current which was downloaded last Thursday. Everyone else in the house is running Windows.

Anyhow, the printer shows up in the Cups config screen, and seems to accept jobs, but when I walk to the printer, there's nothing there. Zip. Nada. Doughnuts. Nicht blinkenlights. There is no response at all from it.

I can ping it, and log into the web-based management interface without any issues. It just won't print.

The output of lpstat -t is as follows:
Code:

rob@slacktop:~$ lpstat -t
scheduler is running
system default destination: MFC-8910DW
device for MFC-8910DW: lpd://192.168.1.3/binary_p1
MFC-8910DW accepting requests since Sat 10 Aug 2019 10:56:53 PM AEST
printer MFC-8910DW is idle.  enabled since Sat 10 Aug 2019 10:56:53 PM AEST
rob@slacktop:~$

Any ideas?

crts 08-10-2019 08:41 AM

I also have a Brother printer but not the same model as you do. The problem that I face with mine is that I must install Alien Bob's multilib in order to make the printer driver work. Have you tried installing Alien Bob's multilib (and the printer driver, of course) yet?

rkelsen 08-10-2019 08:51 AM

Brother MFC-8910DW not responding at all
 
Thanks. I was just thinking it might be something like that. I'll give it a try.

deNiro 08-10-2019 09:09 AM

Brother usually has excellent compatibility.

If it is only for printing functionality, can't you use the Generic PCL 6 LF Printer with gutenprint driver in cups? (or maybe a pcl5)

I have a brother hl 5450dn, and just like my previous brother it worked with many of the drivers thanks to emulation. I use the Generic PCL 6 LF Printer wide margin - CUPS+Gutenprint v5.2.11 driver (under "make" Generic). But it also worked with some of the HP drivers.

allend 08-10-2019 09:32 AM

With my Brother MFC-J825DW, I need to install the multilib versions of glibc-solibs and cups for printing to work.
Thanks to Alien Bob, this is easy.
glibc-solibs
and
cups-compat32
For further details on installing the driver

hazel 08-10-2019 10:27 AM

In my experience, when cups treats a file as having been printed but the printer has just ignored it, it's always a filter problem. And yes, Brother filters are 32-bit. I didn't need 32-bit cups for mine though, just 32-bit glibc.

wilhe_jo 08-10-2019 04:12 PM

Hi!

I had some issues some weeks before with a different brother printer (MFCL2710DW). Maybe for your printer the procedures are similar...

There's actually some information on the slackware doc wiki.
The problem is, that information is not really valid anymore.

Since for some reason I couldn't figure out how to add/change something in this article and I was sure that I will need this information again I did a very short write up on my external-brain-page: http://www.9mal6.de/home/slackware/b...r-installation

To sum it up:
download the driver package, convert it to txz and install it.
then make a sym-link for the cups-wrapper and filter and you're ready.

I'm not sure if multilib is needed (I have it installed for some software running with wine).
There are actually binaries for arm, x86 and x86_64 in the driver-package...

73

1337_powerslacker 08-10-2019 09:35 PM

I have a Brother HL-2240, and it works perfectly with Slackware-current. I can back up others' assertions that you will definitely need Alien Bob's multilib installed. Hope this helps!

rkelsen 08-11-2019 12:13 AM

Thanks all!

I'll mark this as solved.

Multi-lib with the Brother drivers worked.

Generic PCL driver in pure 64 bit also worked.

Thanks again to all who replied. :)

crts 08-11-2019 09:26 AM

Glad you got it solved. One issue I am facing is that after some updates (not every update) the printer stops working. I just reinstall the multilibs and that solves the problem. Since it is an easy fix I have not yet invested any time to further investigate the problem. I would appreciate it if you could post back if you face a similiar issue. This would help me to assess if there is a problem with multilib or just my system setup. I did the setup right after I switched to Slackware. Chances are that I did something back then that is causing the issue.

rkelsen 08-11-2019 04:42 PM

Brother MFC-8910DW not responding at all
 
You will need to update multi lib whenever one of the 'parent' 64 bit components is updated.

allend 08-12-2019 05:41 AM

@rkelsen
Glad you got it working.

@wilhe_jo
Quote:

There's actually some information on the slackware doc wiki.
The problem is, that information is not really valid anymore.
The stale links have been updated and the text made less version specific. The information is still valid.
Thanks for the report.


All times are GMT -5. The time now is 11:07 PM.