-   Slackware (
-   -   brother fax2840 driver install (

not_bob 07-16-2013 04:55 PM

brother fax2840 driver install
I'm running 13.37 and jes bought a new brother fax2840. I usta man config my old brother hl1440 in LPRng. Then a driver fer CUPS made it a cinch. Even later, in 13.37, it configured itself. Now, with a new fax/printer, no such luck. Slack no longer even has LPRng. There are drivers available in rpm and deb pkgs. I don't know how to install them from those two pkgs. I'm not afraid to get my hands dirty and know how to compile from source, but I haven't a clue about rpm and debs. Anyone care to help and old dumb geezer? ;)


kikinovak 07-16-2013 05:37 PM

I've written a little HOWTO on setting up a Brother HL-2030 printer. Installation is basically the same as your model.

allend 07-16-2013 06:46 PM

This SlackDocs page may help.

not_bob 07-17-2013 07:20 AM

SOLVED: brother fax2840 driver install
OMG!! It can't be this easy.

After reading all that info, I did two simple steps. I ran the rpm2txz command (with all those options) on the 2 rpm pkgs and then installed the txz pkgs (lpr 1st). Voilą! When I went back to the cups webpage, there was my printer. I printed the cups webpage from my browser and the printer worked flawlessly. I LOVE Slackware. I love Brother printers. Allend, ....well, I like you a whole bunch. Thank you for the that excellent link. Kiki, I thank you, too, even if I don't really speak French. I've always been a bit wary of that rpm2foo command, suspicious it didn't really perform as advertised. Silly me. Now I know better.

Again, thank you all. ;)

All times are GMT -5. The time now is 04:15 AM.