-   Slackware (
-   -   broken xfce desktop after upgrade to slackware-current (

Gustav 4 08-05-2009 03:58 AM

broken xfce desktop after upgrade to slackware-current
Hello forum

I need a hand in getting my desktop back after an upgrade to slackware-current using slackpkg.

I had xfce running quite well on slackware-12, but after uprading to slackware-current something somewhere broke. Now, there is no desktop background with the little rodent in the middle, and the xfce menu icon is missing from the bottom tool bar, and right-clicking in the desktop background gives no response, (where there used to be a short cut to the xfce menu).

So, there is only half of xfce on my screen.

What do I need to do to remedy this, and prevent it form happening again after the next system upgrade?

kindest regards,


metrofox 08-05-2009 05:56 AM

Did you install all the packages? Maybe you forgot one? Check the MD5 of all the xfce packages, remove the configuration directory :)

XGizzmo 08-05-2009 07:58 AM

How did you upgrade? Did you do a slackpkg clean-system to remove all old packages? Did you do a slackpkg install-new to install all new packages? Did you merge all of the *.new files in /etc?

Gustav 4 08-05-2009 08:28 AM


Thanks for the replies!

This is a run down of how I updated to Slackware-current:

# slackpkg update
# slackpkg install-new
# slackpkg upgrade-all
(Due to the recent switch from TGZ to TXZ packages I ran this again):
# slackpkg upgrade-all

But I did not run this, as Xgizmo mentioned:
# slackpkg clean-system

And I still havedn't looked for *.new files in /etc but i will when I get a chance later tonight.

thanks again!


Gustav 4 08-05-2009 05:17 PM

I just tried slackpkg clean-system and although there were a number of packages removed, startx hadn't changed. It seems as if the system is botched.

Short of reinstalling Slackware 12.2 once again is there anything I could do to restored this upgrade to Slackware-current?

Gustav 4

mRgOBLIN 08-05-2009 05:58 PM

Try creating a new user profile to see if the problem is there for them too.

May be that your old profile has some incompatible settings there.

forum1793 08-05-2009 07:40 PM

Also consider your video and startx options.

What is your video hardware?
Are you using proprietary and if so did you reinstall after upgrade?

Gustav 4 08-06-2009 04:56 AM

Thanks for all your helpful hints!

I logged in as root and launched startx and xfce started without a hitch. So, there IS a profile configuration problem some where with my current user.

I closed the X window system and logged out as root. I logged in as my personal user, and launched xfce. Agian, no start up xfce splash screen, and a session chooser on a black background. BUT! instead of using the Default session as I have always down, I choose a new session, and xfce starts with a real desktop interface, and the right click also brings up a usable menu.

So, how do I get xfce to behave normally with my current profile?


Eternal_Newbie 08-06-2009 03:20 PM

As I mentioned in another similar thread, XFCE 4.6 has changed settings again and the XFCE settings importer is somewhat inadequate. It's really easier to back up or delete anything XFCE related under ~/.config/ and ~/.cache/ and start with a clean profile.

metrofox 08-06-2009 06:52 PM

Today Pat put(it sounds good :D Pat put LOL) the XFCE 4.6.1 package ;)

All times are GMT -5. The time now is 10:00 PM.