-   Slackware (
-   -   Broke LILO during upgrade to 12.2 >< (

27thSunshine 12-15-2008 09:11 AM

Broke LILO during upgrade to 12.2 ><
Well, due to awesome timing, I managed to download and install Slackware about 36 hours before the release of 12.2. So, naturally, it was time for an upgrade! Figured it'd be a good learning experience.
As far as I know, for the most part, things went pretty well. I might still need to mess with some things I didn't quite get to earlier, but before I do the minor stuff I have a considerably bigger problem -- LILO.
I was going through upgrade.txt, and I had figured that I'd properly restarted LILO and all, but I guess not 'cause once I completely rebooted my computer there were errors abound! And, in my new-ness, I'm a little stuck on how to fix 'em.

Usually when problems like this happen I just turn to the re-installation option. So I navigated my way to the new LILO package using the given system-maintenance-prompt, but when I tried reinstalling it I got a "read only" error. I tried checking the .conf to see if I could spot a problem, but it keeps saying "too many sessions open in /var/tmp" so I can't use vi. When I try /var/tmp ls -l, there are only 3 things listed - alsa-something, usr-something [well, my name, not actually usr] and root-something. Then I finally realized that the error message gave me a suggestion, that I unfortunately cannot remember in full but can go check on if it'd help, it had something to do with using a different superblock [8193], but even that kept failing and it just kept telling me the same thing - try [whatever command] -b 8193.

I'm a little spent on ideas and don't have much left to google, far as I can tell I'm the only one who's messed up in this manner [I'll be sure to do better for 12.3!], does anyone have any ideas on what I should try next? At the moment I'm using an Ubuntu Live CD and rebooting without when I find something to do try.

Sorry for the essay, thanks so much!

gegechris99 12-15-2008 09:16 AM


Which kernel do you use?

If you used a generic kernel, you needed to create an initrd.gz image by following the instructions in the README.initrd file available on first CD.

If you did run the mkinitrd command, please post it so we can detect any syntax error. It is recommended to use the full option (see example at end of paragraph 3 in the README.initrd file)

gegechris99 12-15-2008 09:21 AM


I was going through upgrade.txt, and I had figured that I'd properly restarted LILO and all, but I guess not 'cause once I completely rebooted my computer there were errors abound! And, in my new-ness, I'm a little stuck on how to fix 'em.
I forgot to ask. Did you upgrade from Slackware 12.1 or from an earlier version. The UPDATE.TXT instructions are only valid for an upgrade from 12.1 to 12.2.

Also did you went through all the 8 steps in UPDATE.TXT or did you reboot after step 6?

27thSunshine 12-15-2008 05:15 PM

Ah, well.

I was updating from 12.1 -> 12.2 as per recommendation, and I went through all the steps [number 7 was not applicable, but I re-read it just to make sure] before rebooting, to no avail.

I hadn't switched to the generic kernel yet...still with the huge kernel, was thinking on going one step at a time, upgrade then switch.

Wow, I was really offbase, I apologize. I tried booting into slack once more, and wrote down the main error:

checking root file system:
fsck 1.41.3
/sbin/e2fsck: no such file or directory while trying to open /dev/sda2
The superblock could not be read [long paragraph of text], try an alternative superblock:
e2fsck -b 8183 <device>

And when I run lilo -v...

Warning: lilo should be owned by root
Warning: LBA32 addressing assumed
Fatal: raid_setup: stat("/dev/sda")

Does that ring a bell or make sense to anybody..?

gegechris99 12-16-2008 03:16 AM

Could you post those files?


Another question: Is your HD located on a RAID storage system?

27thSunshine 12-16-2008 03:29 AM



# LILO configuration file
# generated by 'liloconfig'
# Start LILO global section
# Append any additional kernel parameters:
append=" vt.default_utf8=0"
boot = /dev/sda

# Boot BMP Image.
# Bitmap in BMP format: 640x480x8
  bitmap = /boot/slack.bmp
# Menu colors (foreground, background, shadow, highlighted
# foreground, highlighted background, highlighted shadow):
  bmp-colors = 255,0,255,0,255,0
# Location of the option table: location x, location y, number of
# columns, lines per column (max 15), "spill" (this is how many
# entries must be in the first column before the next begins to
# be used.  We don't specify it here, as there's just one column.
  bmp-table = 60,6,1,16
# Timer location x, timer location y, foreground color,
# background color, shadow color.
  bmp-timer = 65,27,0,255

# Standard menu.
# Or, you can comment out the bitmap menu above and
# use a boot message with the standard menu:
#message = /boot/boot_message.txt

# Wait until the timeout to boot (if commented out, boot the
# first entry immediately):
# Timeout before the first entry boots.
# This is given in tenths of a second, so 600 for every minute:
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
  root = /dev/sda2
  label = Linux
# Linux bootable partition config ends


/dev/sda1        swap            swap        defaults        0  0
/dev/sda2        /                ext3        defaults        1  1
#/dev/cdrom      /mnt/cdrom      auto        noauto,owner,ro  0  0
/dev/fd0        /mnt/floppy      auto        noauto,owner    0  0
devpts          /dev/pts        devpts      gid=5,mode=620  0  0
proc            /proc            proc        defaults        0  0
tmpfs            /dev/shm        tmpfs      defaults        0  0

Also, I'm sorry for being such a lame new kid, but I have NO IDEA about RAID or any of that ><

gegechris99 12-16-2008 03:47 AM

Your configuration seems OK. Where does the symlink /boot/vmlinuz points to?

It should be your huge kernel.

gegechris99 12-16-2008 03:51 AM

Sorry I'm not a home so I can not check on my system but it seems (after some googling) that the following line is missing from your lilo.conf just after line "boot = /dev/sda":



27thSunshine 12-16-2008 03:57 AM

Hmm..any idea on how to add that in there?
I can't make any changes to anything from Ubuntu, and when I try editing with vi I get the "too many sessions open in /tmp/var" error, but when I check /tmp/var with ls, only 3 things come up and 2 are readonly [and seemingly very important, too], the third I haven't tried deleting because its an alsa thing which is potentially important, plus I don't even know if closing it [however that'd be done] would help...

Thanks so much for your time, by the way~

gegechris99 12-16-2008 04:57 AM

You can boot with the first CD of Slackware 12.2.

After boot, you have to move to your installed 12.2 environment using the following commands:


mount /dev/sda2 /mnt
chroot /mnt
vi /etc/lilo.conf
<make the change,save and exit>

and then remove CD and reboot.

brianL 12-16-2008 06:33 AM


Warning: LBA32 addressing assumed
That can be fixed by adding lba32 in the global options (I've put it just before all the framebuffer options), other than that I can't see anything wrong with your lilo.conf.

27thSunshine 12-16-2008 08:17 AM

Hey guys, thanks for all your help so far.
I fixed lilo.conf, added the new lines, but I guess that wasn't the problem. It's still complaining about a bad superblock, and the suggested one [8193] doesn't work either. I've tried e2fsck /dev/sda2, but it doesn't work, not even with -f, nor does mke2fs -n /dev/sda2...any ideas on how to fix what seems to be the real problem?

27thSunshine 12-16-2008 08:17 AM

Oops, double ><

gegechris99 12-16-2008 09:29 AM

1) After editing lilo.conf, did your run


What was the output?

2) Also, please check symlink /boot/vmlinuz. Where does it point to?

3) Regarding


Warning: lilo should be owned by root
check ownership of /sbin/lilo.

brianL 12-16-2008 10:09 AM

I think you should always run lilo as root.

All times are GMT -5. The time now is 05:15 AM.