-   Slackware (
-   -   Broadcom wifi under Slackware 11 (

person132 10-05-2006 04:58 PM

Broadcom wifi under Slackware 11
I just finished installing Slackware 11 on my Toshiba laptop, and I need to get my Belkin wireless card working. From previous experience (10.2), I know it is a Broadcom chipset, and I was pleased to see it detected at my first bootup (iwconfig prints out an entry). However, when I attempt to do anything with the wireless card (say, scan for networks), I get an error message. For example,


#iwlist scan

eth1: Interface doesn't support scanning: No such device

Any tips?

stitchman 10-05-2006 06:00 PM

the syntax is more like:

iwlist wlan0 scan
you need to specify the device :)

person132 10-05-2006 09:20 PM

Complete outputs:



# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11b/g  ESSID:off/any  Nickname:"DoorstopOfDoom"
          Mode:Managed  Access Point: Invalid  Bit Rate=1 Mb/s
          RTS thr:off  Fragment thr:off
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

sit0      no wireless extensions.


# iwlist scan
lo        Interface doesn't support scanning.
eth0      Interface doesn't support scanning.
eth1      Interface doesn't support scanning : No such device
sit0      Interface doesn't support scanning.

The power light on my wireless card doesn't come on.

What do I need to do to get this driver working?

stitchman 10-05-2006 10:21 PM

Ok i am not sure this will positively work but try adding this to /etc/rc.d/rc.inet1.conf


# Config information for eth1:                                               

then issue this command:


/etc/rc.d/rc.inet1 eth1_restart
EDIT: And by "i am not sure this will positively work" i mean, i also have a broadcom chipset and this is how i get it to work on my laptop :)

zetabill 10-06-2006 12:33 AM

I think we're assuming that you're using the included bcm43xx drivers that come with the huge26.s kernel. Although I checked here and it says you're using ndiswrapper. So which one?

EDIT: In that first link to your other thread you said that a problem was solved with ACPI and the card. Don't forget that, too... ;)

If you're using ndiswrapper then you have to blacklist the bcm43xx module. Personally I had problems with udev randomly loading it even when it was blacklisted so I just deleted it entirely from /lib/modules. That was before I noticed that huge26.s was compiled with a 4k stack which ndiswrapper complains about mercilessly so I ultimately ended up rectifying the problem entirely by compiling a new kernel myself. Anyway, the conflict between bcm43xx and ndiswrapper+bcmwl5 will cause intense nausea so make sure that situation isn't going on.

If you're gonna use bcm43xx then that might be good. Check lspci and see if in fact that your card uses the 4306 chipset. If so, then don't bother with ndiswrapper at all and use fwcutter to get the firmware and use the bcm43xx that comes with huge26.s. Check here for instructions on how to use fwcutter and for a link to get it if you don't already have it.

Good luck and let us know how you do.

person132 10-06-2006 02:43 PM

Thanks for the help.

As to my previous problems, I was using ndiswrapper because I was using the default Slackware 10.2 kernel, which, of course, is of the 2.4 series. Now that I have upgraded to Slackware 11 (with a completely new install) and the 2.6 kernel, I'd like to use the native drivers, because ndiswrapper forced me to turn off ACPI, which is useful for a laptop.

lspci shows my card's chipset as 4318, which, according to the bcm43xx website, is supported (with some issues). I downloaded the source (I think) to the fwcutter ultility, but when I run make, it gives an enormous string of errors culminating in

make: *** [fwcutter.o] Error 1
Is there something I'm missing?

Nylex 10-06-2006 02:58 PM

You need to post the stuff that's above that "Error 1" message.

zetabill 10-06-2006 03:32 PM


Originally Posted by person132
lspci shows my card's chipset as 4318, which, according to the bcm43xx website, is supported (with some issues).

Ouch... and issues they are, as well.

I use the 4318 as well. The bcm43xx drivers are iffy for 4318 and I don't use them. It's what kept me with ndiswrapper. I'm not sure if they've gotten better but I could only use the B network as G wasn't supported and if I left the room where the router was then it would drop the network. Not exactly what I paid for...

It might be a tossup for you... ndiswrapper and no ACPI or bcm43xx and slow speed/no range. I can't make that decision for you.

I can offer, though, that you should certainly check your kernel if you do ndiswrapper. If you grep your kernel config file you should find

zcat /proc/config.gz | grep 4KSTACKS
# CONFIG_4KSTACKS is not set

If you have anything else then your driver will complain mercilessly and fail on you. You can check the -smp- kernel Pat compiled to make sure that you have a bigger stack but if not you'll need to compile a new kernel. Not necessarily a brand new kernel, but you'll need to uncheck that option.

And remember to disable the bcm43xx driver if you find yourself going the ndiswrapper route.

Let us know.

EDIT: Anyway... as for the fwcutter error... need more info. And after that I'm not an expert. Also the config file that Pat made for your kernel is in /boot.

person132 10-07-2006 09:45 PM

All my errors were caused by an original error during the installation (compilation doesn't go very far without glibc). After several reinstalls (it's amazing how easy it is to mess them up), I'm back to my 2.6.17 system. I've chosen the ndiswrapper route (I'll worry about ACPI later). I have ndiswrapper installed but not working. My only question:

How do I deactivate the bcm43xx driver?

Thanks for all your help.

zetabill 10-07-2006 10:08 PM

Like I said earlier, I tried adding it to the /etc/modprobe.d/blacklist file which stopped it from loading on boot unless the card was plugged in. You might want to stick around a bit to see if someone has a solution to stop udev from loading the damn thing. I personally deleted the whole /lib/modules/ directory which solved my problems and I got no errors, either. That's kind of a cheap way out of it but it certainly worked for me.

Hopefully someone could help you with udev leaving it alone and letting blacklist do its job. You could at least move that directory for now in case you don't want it completely gone. If you decide to move it out of lib then make sure you modprobe -r first so you're not performing surgery on an attentive patient...

EDIT: Compiling a new kernel is also a good idea, you know. You can make oldconfig then make menuconfig and navigate to device drivers > network device support > wireless lan and remove the bcm43xx module, save, and recompile.

EDIT2: Also make sure you don't have 4kstack enabled. It's under kernel hacking.

person132 10-07-2006 10:37 PM

Success, I think. The ndiswrapper compilation complained about 4KB stacks, but all evidence (loading the /boot/config file and examinig it, and make oldconfig -> make menuconfig) points to them being disabled. Of course, what really matters is that everything installed correctly (I blacklisted bcm43xx, and a reboot and lsmod showed itas not loaded). There were no problems with ACPI (my last experience was with a 2.4 kernel with ACPI built in. This was a 2.6 with ACPI modules). The only problem is that the transfer speed is not the maximum of 54M. Is that because I am far from the access point?

Thank you again for your help.

zetabill 10-07-2006 10:38 PM

How far from the access point are you and what channel are you using?

EDIT: And what is your transfer speed?

All times are GMT -5. The time now is 06:55 PM.