-   Slackware (
-   -   Broadcom wifi + slackware 14 (

odm4286 10-02-2012 08:32 PM

Broadcom wifi + slackware 14
Hello everyone, linux mint user here switching over to slack. So first I installed slack 13.37 and went through various tutorials in an attempt to get wifi working with no luck. As I was searching slackware 14 was released and I figured that the driver I need may be included in the updated linux kernal, no luck again.

I've tried googling but can't seem to find any information on getting this to work on version 14. Can I just use the slackbuilds for 13.37 or would that be incompatible? Thanks in advance.

TobiSGD 10-02-2012 08:53 PM

Slackbuilds for 14 have been released already, so you can use those. posting this from a laptop with a fresh install of 14 connected with Broadcom 4315 wireless.

frankbell 10-02-2012 08:55 PM

I struggled with Broadcom on Slackware--Current. I'm still on Current, which is up to 14.0, and it's still working.

LQ helped me here. The thread about it may help you.

You need the appropriate firmware, the fwcutter, and the appropriate driver. You can find them all at Slackbuilds.

You can learn useful background here:

ReaperX7 10-02-2012 08:57 PM

You'll need the b43-firmware and b43-fwcutter packages, however to be sure run "lspci" from a terminal and post which card and revision you have as drivers will vary somewhat.

Didier Spaier 10-03-2012 01:38 AM

Use the following command to confirm the vendor and device ID as well as kernel driver in use and modules which can be used:

lspci -nnk|grep -A3 Net

DrCube 10-03-2012 09:07 AM

Funny you should ask, I did this on a fresh install of 14.0 on my Dell Inspiron 1545 just this morning. My wireless card is BCM4312.

I originally had trouble with the 13.37 package, but this morning it worked fine with the slackbuild for 14.0. I didn't need the fwcutter or b43, broadcom-sta was the only package I needed. Check these pages here:

(see next post)

Make sure you use the broadcom-sta slackbuild for 14.0 and include the following lines in your /etc/modprobe.d/blacklist.conf:

blacklist b43
blacklist b43legacy
blacklist bcma
blacklist ssb

Install wicd, reboot and you should be able to connect to wireless from there. At least, it was successful for me and my Dell 1545. Good luck and happy slacking. :)

---------- Post added 10-03-12 at 08:07 AM ----------

Okay, so I guess since that was my first post here, I couldn't post links. Here's another try:

odm4286 10-03-2012 09:13 AM

Thanks for the quick replies guys, im at work atm so I cannot run lspci but im sure im using a BCM4315. Also I was able to run slackbuilds and attempted to modprobe wl but I keep getting a message with something along the lines of "unable to insert wl". Maybe after I blacklist other modules it will work?

TobiSGD 10-03-2012 09:30 AM

I also have the 4315, I just installed b43-fwcutter and b43-firmware and since then it works flawlessly.

odm4286 10-03-2012 07:09 PM


Originally Posted by Didier Spaier (Post 4795703)
Use the following command to confirm the vendor and device ID as well as kernel driver in use and modules which can be used:

lspci -nnk|grep -A3 Net

Ok here network controller [0280]: broadcom corporation bcm4312 802.11b/g lp-phy [14e4:4315] (rev 01) subsystem: hewlett-packard company u98z049.00 wireless mini pcie card [103c:1507]

I went through the whole slackbuilds thing and installed everything(i hope) but still no luck. Do I need to install wcid?

TobiSGD 10-03-2012 07:37 PM

To manage your network connection you can either do it the manual way with editing rc.inet1, or you can use GUI tools like wicd (has also a text based client) or the NetworkManager (can be configured using the commandline or the NetworkManager applet). NetworkManager is installed by default.

odm4286 10-03-2012 07:52 PM

sorry to be a pain but can someone post some troubleshooting tips? I reinstalled the software from slackbuilds and logged in as root this time rather then using su just to be sure things went as they should. I also made sure I followed the instructions found here regarding blacklisting. Sorry for being a newb but the only other information I have is that iwconfig shows the following : lo no wireless extensions
eth0 no wireless extensions

also as i said before when I try to modprobe wl I get the following message "could not insert 'wl': Exec format error" and lastly im using the bcm4312 chipset

thanks a TON

ReaperX7 10-03-2012 08:42 PM

If you use the b43-firmware and b43-fwcutter packages do not blacklist anything.

Habitual 10-03-2012 09:22 PM

I just went through all the same routine over here... hope it helps.

the b4312 card/chip will work with stock
I used the wicd package also.

See for steps.

Another post about wifi/b43xx that I used to get it working with help from LQ post replies.

I hope it helps you also.

hakan56 10-04-2012 07:31 AM

I have the same card as you, and it works for me with the broadcom-sta driver, I use networkmanager myself but wicd also works as "DrCube" verifies.

I think that either your "blacklist" doesn't work or your build of "broadcom-sta" didn't succed

First try too remove the modules by..
# modprobe -r b43 b43legacy bcma ssb
..and then...
# modprobe wl
..if that works..

bash-4.2# lsmod |grep wl
wl                  2535094  0
lib80211                3877  2 wl,lib80211_crypt_tkip

If that doesn't work try to rebuild broadcom-sta.
Unfortunately since I'm running slackware64 my wl-module will not help you.


Habitual 10-04-2012 07:39 AM



I didn't mean to hijack someone's thread, I merely wanted to offer assistance for the OP via some links/posts that I found useful for the/my b43(21) chip/card.

Have a Great Day!

All times are GMT -5. The time now is 08:01 PM.