-   Slackware (
-   -   Broadcom Trouble Dell 1545n Slackware Current (

frankbell 01-27-2012 08:39 PM

Broadcom Trouble Dell 1545n Slackware Current
I'm having trouble getting my Broadcom wireless working in my Dell 1545n laptop with Slackware Current. Wired works fine.

I have tried the broadcom-sta and b43-fwcutter from Slackbuilds twice with no luck. I did follow the instructions to update the /etc/modprobe.d/b43-blacklist.conf file as described on the Slackbuilds broadcom-sta page.

Here is the output of uname -a:


Linux hammerhead #2 SMP Sat May 21 23:13:29 CDT 2011 i686 Genuine Intel(R) CPU            585  @ 2.16GHz GenuineIntel GNU/Linux
and of lspci -vnn | grep 14e4 per the instructions at LinuxWireless.


0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
The system threw no error messages throughout the process.

I did get the Broadcom working perfectly on my Dell Mini 9 with Salix following the instructions from the Salix website. That machine seems to have a similar chipset. Here's the info from the Mini 9:


03:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
        Subsystem: Broadcom Corporation Device [14e4:04b5]

Any suggestions would be most welcome.

Edit: The Salix box is running v. 13.37.

ukiuki 01-28-2012 01:39 AM

You may just need the firmware, i had similar problem once and all was missing was the firmware.
Try this:


frankbell 01-28-2012 08:42 PM

Thanks. The Slackbuilds broadcom-sta claimed to have the firmware but maybe it didn't like me.

The omattos link doesn't seem to like me either, at least not right now.

I'll probably won't be able to dig into this again until Tuesday. I'll certainly let you know what happens.

doomey 01-29-2012 05:34 PM

you were not very clear: did you install b43-fwcutter and b43-firmware (in that order) from slackbuilds?
try doing that and don't forget to remove the blacklisting of b43 and ssb from blacklist.conf.

or you could try donwloading the latest sta driver (be careful of arch, 32 or 64), unpacking it to some directory, cd there, and then run:

make clean && make && make install && depmod -a
if you use the sta driver, then leave b43 and ssb blacklisted.

and don't forget to restart.

frankbell 01-29-2012 08:55 PM


Originally Posted by doomey (Post 4587736)
you were not very clear: did you install b43-fwcutter and b43-firmware (in that order) from slackbuilds?

As described, I did the broadcom-sta, then the b43-fwcutter. I did it once befire, then, after consulting with a member of my LUG, tried it again. I figured it was time to seek advice from a wider circle.

I'll try the bw43-firmware a whirl on Tuesday.


frankbell 01-31-2012 08:27 PM

Update--real life caught up with me. I'll update when I escape from it.

onebuck 02-01-2012 10:40 AM

Member response

One note for 'sta', sometimes the device is recognized as a eth device instead of wlan. Your device may be assigned eth1 or another eth(depend on devices in system).

Look at Linux-Wireless which shows for your '14e4:4315' Broadcom 4312 will use either the 'sta' or 'b43' driver but you will need the firmware.

device list contains list of manufacture supported wireless.

Maybe this old post will help: Slackware 13.0 RC2 X86_64 Broadcom bcm4312 problems


frankbell 02-05-2012 08:05 PM

Thank you all for your responses.

I finally got it working using the STA driver during the interminable garbage in between the actual play of the game in the US NFL Super Bowl.

I took a methodical approach, changing one thing at a time.

After making each change, I would reboot, test ifconfig and iwconfig, then make another change.

Once the wlan0 appeared in iwconfig, it gave me


Operation not possible due to RF-kill
in response to


ifconfig wlan0 up
I looked that up and found it meant that the hardware switch (on this computer, the F3 key) was toggled off. I toggled it on and bingo! wireless.

Once again, thank you all for your help.

All times are GMT -5. The time now is 04:04 AM.